aboutsummaryrefslogtreecommitdiff
path: root/misc/p5-File-CounterFile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-18 18:21:17 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-18 18:21:17 +0000
commite269e8e2600803c3dd44319dc45254941c5f795b (patch)
tree0e4f7a069f9c7afcb60bf751638b70f142d37f9b /misc/p5-File-CounterFile
parent5fa18a7717de599811941de3fa7c8afd0d8b2a04 (diff)
downloadports-e269e8e2600803c3dd44319dc45254941c5f795b.tar.gz
ports-e269e8e2600803c3dd44319dc45254941c5f795b.zip
Notes
Diffstat (limited to 'misc/p5-File-CounterFile')
-rw-r--r--misc/p5-File-CounterFile/Makefile13
-rw-r--r--misc/p5-File-CounterFile/distinfo2
-rw-r--r--misc/p5-File-CounterFile/files/patch-CounterFile.pm10
3 files changed, 17 insertions, 8 deletions
diff --git a/misc/p5-File-CounterFile/Makefile b/misc/p5-File-CounterFile/Makefile
index f4f81f7f2709..4e0d811df6d5 100644
--- a/misc/p5-File-CounterFile/Makefile
+++ b/misc/p5-File-CounterFile/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= File-CounterFile
-PORTVERSION= 1.02
+PORTVERSION= 1.03
CATEGORIES= misc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= File
@@ -19,4 +19,13 @@ PERL_CONFIGURE= yes
MAN3= File::CounterFile.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+post-configure:
+ cd ${WRKSRC}; \
+ ${PERL} -pi -e 's|(.*Fcntl.*) SEEK_SET(.*)|\1\2\nuse POSIX qw(SEEK_SET);|;' \
+ CounterFile.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/misc/p5-File-CounterFile/distinfo b/misc/p5-File-CounterFile/distinfo
index 8dae831ac902..b4e3daba0d60 100644
--- a/misc/p5-File-CounterFile/distinfo
+++ b/misc/p5-File-CounterFile/distinfo
@@ -1 +1 @@
-MD5 (File-CounterFile-1.02.tar.gz) = 5d60cbf081a9b23b55ac5db429cc4dfc
+MD5 (File-CounterFile-1.03.tar.gz) = 1b81c7ae95fa6df289d8f11b17b76064
diff --git a/misc/p5-File-CounterFile/files/patch-CounterFile.pm b/misc/p5-File-CounterFile/files/patch-CounterFile.pm
index dbea78491478..f31706ef9c33 100644
--- a/misc/p5-File-CounterFile/files/patch-CounterFile.pm
+++ b/misc/p5-File-CounterFile/files/patch-CounterFile.pm
@@ -1,5 +1,5 @@
---- CounterFile.pm.orig Tue Jul 30 23:45:06 2002
-+++ CounterFile.pm Sun Jul 6 08:08:46 2003
+--- CounterFile.pm.orig Sun Jan 18 13:31:18 2004
++++ CounterFile.pm Sun Jan 18 13:31:54 2004
@@ -19,7 +19,7 @@
$DEFAULT_INITIAL = 0; # default initial counter value
@@ -9,12 +9,12 @@
# Experimental overloading.
use overload ('++' => \&inc,
-@@ -205,7 +205,7 @@
+@@ -210,7 +210,7 @@
If the file name does not start with "/" or ".", then it is
interpreted as a file relative to C<$File::CounterFile::DEFAULT_DIR>.
The default value for this variable is initialized from the
--environment variable C<TMPDIR>, or F</usr/tmp> is no environment
-+environment variable C<TMPDIR>, or F</var/tmp> is no environment
+-environment variable C<TMPDIR>, or F</usr/tmp> if no environment
++environment variable C<TMPDIR>, or F</var/tmp> if no environment
variable is defined. You may want to assign a different value to this
variable before creating counters.