aboutsummaryrefslogtreecommitdiff
path: root/misc/p5-Geo-Coder-PlaceFinder
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-20 06:47:34 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-20 06:47:34 +0000
commit5c3cefb426b4cd20e34b499b0d285043edece9ab (patch)
tree5d8c67681192e477e7c501f42f6c6ccb7e479cf3 /misc/p5-Geo-Coder-PlaceFinder
parentf893a9833bf8d836da6b9a27c8b5652bdc722362 (diff)
downloadports-5c3cefb426b4cd20e34b499b0d285043edece9ab.tar.gz
ports-5c3cefb426b4cd20e34b499b0d285043edece9ab.zip
Notes
Diffstat (limited to 'misc/p5-Geo-Coder-PlaceFinder')
-rw-r--r--misc/p5-Geo-Coder-PlaceFinder/Makefile36
-rw-r--r--misc/p5-Geo-Coder-PlaceFinder/distinfo2
-rw-r--r--misc/p5-Geo-Coder-PlaceFinder/pkg-descr4
-rw-r--r--misc/p5-Geo-Coder-PlaceFinder/pkg-plist7
4 files changed, 49 insertions, 0 deletions
diff --git a/misc/p5-Geo-Coder-PlaceFinder/Makefile b/misc/p5-Geo-Coder-PlaceFinder/Makefile
new file mode 100644
index 000000000000..9c7a5252d2b3
--- /dev/null
+++ b/misc/p5-Geo-Coder-PlaceFinder/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-Geo-Coder-PlaceFinder
+# Date created: 2011-10-13
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-Coder-PlaceFinder
+PORTVERSION= 0.05
+CATEGORIES= misc geography perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Geocode addresses with Yahoo PlaceFinder
+
+BUILD_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
+ p5-JSON-XS>=2:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
+ p5-JSON-XS>=2:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Geo::Coder::PlaceFinder.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.82:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/misc/p5-Geo-Coder-PlaceFinder/distinfo b/misc/p5-Geo-Coder-PlaceFinder/distinfo
new file mode 100644
index 000000000000..f25e01fdb3a9
--- /dev/null
+++ b/misc/p5-Geo-Coder-PlaceFinder/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Geo-Coder-PlaceFinder-0.05.tar.gz) = 44915daceadb4b6e5ccbe7f759878eaf72b5fc6da4fb6c964d3febf76c7ce234
+SIZE (Geo-Coder-PlaceFinder-0.05.tar.gz) = 6400
diff --git a/misc/p5-Geo-Coder-PlaceFinder/pkg-descr b/misc/p5-Geo-Coder-PlaceFinder/pkg-descr
new file mode 100644
index 000000000000..c90b5a2c85a9
--- /dev/null
+++ b/misc/p5-Geo-Coder-PlaceFinder/pkg-descr
@@ -0,0 +1,4 @@
+Geo::Coder::PlaceFinder provides an interface to the Yahoo PlaceFinder geocoding
+service.
+
+WWW: http://search.cpan.org/dist/Geo-Coder-PlaceFinder/
diff --git a/misc/p5-Geo-Coder-PlaceFinder/pkg-plist b/misc/p5-Geo-Coder-PlaceFinder/pkg-plist
new file mode 100644
index 000000000000..e3ee2d8c4012
--- /dev/null
+++ b/misc/p5-Geo-Coder-PlaceFinder/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Geo/Coder/PlaceFinder.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/PlaceFinder/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/PlaceFinder
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo
+@dirrmtry %%SITE_PERL%%/Geo/Coder
+@dirrmtry %%SITE_PERL%%/Geo