aboutsummaryrefslogtreecommitdiff
path: root/misc/p5-Software-License
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2010-05-11 06:43:46 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2010-05-11 06:43:46 +0000
commit88da3f1493ec9ef76166fb57e24841dbd6befeb4 (patch)
treec7a1b3c67cebf7dbe70cfdf3e4c4ddb51c5604e8 /misc/p5-Software-License
parent7f19f25c8030da4eaec2b3a83f0cfc7f4a241a44 (diff)
downloadports-88da3f1493ec9ef76166fb57e24841dbd6befeb4.tar.gz
ports-88da3f1493ec9ef76166fb57e24841dbd6befeb4.zip
Notes
Diffstat (limited to 'misc/p5-Software-License')
-rw-r--r--misc/p5-Software-License/Makefile52
-rw-r--r--misc/p5-Software-License/distinfo3
-rw-r--r--misc/p5-Software-License/pkg-descr3
-rw-r--r--misc/p5-Software-License/pkg-plist31
4 files changed, 89 insertions, 0 deletions
diff --git a/misc/p5-Software-License/Makefile b/misc/p5-Software-License/Makefile
new file mode 100644
index 000000000000..6d932c1e9e82
--- /dev/null
+++ b/misc/p5-Software-License/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: Software::License
+# Date created: 11 May 2010
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Software-License
+PORTVERSION= 0.016
+CATEGORIES= misc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/R/RJ/RJBS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Packages that provide templated software licenses
+
+BUILD_DEPENDS= p5-Data-Section>=0:${PORTSDIR}/devel/p5-Data-Section \
+ p5-Sub-Install>=0:${PORTSDIR}/devel/p5-Sub-Install \
+ p5-Text-Template>=0:${PORTSDIR}/textproc/p5-Text-Template
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Software::License.3 \
+ Software::License::AGPL_3.3 \
+ Software::License::Apache_1_1.3 \
+ Software::License::Apache_2_0.3 \
+ Software::License::Artistic_1_0.3 \
+ Software::License::Artistic_2_0.3 \
+ Software::License::BSD.3 \
+ Software::License::CC0_1_0.3 \
+ Software::License::FreeBSD.3 \
+ Software::License::GFDL_1_2.3 \
+ Software::License::GPL_1.3 \
+ Software::License::GPL_2.3 \
+ Software::License::GPL_3.3 \
+ Software::License::LGPL_2_1.3 \
+ Software::License::LGPL_3_0.3 \
+ Software::License::MIT.3 \
+ Software::License::Mozilla_1_0.3 \
+ Software::License::Mozilla_1_1.3 \
+ Software::License::None.3 \
+ Software::License::OpenSSL.3 \
+ Software::License::Perl_5.3 \
+ Software::License::QPL_1_0.3 \
+ Software::License::SSLeay.3 \
+ Software::License::Sun.3 \
+ Software::License::Zlib.3 \
+ Software::LicenseUtils.3
+
+.include <bsd.port.mk>
diff --git a/misc/p5-Software-License/distinfo b/misc/p5-Software-License/distinfo
new file mode 100644
index 000000000000..729eb2c1fa09
--- /dev/null
+++ b/misc/p5-Software-License/distinfo
@@ -0,0 +1,3 @@
+MD5 (Software-License-0.016.tar.gz) = 629d2550325964bce87dfcccabc0bba6
+SHA256 (Software-License-0.016.tar.gz) = 54fd60714b85853a3e1840132243c69bf16a77f957c93f5b4d0d4df3bc659a86
+SIZE (Software-License-0.016.tar.gz) = 106310
diff --git a/misc/p5-Software-License/pkg-descr b/misc/p5-Software-License/pkg-descr
new file mode 100644
index 000000000000..40c51799cc28
--- /dev/null
+++ b/misc/p5-Software-License/pkg-descr
@@ -0,0 +1,3 @@
+Software::License - packages that provide templated software licenses
+
+WWW: http://search.cpan.org/dist/Software-License/
diff --git a/misc/p5-Software-License/pkg-plist b/misc/p5-Software-License/pkg-plist
new file mode 100644
index 000000000000..38d34318079b
--- /dev/null
+++ b/misc/p5-Software-License/pkg-plist
@@ -0,0 +1,31 @@
+%%SITE_PERL%%/Software/License.pm
+%%SITE_PERL%%/Software/License/AGPL_3.pm
+%%SITE_PERL%%/Software/License/Apache_1_1.pm
+%%SITE_PERL%%/Software/License/Apache_2_0.pm
+%%SITE_PERL%%/Software/License/Artistic_1_0.pm
+%%SITE_PERL%%/Software/License/Artistic_2_0.pm
+%%SITE_PERL%%/Software/License/BSD.pm
+%%SITE_PERL%%/Software/License/CC0_1_0.pm
+%%SITE_PERL%%/Software/License/FreeBSD.pm
+%%SITE_PERL%%/Software/License/GFDL_1_2.pm
+%%SITE_PERL%%/Software/License/GPL_1.pm
+%%SITE_PERL%%/Software/License/GPL_2.pm
+%%SITE_PERL%%/Software/License/GPL_3.pm
+%%SITE_PERL%%/Software/License/LGPL_2_1.pm
+%%SITE_PERL%%/Software/License/LGPL_3_0.pm
+%%SITE_PERL%%/Software/License/MIT.pm
+%%SITE_PERL%%/Software/License/Mozilla_1_0.pm
+%%SITE_PERL%%/Software/License/Mozilla_1_1.pm
+%%SITE_PERL%%/Software/License/None.pm
+%%SITE_PERL%%/Software/License/OpenSSL.pm
+%%SITE_PERL%%/Software/License/Perl_5.pm
+%%SITE_PERL%%/Software/License/QPL_1_0.pm
+%%SITE_PERL%%/Software/License/SSLeay.pm
+%%SITE_PERL%%/Software/License/Sun.pm
+%%SITE_PERL%%/Software/License/Zlib.pm
+%%SITE_PERL%%/Software/LicenseUtils.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Software/License/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Software/License
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Software
+@dirrmtry %%SITE_PERL%%/Software/License
+@dirrmtry %%SITE_PERL%%/Software