aboutsummaryrefslogtreecommitdiff
path: root/misc/pantry
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-07-21 19:55:12 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-07-21 19:55:12 +0000
commitb5857730a518f29047bd0a41c65009cc6f307360 (patch)
tree237a4ceef0943b958bac552358b23b309b3879ac /misc/pantry
parent3b32dcf4ec43e06102ee7512118ac1696c2b4ef2 (diff)
downloadports-b5857730a518f29047bd0a41c65009cc6f307360.tar.gz
ports-b5857730a518f29047bd0a41c65009cc6f307360.zip
Notes
Diffstat (limited to 'misc/pantry')
-rw-r--r--misc/pantry/Makefile40
-rw-r--r--misc/pantry/distinfo3
-rw-r--r--misc/pantry/pkg-descr14
-rw-r--r--misc/pantry/pkg-plist141
4 files changed, 198 insertions, 0 deletions
diff --git a/misc/pantry/Makefile b/misc/pantry/Makefile
new file mode 100644
index 000000000000..13059c13fe97
--- /dev/null
+++ b/misc/pantry/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: pantry
+# Date created: 21 July 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pantry
+PORTVERSION= 0.${DISTVERSION}
+DISTVERSION= 11
+CATEGORIES= misc
+MASTER_SITES= SF
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Command-line nutrition analysis program
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+MAN1= ${PORTNAME}.1
+PORTDATA= master
+
+post-extract:
+ @${MV} ${WRKSRC}/docs/${PORTNAME}.1 ${WRKSRC}/
+
+post-install:
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1/
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ @cd ${WRKSRC}/docs/&&${COPYTREE_SHARE} . ${DOCSDIR}/
+.endif
+.ifndef NOPORTEXAMPLES
+ @${INSTALL} -d ${EXAMPLESDIR}/
+ @cd ${WRKSRC}/examples/&&${COPYTREE_SHARE} . ${EXAMPLESDIR}/
+.endif
+.ifndef NOPORTDATA
+ @${INSTALL} -d ${DATADIR}/
+ @${INSTALL_DATA} ${WRKSRC}/master ${DATADIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/misc/pantry/distinfo b/misc/pantry/distinfo
new file mode 100644
index 000000000000..121fb8a0382e
--- /dev/null
+++ b/misc/pantry/distinfo
@@ -0,0 +1,3 @@
+MD5 (pantry-11.tar.gz) = fa200e8041edb3e757464920fe25d81b
+SHA256 (pantry-11.tar.gz) = 559d6324cc67633affe736854c71fdd913282fe0f1239fedf84a2e1f1f43cde5
+SIZE (pantry-11.tar.gz) = 7542778
diff --git a/misc/pantry/pkg-descr b/misc/pantry/pkg-descr
new file mode 100644
index 000000000000..e0c15df2c5bf
--- /dev/null
+++ b/misc/pantry/pkg-descr
@@ -0,0 +1,14 @@
+Pantry is a command-line oriented nutrient analysis program. It is a
+true command-line program: there are no menus, there are no prompts.
+Instead, you simply type commands from your shell prompt, and Pantry
+does what you ask it to do, displaying results if you have asked it to
+do that.
+
+In addition to using Pantry from your shell prompt, you also interact
+with it through XML files. Using XML, you can edit Pantry's
+configuration file. You can also add nutrient information for custom
+foods (though Pantry includes nutrient information for over 7,000 foods
+to get you started) and recipes using XML.
+
+WWW: http://pantry.sourceforge.net/
+Author: Omari Norman <massysett at users.sourceforge.net>
diff --git a/misc/pantry/pkg-plist b/misc/pantry/pkg-plist
new file mode 100644
index 000000000000..d7457367d0fa
--- /dev/null
+++ b/misc/pantry/pkg-plist
@@ -0,0 +1,141 @@
+bin/pantry
+bin/pantry-addTo
+%%PYTHON_SITELIBDIR%%/pantry/__init__.py
+%%PYTHON_SITELIBDIR%%/pantry/__init__.pyc
+%%PYTHON_SITELIBDIR%%/pantry/__init__.pyo
+%%PYTHON_SITELIBDIR%%/pantry/cli/__init__.py
+%%PYTHON_SITELIBDIR%%/pantry/cli/__init__.pyc
+%%PYTHON_SITELIBDIR%%/pantry/cli/__init__.pyo
+%%PYTHON_SITELIBDIR%%/pantry/cli/config.py
+%%PYTHON_SITELIBDIR%%/pantry/cli/config.pyc
+%%PYTHON_SITELIBDIR%%/pantry/cli/config.pyo
+%%PYTHON_SITELIBDIR%%/pantry/cli/main.py
+%%PYTHON_SITELIBDIR%%/pantry/cli/main.pyc
+%%PYTHON_SITELIBDIR%%/pantry/cli/main.pyo
+%%PYTHON_SITELIBDIR%%/pantry/cli/reports.py
+%%PYTHON_SITELIBDIR%%/pantry/cli/reports.pyc
+%%PYTHON_SITELIBDIR%%/pantry/cli/reports.pyo
+%%PYTHON_SITELIBDIR%%/pantry/lib/__init__.py
+%%PYTHON_SITELIBDIR%%/pantry/lib/__init__.pyc
+%%PYTHON_SITELIBDIR%%/pantry/lib/__init__.pyo
+%%PYTHON_SITELIBDIR%%/pantry/lib/cabinets.py
+%%PYTHON_SITELIBDIR%%/pantry/lib/cabinets.pyc
+%%PYTHON_SITELIBDIR%%/pantry/lib/cabinets.pyo
+%%PYTHON_SITELIBDIR%%/pantry/lib/foods.py
+%%PYTHON_SITELIBDIR%%/pantry/lib/foods.pyc
+%%PYTHON_SITELIBDIR%%/pantry/lib/foods.pyo
+%%PYTHON_SITELIBDIR%%/pantry/unicodeHelper.py
+%%PYTHON_SITELIBDIR%%/pantry/unicodeHelper.pyc
+%%PYTHON_SITELIBDIR%%/pantry/unicodeHelper.pyo
+%%PYTHON_SITELIBDIR%%/pantry/version.py
+%%PYTHON_SITELIBDIR%%/pantry/version.pyc
+%%PYTHON_SITELIBDIR%%/pantry/version.pyo
+%%PYTHON_SITELIBDIR%%/pantry/xmlCheck.py
+%%PYTHON_SITELIBDIR%%/pantry/xmlCheck.pyc
+%%PYTHON_SITELIBDIR%%/pantry/xmlCheck.pyo
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/__init__.py
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/__init__.pyc
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/__init__.pyo
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/_outputters.py
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/_outputters.pyc
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/_outputters.pyo
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/catalog.py
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/catalog.pyc
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/catalog.pyo
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/characters.py
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/characters.pyc
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/characters.pyo
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/charconv.py
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/charconv.pyc
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/charconv.pyo
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/dtdparser.py
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/dtdparser.pyc
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/dtdparser.pyo
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/errors.py
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/errors.pyc
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/errors.pyo
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/namespace.py
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/namespace.pyc
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/namespace.pyo
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/utils.py
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/utils.pyc
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/utils.pyo
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/xcatalog.py
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/xcatalog.pyc
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/xcatalog.pyo
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/xmlapp.py
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/xmlapp.pyc
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/xmlapp.pyo
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/xmldtd.py
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/xmldtd.pyc
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/xmldtd.pyo
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/xmlproc.py
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/xmlproc.pyc
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/xmlproc.pyo
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/xmlutils.py
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/xmlutils.pyc
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/xmlutils.pyo
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/xmlval.py
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/xmlval.pyc
+%%PYTHON_SITELIBDIR%%/pantry/xmlproc/xmlval.pyo
+%%PORTDOCS%%%%DOCSDIR%%/entities
+%%PORTDOCS%%%%DOCSDIR%%/examples
+%%PORTDOCS%%%%DOCSDIR%%/files
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/apa.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/apb.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch01.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch01s02.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch01s03.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch01s04.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch02.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch02s02.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch02s03.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch02s04.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch02s05.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch02s06.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch02s07.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch02s08.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch03.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch03s02.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch03s03.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch04.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch04s02.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch04s03.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch04s04.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch04s05.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch04s06.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch04s07.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch05.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch05s02.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch05s03.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch05s04.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch06.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch06s02.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch06s03.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch06s04.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch07.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch07s02.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch07s03.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/ch07s04.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/pr01.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/pr01s02.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/pr01s03.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/pr01s04.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/pr01s05.html
+%%PORTDOCS%%%%DOCSDIR%%/html-chunk/re01.html
+%%PORTDOCS%%%%DOCSDIR%%/pantry-user-guide-USLetter.pdf
+%%PORTDOCS%%%%DOCSDIR%%/pantry-user-guide.html
+%%PORTDOCS%%%%DOCSDIR%%/pantry-user-guide.txt
+%%PORTDOCS%%%%DOCSDIR%%/pantry-user-guide.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/foods.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/foods.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pantryrc.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/recipes.xml
+@dirrm %%PYTHON_SITELIBDIR%%/pantry/cli
+@dirrm %%PYTHON_SITELIBDIR%%/pantry/lib
+@dirrm %%PYTHON_SITELIBDIR%%/pantry/xmlproc
+@dirrm %%PYTHON_SITELIBDIR%%/pantry
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html-chunk
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%