aboutsummaryrefslogtreecommitdiff
path: root/misc/pastebinit
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2008-03-06 12:58:20 +0000
committerWesley Shields <wxs@FreeBSD.org>2008-03-06 12:58:20 +0000
commit40b28e6445dc62543a0532bc0cf727a3671d191a (patch)
treef46bd9d53b840956982dcd78ae94b4cd9e5a6156 /misc/pastebinit
parentb571c50a25d86b4babfdfb1e050ebb410b5b9f21 (diff)
downloadports-40b28e6445dc62543a0532bc0cf727a3671d191a.tar.gz
ports-40b28e6445dc62543a0532bc0cf727a3671d191a.zip
Notes
Diffstat (limited to 'misc/pastebinit')
-rw-r--r--misc/pastebinit/Makefile29
-rw-r--r--misc/pastebinit/distinfo3
-rw-r--r--misc/pastebinit/pkg-descr3
3 files changed, 35 insertions, 0 deletions
diff --git a/misc/pastebinit/Makefile b/misc/pastebinit/Makefile
new file mode 100644
index 000000000000..5c77a63c0c6b
--- /dev/null
+++ b/misc/pastebinit/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: pastebinit
+# Date created: Thu Feb 21 00:21:23 EST 2008
+# Whom: comperr <comperr.extra@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pastebinit
+PORTVERSION= 0.9
+CATEGORIES= misc python
+MASTER_SITES= http://www.stgraber.org/download/projects/pastebin/
+
+MAINTAINER= comperr.extra@gmail.com
+COMMENT= A command line utility for pastebing
+
+USE_PYTHON= yes
+
+NO_BUILD= yes
+
+PLIST_FILES= bin/pastebinit
+
+post-patch:
+ ${REINPLACE_CMD} -e 's#/usr/bin/python#${PYTHON_CMD}#' \
+ ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/misc/pastebinit/distinfo b/misc/pastebinit/distinfo
new file mode 100644
index 000000000000..7e5cdb3f6744
--- /dev/null
+++ b/misc/pastebinit/distinfo
@@ -0,0 +1,3 @@
+MD5 (pastebinit-0.9.tar.gz) = 16c3e6ae00cf689465a4fde2d3b20757
+SHA256 (pastebinit-0.9.tar.gz) = e437880db7811727c9330b1947a27ab9df1ae01fe22e3ad8ed35db45b99250ec
+SIZE (pastebinit-0.9.tar.gz) = 12645
diff --git a/misc/pastebinit/pkg-descr b/misc/pastebinit/pkg-descr
new file mode 100644
index 000000000000..c0668da1249b
--- /dev/null
+++ b/misc/pastebinit/pkg-descr
@@ -0,0 +1,3 @@
+A command line pastebin utility.
+
+WWW: http://www.stgraber.org/download/projects/pastebin/