aboutsummaryrefslogtreecommitdiff
path: root/misc/pear-Text_Figlet/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-12-15 12:19:35 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-12-15 12:19:35 +0000
commitd7acb210f6da1c04681679a4b62b65c220ea7a27 (patch)
tree14136819a83984fe73c37d13a3fff1f41f83bf7c /misc/pear-Text_Figlet/Makefile
parent3058a593a836cf4d86e947011114dbb879b22f49 (diff)
Notes
Diffstat (limited to 'misc/pear-Text_Figlet/Makefile')
-rw-r--r--misc/pear-Text_Figlet/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/misc/pear-Text_Figlet/Makefile b/misc/pear-Text_Figlet/Makefile
new file mode 100644
index 000000000000..69a2b4bc5c6d
--- /dev/null
+++ b/misc/pear-Text_Figlet/Makefile
@@ -0,0 +1,41 @@
+# Ports collection makefile for: pear-Text_Figlet
+# Date created: 15 December 2004
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text_Figlet
+PORTVERSION= 0.8.0
+CATEGORIES= misc pear
+
+MAINTAINER= antonio@php.net
+COMMENT= Render text using FIGlet fonts
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PHP= yes
+
+CATEGORY= Text
+FILES= Figlet.php
+DOCS= README.TXT
+EXAMPLES= 3-d.flf alligator2.flf bell.flf block.flf contessa.flf cybermedium.flf \
+ isometric1.flf larry3d.flf script.flf slant.flf figlet.php
+_EXAMPLESDIR= docs/examples
+
+post-extract:
+ ${MKDIR} ${WRKSRC}
+ ${MV} ${WRKDIR}/docs ${WRKSRC}/
+ ${MV} ${WRKDIR}/Figlet.php ${WRKSRC}/
+
+.include <bsd.port.pre.mk>
+
+PHP_VERS= ${PHP_VERSION:S/.//g}
+
+.if defined(PHP_VERS) && ${PHP_VERS} < 404
+IGNORE= "You need PHP 4.0.4 or later to install PEAR::Text_Figlet"
+.endif
+
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>