aboutsummaryrefslogtreecommitdiff
path: root/misc/phraze
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-04-28 11:10:20 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-04-28 11:10:20 +0000
commitd1324a1a6333001b47fdbf20f896a2156b9c3140 (patch)
treed93d17b896fb56498a86a739b350f6b2e8fcc815 /misc/phraze
parentb9fde6414dc98d9082246729d596e795f8b9155d (diff)
downloadports-d1324a1a6333001b47fdbf20f896a2156b9c3140.tar.gz
ports-d1324a1a6333001b47fdbf20f896a2156b9c3140.zip
Notes
Diffstat (limited to 'misc/phraze')
-rw-r--r--misc/phraze/Makefile34
-rw-r--r--misc/phraze/distinfo1
-rw-r--r--misc/phraze/pkg-descr10
-rw-r--r--misc/phraze/pkg-plist4
4 files changed, 49 insertions, 0 deletions
diff --git a/misc/phraze/Makefile b/misc/phraze/Makefile
new file mode 100644
index 000000000000..08d990a8717d
--- /dev/null
+++ b/misc/phraze/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# Ports collection makefile for: phraze
+# Date created: Wed Apr 16, 2003
+# Whom: Michael L. Hostbaek <mich@freebsdcluster.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phraze
+PORTVERSION= 0.1
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= mich@freebsdcluster.org
+COMMENT= Converts telephone number to combinations of valid words
+
+USE_RUBY= yes
+NO_BUILD= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^#!/usr/bin/ruby|#!${RUBY}|; \
+ s|/usr/local/phraze|${DATADIR}|' ${WRKSRC}/phraze ${WRKSRC}/phraze.1
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/phraze.dict ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/phraze ${PREFIX}/bin/phraze
+ ${INSTALL_MAN} ${WRKSRC}/phraze.1 ${PREFIX}/man/man1/
+
+MAN1= phraze.1
+
+.include <bsd.port.mk>
diff --git a/misc/phraze/distinfo b/misc/phraze/distinfo
new file mode 100644
index 000000000000..43e301fd1932
--- /dev/null
+++ b/misc/phraze/distinfo
@@ -0,0 +1 @@
+MD5 (phraze-0.1.tar.gz) = 01f1d29be64d7ecd11c8ff5a0c0ce633
diff --git a/misc/phraze/pkg-descr b/misc/phraze/pkg-descr
new file mode 100644
index 000000000000..16db82eeedeb
--- /dev/null
+++ b/misc/phraze/pkg-descr
@@ -0,0 +1,10 @@
+Phraze takes a telephone number and produces a list of combinations of
+valid words that can be derived from it, using the keypad of a US phone.
+
+Requires ruby.
+
+WWW: http://phraze.sourceforge.net/
+AUTHOR: Jeff Pace <jpace@incava.org>
+
+ - Michael L. Hostbaek
+ mich@freebsdcluster.org
diff --git a/misc/phraze/pkg-plist b/misc/phraze/pkg-plist
new file mode 100644
index 000000000000..52026528d5d1
--- /dev/null
+++ b/misc/phraze/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+bin/phraze
+%%DATADIR%%/phraze.dict
+@dirrm %%DATADIR%%