aboutsummaryrefslogtreecommitdiff
path: root/misc/pipe
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2005-04-06 23:59:53 +0000
committerHerve Quiroz <hq@FreeBSD.org>2005-04-06 23:59:53 +0000
commitafc723066c2cf40d7be8fbb6f2da94bb11478689 (patch)
tree9cca8e6267dff294336549804b8817822ed39ec5 /misc/pipe
parent49d32a10a6e26cb9181207bf47b672da28c2c48c (diff)
downloadports-afc723066c2cf40d7be8fbb6f2da94bb11478689.tar.gz
ports-afc723066c2cf40d7be8fbb6f2da94bb11478689.zip
- Update to 0.b.1.5 (and unbreak) [1]
- Stipulate JAVA_VERSION [1] - Symlink examples so the program can find them and provide the "Examples" menu [1] - Add 'java' category [2] - Install documentation using FIND | INSTALL_DATA - Improve the launcher shell script (use javavmwrapper 2.0) - Use SUB_FILES to build the launcher shell script PR: 79578 [1] Submitted by: Sam Lawrance <boris@brooknet.com.au> [1] Reported by: portlint [2] Reviewed by: Sam Lawrance <boris@brooknet.com.au>
Notes
Notes: svn path=/head/; revision=132659
Diffstat (limited to 'misc/pipe')
-rw-r--r--misc/pipe/Makefile26
-rw-r--r--misc/pipe/distinfo4
-rw-r--r--misc/pipe/files/pipe3
-rw-r--r--misc/pipe/files/pipe.sh.in5
4 files changed, 20 insertions, 18 deletions
diff --git a/misc/pipe/Makefile b/misc/pipe/Makefile
index ec58168de914..a81cb82fdc7c 100644
--- a/misc/pipe/Makefile
+++ b/misc/pipe/Makefile
@@ -7,43 +7,43 @@
#
PORTNAME= pipe
-PORTVERSION= 0.b.1.0
-CATEGORIES= misc
+PORTVERSION= 0.b.1.5
+CATEGORIES= misc java
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= petri-net
-DISTNAME= ${PORTNAME}-beta-1.0
+DISTNAME= ${PORTNAME}-beta-1.5
MAINTAINER= ports@FreeBSD.org
COMMENT= Platform Independent Petri-Net Editor
-BROKEN= Size mismatch
-
USE_ZIP= yes
-WRKSRC= ${WRKDIR}/PIPE
+WRKSRC= ${WRKDIR}/${PORTNAME}
NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_JAVA= yes
+JAVA_VERSION= 1.3+
PLIST_FILES= bin/pipe
+SUB_FILES= pipe.sh
.if !defined(NOPORTDOCS)
-PORTDOCS= *
+PORTDOCS= javadoc license manual
.endif
-post-extract:
- @${SED} 's,%%DATADIR%%,${DATADIR},' ${FILESDIR}/pipe > ${WRKSRC}/pipe
-
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/pipe ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/pipe.sh ${PREFIX}/bin/pipe
@${MKDIR} ${DATADIR}
${CP} -R ${WRKSRC}/bin/ ${DATADIR}
+ ${LN} -s ${DATADIR}/petri-nets ${DATADIR}/Example\ nets
@${FIND} ${DATADIR} ! -type d | \
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
@${FIND} ${DATADIR} -type d | ${SORT} -r | \
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${CP} -R ${WRKSRC}/doc/ ${DOCSDIR}
+ cd ${WRKSRC}/resources && \
+ ${FIND} ${PORTDOCS} -type d -exec ${MKDIR} ${DOCSDIR}/{} \;
+ cd ${WRKSRC}/resources && \
+ ${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
.endif
.include <bsd.port.mk>
diff --git a/misc/pipe/distinfo b/misc/pipe/distinfo
index 2d88ad098ec9..a4c6fd02be7b 100644
--- a/misc/pipe/distinfo
+++ b/misc/pipe/distinfo
@@ -1,2 +1,2 @@
-MD5 (pipe-beta-1.0.zip) = bd9bff57bec23a2e1fdfac61546421a4
-SIZE (pipe-beta-1.0.zip) = 1797504
+MD5 (pipe-beta-1.5.zip) = ad88a8b58de02fb0b68f7f85b11d3057
+SIZE (pipe-beta-1.5.zip) = 1498335
diff --git a/misc/pipe/files/pipe b/misc/pipe/files/pipe
deleted file mode 100644
index 7c6abae119fe..000000000000
--- a/misc/pipe/files/pipe
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-java -cp %%DATADIR%% RunGui
diff --git a/misc/pipe/files/pipe.sh.in b/misc/pipe/files/pipe.sh.in
new file mode 100644
index 000000000000..48d6f3b13158
--- /dev/null
+++ b/misc/pipe/files/pipe.sh.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -cp "%%DATADIR%%" RunGui