aboutsummaryrefslogtreecommitdiff
path: root/misc/portell
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2004-06-25 13:11:30 +0000
committerMichael Landin <mich@FreeBSD.org>2004-06-25 13:11:30 +0000
commita9c369d7ef766bfcbff9a7439f7f687258d85599 (patch)
tree973ffa39ba1d58835c1a052c291b9d532faba3bd /misc/portell
parent04117250712ec1222db2c22e8d161f02ee448ea9 (diff)
downloadports-a9c369d7ef766bfcbff9a7439f7f687258d85599.tar.gz
ports-a9c369d7ef766bfcbff9a7439f7f687258d85599.zip
Notes
Diffstat (limited to 'misc/portell')
-rw-r--r--misc/portell/Makefile2
-rw-r--r--misc/portell/files/patch-ab47
2 files changed, 48 insertions, 1 deletions
diff --git a/misc/portell/Makefile b/misc/portell/Makefile
index c334a6acfcfd..2731d01aa623 100644
--- a/misc/portell/Makefile
+++ b/misc/portell/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portell
PORTVERSION= 0.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/misc/portell/files/patch-ab b/misc/portell/files/patch-ab
new file mode 100644
index 000000000000..47db5c2cf69d
--- /dev/null
+++ b/misc/portell/files/patch-ab
@@ -0,0 +1,47 @@
+--- portell.py.orig Thu Jun 24 07:41:00 2004
++++ portell.py Thu Jun 24 07:42:12 2004
+@@ -2,6 +2,7 @@
+ # portell.py
+ # Description: prints a port's descr-file from whatever directory you're in.
+ # Author: Ryan "gt3" Kulla
++# Bugfixes: Radim "HSN" Kolar
+ # Email: ambiod@sbcglobal.net
+ # Version: 0.1
+ # Usage: portell.py <portname>
+@@ -23,20 +24,31 @@
+ PORTELL_DB_FILE = "/var/db/portell.db"
+
+ PORTS_DIR = "/usr/ports/"
++IGNORE_DIRS = { "distfiles":None, "Tools":None, "packages":None }
+
+ def write_pathname(d, dirname, names):
+- dirname = join(dirname.split('/')[:5], '/') # chop port path subdirs
+- d[os.path.basename(dirname)] = dirname
++ dirs=dirname.split('/')
++ if len(dirs)==4:
++ if IGNORE_DIRS.has_key(dirs[3]):
++ del names[:]
++ elif len(dirs)==5:
++ d[dirs[4]] = dirname
++ del names[:]
+
+ def update_db():
+- if os.access(PORTELL_DB_FILE, os.F_OK):
+- os.unlink(PORTELL_DB_FILE)
++ try:
++ os.unlink(PORTELL_DB_FILE)
++ except:
++ pass
+ try:
+ d = shelve.open(PORTELL_DB)
+- os.chmod(PORTELL_DB_FILE, 0666)
+ except:
+ print "can't read or write %s. are you root?" % PORTELL_DB_FILE
+ sys.exit(0)
++ try:
++ os.chmod(PORTELL_DB_FILE, 0666)
++ except:
++ pass
+ os.path.walk(PORTS_DIR, write_pathname, d)
+ d.close()
+