aboutsummaryrefslogtreecommitdiff
path: root/misc/posixtestsuite/Makefile
diff options
context:
space:
mode:
authorAlexey Zelkin <phantom@FreeBSD.org>2004-03-20 13:19:31 +0000
committerAlexey Zelkin <phantom@FreeBSD.org>2004-03-20 13:19:31 +0000
commitf8f2036bd0670ebff2bb0c47488caac4b4382042 (patch)
treedcba114a164b256546bf777d879b513b2eea794b /misc/posixtestsuite/Makefile
parent941aa55a952847cbdf2893f8e41f70b740f2a72c (diff)
downloadports-f8f2036bd0670ebff2bb0c47488caac4b4382042.tar.gz
ports-f8f2036bd0670ebff2bb0c47488caac4b4382042.zip
Make libpthread default threading library. Since this port is supposed
to be compiled/run against any threading library in system, so we can't use default PTHREAD_LIBS stuff here.
Notes
Notes: svn path=/head/; revision=104736
Diffstat (limited to 'misc/posixtestsuite/Makefile')
-rw-r--r--misc/posixtestsuite/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/misc/posixtestsuite/Makefile b/misc/posixtestsuite/Makefile
index e5334ff87420..32b6772d757a 100644
--- a/misc/posixtestsuite/Makefile
+++ b/misc/posixtestsuite/Makefile
@@ -43,7 +43,7 @@ THEPIPE= | tee 2>&1
.if defined(WITH_THRLIB)
THRLIB=${WITH_THRLIB}
.else
-THRLIB= -lc_r
+THRLIB= -lpthread
.endif
pre-everything::
@@ -58,15 +58,16 @@ pre-everything::
@${ECHO} ""
@${ECHO} " * QUIET - don't print progress messages while running"
@${ECHO} " * WITH_THRLIB - choose thread library to run test against"
- @${ECHO} " (NB: by default 'libc_r' is used)"
+ @${ECHO} " (NB: by default 'libpthread' is used)"
@${ECHO} ""
@${ECHO} "Examples:"
@${ECHO} ""
- @${ECHO} " make WITH_THRLIB=libkse run"
- @${ECHO} " - run tests against libkse"
+ @${ECHO} " make WITH_THRLIB=libthr run"
+ @${ECHO} " - run tests against libthr"
@${ECHO} ""
@${ECHO} " make QUIET=YES WITH_THRLIB= regression"
- @${ECHO} " - be quiet, run tests against libc, compare tests results"
+ @${ECHO} " - be quiet, run tests against libpthread (default"
+ @${ECHO} " threading library), compare tests results"
@${ECHO} ""
help: pre-everything