aboutsummaryrefslogtreecommitdiff
path: root/misc/posixtestsuite
diff options
context:
space:
mode:
authorAlexey Zelkin <phantom@FreeBSD.org>2003-11-10 09:49:38 +0000
committerAlexey Zelkin <phantom@FreeBSD.org>2003-11-10 09:49:38 +0000
commita03340214d607962c2f5e25a1e62f3bcae9d5f59 (patch)
tree946d06ed8282621e264df9d1356762948acbc38f /misc/posixtestsuite
parent9edb1b2b506e7d9ff7cf40aacf05ac6f742ba0fd (diff)
downloadports-a03340214d607962c2f5e25a1e62f3bcae9d5f59.tar.gz
ports-a03340214d607962c2f5e25a1e62f3bcae9d5f59.zip
Notes
Diffstat (limited to 'misc/posixtestsuite')
-rw-r--r--misc/posixtestsuite/Makefile101
-rw-r--r--misc/posixtestsuite/distinfo1
-rw-r--r--misc/posixtestsuite/files/patch-gentests.pl11
-rw-r--r--misc/posixtestsuite/files/patch-locate-test27
-rw-r--r--misc/posixtestsuite/pkg-descr6
5 files changed, 146 insertions, 0 deletions
diff --git a/misc/posixtestsuite/Makefile b/misc/posixtestsuite/Makefile
new file mode 100644
index 000000000000..082acbe8bfc5
--- /dev/null
+++ b/misc/posixtestsuite/Makefile
@@ -0,0 +1,101 @@
+# New ports collection makefile for: posixtestsuite
+# Date created: 11 November 2003
+# Whom: Alexey Zelkin <phantom@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= posixtestsuite
+PORTVERSION= 1.3.0
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= posixtest
+
+MAINTAINER= phantom@FreeBSD.org
+COMMENT= Open POSIX Test Suite
+
+WRKSRC= ${WRKDIR}/posixtestsuite
+
+NO_CONFIGURE= YES
+NO_BUILD= YES
+NO_INSTALL= YES
+NO_PACKAGE= "Nothing to package"
+
+USE_GMAKE= YES
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+REGR_LOG= log.run-4stable
+.else
+REGR_LOG= log.run-5current
+.endif
+
+RUN_RESULT= ${WRKSRC}/run.result
+LOCAL_REGR_LOG= ${WRKSRC}/regression.result
+
+.if defined(QUIET)
+THEPIPE= >
+.else
+THEPIPE= | tee 2>&1
+.endif
+
+.if defined(WITH_THRLIB)
+THRLIB=${WITH_THRLIB}
+.else
+THRLIB= -lc_r
+.endif
+
+pre-everything::
+ @${ECHO} "Following make commands are available:"
+ @${ECHO} ""
+ @${ECHO} " * help - this message"
+ @${ECHO} " * run - run whole testsuite"
+ @${ECHO} " * rerun - re-run broken tests"
+ @${ECHO} " * regression - show differences between original and current results"
+ @${ECHO} ""
+ @${ECHO} "Following options are available:"
+ @${ECHO} ""
+ @${ECHO} " * QUIET - don't print progress messages while running"
+ @${ECHO} " * WITH_THRLIB - choose thread library to run test against"
+ @${ECHO} " (NB: by default 'libc_r' is used)"
+ @${ECHO} ""
+ @${ECHO} "Examples:"
+ @${ECHO} ""
+ @${ECHO} " make WITH_THRLIB=libkse run"
+ @${ECHO} " - run tests against libkse"
+ @${ECHO} ""
+ @${ECHO} " make QUIET=YES WITH_THRLIB= regression"
+ @${ECHO} " - be quiet, run tests against libc, compare tests results"
+ @${ECHO} ""
+
+help: pre-everything
+
+aclean: all
+ @${ECHO} "Cleaning tests tree..."
+ -@(cd ${WRKSRC} && rm -f ${RUN_RESULT} && gmake clean)
+
+rerun: all
+.if defined(WITH_THRLIB)
+ echo ${THRLIB} > ${WRKSRC}/LDFLAGS
+.endif
+.if empty(THRLIB)
+ @${ECHO} "Running tests (against -lc) ..."
+.else
+ @${ECHO} "Running tests (against ${THRLIB}) ..."
+.endif
+ @(cd ${WRKSRC} && gmake all) ${THEPIPE} ${RUN_RESULT}
+ @${ECHO} ""
+ @${ECHO} "Run output is stored into following files:"
+ @${ECHO} " * short version: ${RUN_RESULT}"
+ @${ECHO} " * extended version: ${WRKSRC}/logfile"
+
+run: aclean rerun
+
+regression: run
+ @${ECHO} "Show regression log..."
+ @(cd ${WRKSRC} && diff -u ${FILESDIR}/${REGR_LOG} ${RUN_RESULT}) > ${LOCAL_REGR_LOG}
+ @[ -z ${LOCAL_REGR_LOG ] || ( ${ECHO} "No regression detected"; exit 0 )
+ @${ECHO} "Regression log stored at ${LOCAL_REGR_LOG}
+
+.include <bsd.port.post.mk>
diff --git a/misc/posixtestsuite/distinfo b/misc/posixtestsuite/distinfo
new file mode 100644
index 000000000000..41180900e6d7
--- /dev/null
+++ b/misc/posixtestsuite/distinfo
@@ -0,0 +1 @@
+MD5 (posixtestsuite-1.3.0.tar.gz) = c9a6c16be087bc58ecb9ec316659244c
diff --git a/misc/posixtestsuite/files/patch-gentests.pl b/misc/posixtestsuite/files/patch-gentests.pl
new file mode 100644
index 000000000000..ef9e9f009952
--- /dev/null
+++ b/misc/posixtestsuite/files/patch-gentests.pl
@@ -0,0 +1,11 @@
+--- conformance/interfaces/sigaction/gentests.pl~ Mon Nov 10 11:37:15 2003
++++ conformance/interfaces/sigaction/gentests.pl Mon Nov 10 11:43:01 2003
+@@ -11,7 +11,7 @@
+ my (@signals) = ("SIGABRT", "SIGALRM", "SIGBUS", "SIGCHLD", "SIGCONT",
+ "SIGFPE", "SIGHUP", "SIGILL", "SIGINT", "SIGPIPE",
+ "SIGQUIT", "SIGSEGV", "SIGTERM", "SIGTSTP", "SIGTTIN",
+- "SIGTTOU", "SIGUSR1", "SIGUSR2", "SIGPOLL", "SIGPROF",
++ "SIGTTOU", "SIGUSR1", "SIGUSR2", "SIGPROF",
+ "SIGSYS", "SIGTRAP", "SIGURG", "SIGVTALRM", "SIGXCPU",
+ "SIGXFSZ");
+
diff --git a/misc/posixtestsuite/files/patch-locate-test b/misc/posixtestsuite/files/patch-locate-test
new file mode 100644
index 000000000000..fc1dac0308ae
--- /dev/null
+++ b/misc/posixtestsuite/files/patch-locate-test
@@ -0,0 +1,27 @@
+diff -ur locate-test~ locate-test
+--- locate-test Tue Sep 23 21:45:57 2003
++++ locate-test Tue Nov 11 07:30:35 2003
+@@ -60,19 +60,19 @@
+ shift;
+ ;;
+ "--fmake")
+- find functional/ -type f -maxdepth 2 -mindepth 2 -name "Makefile" -printf "%h\n"
++ find functional/ -type f -maxdepth 2 -mindepth 2 -name "Makefile" | sed 's#/Makefile##g'
+ exit 0;
+ ;;
+ "--frun")
+- find functional/ -type f -maxdepth 2 -mindepth 2 -name "run.sh" -printf "%h\n"
++ find functional/ -type f -maxdepth 2 -mindepth 2 -name "run.sh" | sed 's#/run.sh##g'
+ exit 0;
+ ;;
+ "--smake")
+- find stress/ -type f -maxdepth 2 -mindepth 2 -name "Makefile" -printf "%h\n"
++ find stress/ -type f -maxdepth 2 -mindepth 2 -name "Makefile" | sed 's#/Makefile##g'
+ exit 0;
+ ;;
+ "--srun")
+- find stress/ -type f -maxdepth 2 -mindepth 2 -name "run.sh" -printf "%h\n"
++ find stress/ -type f -maxdepth 2 -mindepth 2 -name "run.sh" | sed 's#/run.sh##g'
+ exit 0;
+ ;;
+ "--help")
diff --git a/misc/posixtestsuite/pkg-descr b/misc/posixtestsuite/pkg-descr
new file mode 100644
index 000000000000..20f8a8171c35
--- /dev/null
+++ b/misc/posixtestsuite/pkg-descr
@@ -0,0 +1,6 @@
+The POSIX Test Suite is an open source test suite with the goal of
+performing conformance, functional, and stress testing of the IEEE
+1003.1-2001 System Interfaces specification in a manner that is
+agnostic to any given implementation.
+
+WWW: http://posixtest.sf.net/