aboutsummaryrefslogtreecommitdiff
path: root/misc/py-eemeter
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-01-25 18:31:19 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-01-25 18:31:19 +0000
commitbb86bc3ed79bbf2998f0a4c5e23aeee528ab2264 (patch)
tree2411beaf7c66e957e6096dae29a96d74d9c1afbc /misc/py-eemeter
parent5f5c0e06c871930eed6999fde503c6eb0626f435 (diff)
downloadports-bb86bc3ed79bbf2998f0a4c5e23aeee528ab2264.tar.gz
ports-bb86bc3ed79bbf2998f0a4c5e23aeee528ab2264.zip
Notes
Diffstat (limited to 'misc/py-eemeter')
-rw-r--r--misc/py-eemeter/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/misc/py-eemeter/Makefile b/misc/py-eemeter/Makefile
index 7869703b5c46..50f2bda5ba62 100644
--- a/misc/py-eemeter/Makefile
+++ b/misc/py-eemeter/Makefile
@@ -3,7 +3,7 @@
PORTNAME= eemeter
DISTVERSIONPREFIX= v
DISTVERSION= 2.5.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,12 +15,19 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pandas>0:math/py-pandas@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}statsmodels>0:math/py-statsmodels@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
USES= python
USE_GITHUB= yes # PyPI doesn't have the latest version for some reason
GH_ACCOUNT= openeemeter
USE_PYTHON= distutils concurrent autoplist
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}statsmodels010>0:math/py-statsmodels010@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}statsmodels>0:math/py-statsmodels@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>