aboutsummaryrefslogtreecommitdiff
path: root/misc/py-pexpect
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-04-07 20:06:23 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-04-07 20:06:23 +0000
commit0c6d3e5444a55d5d3a9cdf291f38cfc4cdf47984 (patch)
treec4fdc319db30ceb11cff23bb97d85ed382fa0b01 /misc/py-pexpect
parent42e72f22814b506a5fa1d6be604d3562a10fac03 (diff)
downloadports-0c6d3e5444a55d5d3a9cdf291f38cfc4cdf47984.tar.gz
ports-0c6d3e5444a55d5d3a9cdf291f38cfc4cdf47984.zip
Notes
Diffstat (limited to 'misc/py-pexpect')
-rw-r--r--misc/py-pexpect/Makefile11
-rw-r--r--misc/py-pexpect/distinfo6
-rw-r--r--misc/py-pexpect/pkg-descr13
3 files changed, 17 insertions, 13 deletions
diff --git a/misc/py-pexpect/Makefile b/misc/py-pexpect/Makefile
index 4263c824708f..6d09a99ca8c0 100644
--- a/misc/py-pexpect/Makefile
+++ b/misc/py-pexpect/Makefile
@@ -2,20 +2,21 @@
# $FreeBSD$
PORTNAME= pexpect
-PORTVERSION= 4.6.0
+PORTVERSION= 4.7.0
CATEGORIES= misc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= python@FreeBSD.org
-COMMENT= Pure Python Expect-like module
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python module for controlling interactive programs in pseudo-terminal
LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ptyprocess>=0:sysutils/py-ptyprocess@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ptyprocess>=0.5:sysutils/py-ptyprocess@${PY_FLAVOR}
USES= python
-USE_PYTHON= distutils autoplist
+USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/misc/py-pexpect/distinfo b/misc/py-pexpect/distinfo
index 5d0ed0e6dea3..a3f3a8a6e027 100644
--- a/misc/py-pexpect/distinfo
+++ b/misc/py-pexpect/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1532948225
-SHA256 (pexpect-4.6.0.tar.gz) = 2a8e88259839571d1251d278476f3eec5db26deb73a70be5ed5dc5435e418aba
-SIZE (pexpect-4.6.0.tar.gz) = 148966
+TIMESTAMP = 1554646960
+SHA256 (pexpect-4.7.0.tar.gz) = 9e2c1fd0e6ee3a49b28f95d4b33bc389c89b20af6a1255906e90ff1262ce62eb
+SIZE (pexpect-4.7.0.tar.gz) = 153747
diff --git a/misc/py-pexpect/pkg-descr b/misc/py-pexpect/pkg-descr
index e64c7a299b17..e51dff3ba0eb 100644
--- a/misc/py-pexpect/pkg-descr
+++ b/misc/py-pexpect/pkg-descr
@@ -1,14 +1,17 @@
-Pexpect makes Python a better glue for controlling child applications.
-
Pexpect is a pure Python module for spawning child applications; controlling
them; and responding to expected patterns in their output. Pexpect works like
-Don Libes' Expect. Pexpect allows your script to spawn a child application
-and control it as if a human were typing commands.
+Don Libes' Expect. Pexpect allows your script to spawn a child application and
+control it as if a human were typing commands.
Pexpect can be used for automating interactive applications such as ssh, ftp,
passwd, telnet, etc. It can be used to a automate setup scripts for duplicating
software package installations on different servers. It can be used for
automated software testing. Pexpect is in the spirit of Don Libes' Expect, but
-Pexpect is pure Python. The Pexpect interface was designed to be easy to use.
+Pexpect is pure Python.
+
+The main features of Pexpect require the pty module in the Python standard
+library, which is only available on Unix-like systems. Some features -- waiting
+for patterns from file descriptors or subprocesses -- waiting for patterns from
+file descriptors or subprocesses.
WWW: https://pexpect.readthedocs.io/