aboutsummaryrefslogtreecommitdiff
path: root/misc/py-pykml
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-07-29 04:25:13 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-07-29 04:25:13 +0000
commit46da660498156f1913a5e13ca7ae569feb19fbfe (patch)
tree2ec10adfcf792e72df4396029a6475c45f7c023b /misc/py-pykml
parent02187a448d14c0956263df72df266c0c4a79cda7 (diff)
Notes
Diffstat (limited to 'misc/py-pykml')
-rw-r--r--misc/py-pykml/Makefile21
-rw-r--r--misc/py-pykml/distinfo3
-rw-r--r--misc/py-pykml/pkg-descr13
3 files changed, 37 insertions, 0 deletions
diff --git a/misc/py-pykml/Makefile b/misc/py-pykml/Makefile
new file mode 100644
index 000000000000..3ca388d26ce4
--- /dev/null
+++ b/misc/py-pykml/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= pykml
+DISTVERSION= 0.1.3
+CATEGORIES= misc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python KML library, language for encoding, annotating geographic data
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=2.2.6:devel/py-lxml@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils concurrent autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/py-pykml/distinfo b/misc/py-pykml/distinfo
new file mode 100644
index 000000000000..d213e063d088
--- /dev/null
+++ b/misc/py-pykml/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1532835706
+SHA256 (pykml-0.1.3.tar.gz) = e1a133e582f0b4652a6b00bac970b446d90580664e5a634a670731c990ff9f05
+SIZE (pykml-0.1.3.tar.gz) = 43925
diff --git a/misc/py-pykml/pkg-descr b/misc/py-pykml/pkg-descr
new file mode 100644
index 000000000000..f271fd0ea71e
--- /dev/null
+++ b/misc/py-pykml/pkg-descr
@@ -0,0 +1,13 @@
+pyKML is a Python package for creating, parsing, manipulating, and validating
+KML, a language for encoding and annotating geographic data.
+
+pyKML is based on the lxml.objectify API which provides a Pythonic API for
+working with XML documents. pyKML adds additional functionality specific to the
+KML language.
+
+KML comes in several flavors. pyKML can be used with KML documents that follow
+the base OGC KML specification, the Google Extensions Namespace, or a
+user-supplied extension to the base KML specification (defined by an XML Schema
+document).
+
+WWW: https://pythonhosted.org/pykml