aboutsummaryrefslogtreecommitdiff
path: root/misc/pylize
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-06-10 01:46:52 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-06-10 01:46:52 +0000
commit0fd5d33aa55574045828082125ed93e1dc8d8138 (patch)
tree665107a06291c0d384632b31d697a76f60c76a74 /misc/pylize
parent08fa48ea8b62ce39873b80a387a4266a5daed7a8 (diff)
downloadports-0fd5d33aa55574045828082125ed93e1dc8d8138.tar.gz
ports-0fd5d33aa55574045828082125ed93e1dc8d8138.zip
Notes
Diffstat (limited to 'misc/pylize')
-rw-r--r--misc/pylize/Makefile33
-rw-r--r--misc/pylize/distinfo2
-rw-r--r--misc/pylize/pkg-descr14
3 files changed, 49 insertions, 0 deletions
diff --git a/misc/pylize/Makefile b/misc/pylize/Makefile
new file mode 100644
index 000000000000..db1c851cac40
--- /dev/null
+++ b/misc/pylize/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: pylize
+# Date created: Jun 10, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= pylize
+PORTVERSION= 1.1b
+CATEGORIES= misc
+MASTER_SITES= http://www.chrisarndt.de/en/software/pylize/download/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A presentation generation tool
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/HTMLgen.py:${PORTSDIR}/www/py-HTMLgen \
+ ${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/HTMLgen.py:${PORTSDIR}/www/py-HTMLgen \
+ ${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging
+
+USE_BZIP2= yes
+USE_PYTHON= yes
+
+PLIST_FILES= bin/pylize
+
+post-install:
+ @${FIND} ${DATADIR} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${DATADIR} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/misc/pylize/distinfo b/misc/pylize/distinfo
new file mode 100644
index 000000000000..4e6ba84bde51
--- /dev/null
+++ b/misc/pylize/distinfo
@@ -0,0 +1,2 @@
+MD5 (pylize-1.1b.tar.bz2) = ce2f0e9aa37ce4ba262527b49355a6f1
+SIZE (pylize-1.1b.tar.bz2) = 52914
diff --git a/misc/pylize/pkg-descr b/misc/pylize/pkg-descr
new file mode 100644
index 000000000000..d8f1d4bd97f1
--- /dev/null
+++ b/misc/pylize/pkg-descr
@@ -0,0 +1,14 @@
+pylize is a presentation generation tool. Among its features are:
+ * generates a template master document
+ * creates a set of HTML slides from the master document
+ * automatically creates the table of contents and distributes it to
+ serveral slides if necessary
+ * a nice CSS driven slide layout, including logo, navigation links,
+ progress-bar etc.
+ * easy navigation by accesskeys and single-key presses (through JavaScript)
+ * easy changing of layout through templates
+ * all information for a presentation in one master file, but configurable
+ through a per-user options file
+ * fully localized
+
+WWW: http://www.chrisarndt.de/software/pylize/