aboutsummaryrefslogtreecommitdiff
path: root/misc/qbrew/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-05-14 22:41:43 +0000
committerPatrick Li <pat@FreeBSD.org>2002-05-14 22:41:43 +0000
commitf7c047b9872d337336144fa4b1ffd6b0f1f611a2 (patch)
tree232d53787554fb04ded7988a290a2ae56572a505 /misc/qbrew/Makefile
parent52ab9de6268156b7e272afcf1541541a138b2dad (diff)
downloadports-f7c047b9872d337336144fa4b1ffd6b0f1f611a2.tar.gz
ports-f7c047b9872d337336144fa4b1ffd6b0f1f611a2.zip
Notes
Diffstat (limited to 'misc/qbrew/Makefile')
-rw-r--r--misc/qbrew/Makefile28
1 files changed, 25 insertions, 3 deletions
diff --git a/misc/qbrew/Makefile b/misc/qbrew/Makefile
index 0aebebc3d212..96e225c9ae58 100644
--- a/misc/qbrew/Makefile
+++ b/misc/qbrew/Makefile
@@ -6,14 +6,36 @@
#
PORTNAME= qbrew
-PORTVERSION= 0.3.0
+PORTVERSION= 0.3.1
CATEGORIES= misc
MASTER_SITES= http://www.usermode.org/code/
MAINTAINER= david@usermode.org
-USE_QT_VER= 2
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+
+QT_VERSION?= 2
+
+.if ${QT_VERSION} == "3"
+USE_QT_VER= 3
+CONFIGURE_ARGS+=--enable-threads
+pre-everything::
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Configuring for use with Qt 3.x libraries."
+ @${ECHO_MSG} "If you want to compile with Qt 2.x support,"
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make QT_VERSION=2\""
+ @${ECHO_MSG}
+.else
+USE_QT_VER= 2
+pre-everything::
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Configuring for use with Qt 2.x libraries."
+ @${ECHO_MSG} "If you want to compile with Qt 3.x support,"
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make QT_VERSION=3\""
+ @${ECHO_MSG}
+.endif
+
+post-install:
+ strip ${PREFIX}/bin/qbrew
.include <bsd.port.mk>