aboutsummaryrefslogtreecommitdiff
path: root/misc/qbrew
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2007-10-09 22:57:11 +0000
committerBeech Rintoul <beech@FreeBSD.org>2007-10-09 22:57:11 +0000
commitce5142825a60cd9535f0b89c7a90fb9caaa25265 (patch)
tree1b70653fc021688cb8389860f91d30ae1ea45888 /misc/qbrew
parentde0d021646f10173567953989151e0c701b365cf (diff)
downloadports-ce5142825a60cd9535f0b89c7a90fb9caaa25265.tar.gz
ports-ce5142825a60cd9535f0b89c7a90fb9caaa25265.zip
Notes
Diffstat (limited to 'misc/qbrew')
-rw-r--r--misc/qbrew/Makefile33
-rw-r--r--misc/qbrew/distinfo6
-rw-r--r--misc/qbrew/files/patch-qbrew-calc.h22
-rw-r--r--misc/qbrew/pkg-descr3
-rw-r--r--misc/qbrew/pkg-plist7
5 files changed, 19 insertions, 52 deletions
diff --git a/misc/qbrew/Makefile b/misc/qbrew/Makefile
index 674eb6663722..f4b46bd0bb45 100644
--- a/misc/qbrew/Makefile
+++ b/misc/qbrew/Makefile
@@ -6,35 +6,34 @@
#
PORTNAME= qbrew
-PORTVERSION= 0.3.5
-PORTREVISION= 1
+PORTVERSION= 0.4.0
CATEGORIES= misc
MASTER_SITES= http://www.usermode.org/code/
MAINTAINER= david@usermode.org
COMMENT= A homebrewer's recipe calculator
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-USE_QT_VER= 3
+USE_QT_VER= 4
+QT_COMPONENTS= qmake moc uic rcc xml gui
PORTDOCS= *
-QT_NONSTANDARD= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --x-includes=${X11BASE}/include \
- --x-libraries=${X11BASE}/lib \
- --with-qt-dir=${X11BASE}
-CONFIGURE_ENV= MOC=${X11BASE}/bin/moc \
- UIC=${X11BASE}/bin/uic
+HAS_CONFIGURE= yes
-.include <bsd.port.pre.mk>
+CONFIGURE_ENV+= HAVEDEFS="HAVE_ROUND" \
+ BINDIR="${PREFIX}/bin" \
+ DATADIR="${DATADIR}" \
+ DOCDIR="${DOCSDIR}"
-post-patch:
+pre-configure:
.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -E 's,^(SUBDIRS = .*) docs,\1,' \
- ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/INSTALLS/s|doc||' \
+ ${WRKSRC}/qbrew.pro
.endif
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} -unix CONFIG+="configure" qbrew.pro
+
post-install:
${STRIP_CMD} ${PREFIX}/bin/qbrew
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/qbrew/distinfo b/misc/qbrew/distinfo
index af17d1fe7473..5d9f91a9b88f 100644
--- a/misc/qbrew/distinfo
+++ b/misc/qbrew/distinfo
@@ -1,3 +1,3 @@
-MD5 (qbrew-0.3.5.tar.gz) = 677d48a34954deedf3c812e77e6462bb
-SHA256 (qbrew-0.3.5.tar.gz) = 92f9c2cfbeac7f4a158a5cc17bf88ce372ed5bf2219091bf15bf7f0f70023fdb
-SIZE (qbrew-0.3.5.tar.gz) = 458523
+MD5 (qbrew-0.4.0.tar.gz) = 79c60eff3424558f077dd6f807558d6b
+SHA256 (qbrew-0.4.0.tar.gz) = 7b8427f5309dafbbb8b6542642bb31efd8af114fd94c1e8708e0eb1cfda46779
+SIZE (qbrew-0.4.0.tar.gz) = 283844
diff --git a/misc/qbrew/files/patch-qbrew-calc.h b/misc/qbrew/files/patch-qbrew-calc.h
deleted file mode 100644
index 27116742d80e..000000000000
--- a/misc/qbrew/files/patch-qbrew-calc.h
+++ /dev/null
@@ -1,22 +0,0 @@
---- qbrew/calc.h.orig Sat Dec 16 14:34:28 2006
-+++ qbrew/calc.h Sat Dec 16 14:34:52 2006
-@@ -175,15 +175,15 @@
- static int SRM(Recipe *r);
-
- // convert Specific Gravity to Plato
-- static double Calc::SgToP(double sg);
-+ static double SgToP(double sg);
- // convert grain extract to yield
-- static double Calc::extractToYield(double extract);
-- static double Calc::yieldToExtract(double yield);
-+ static double extractToYield(double extract);
-+ static double yieldToExtract(double yield);
-
- // add an entry to the utilization table
- static void addUEntry(const UEntry &u);
- // get the table of utilizations
-- static const QValueList<UEntry> &Calc::getUEntryList();
-+ static const QValueList<UEntry> &getUEntryList();
-
- private:
- static double calcOG(Recipe *r);
diff --git a/misc/qbrew/pkg-descr b/misc/qbrew/pkg-descr
index 550ff13daea0..bb956b9b8b77 100644
--- a/misc/qbrew/pkg-descr
+++ b/misc/qbrew/pkg-descr
@@ -2,6 +2,3 @@ QBrew is a homebrewer's recipe calculator. With it a brewer can formulate new
recipes and calculate gravity, bitterness, color and other attributes.
WWW: http://www.usermode.org/code.html
-
-- David Johnson
-david@usermode.org
diff --git a/misc/qbrew/pkg-plist b/misc/qbrew/pkg-plist
index fa85ef84afaf..43932d13d6a2 100644
--- a/misc/qbrew/pkg-plist
+++ b/misc/qbrew/pkg-plist
@@ -1,11 +1,4 @@
bin/qbrew
-%%DATADIR%%/ChangeLog
-%%DATADIR%%/LICENSE
-%%DATADIR%%/README
-%%DATADIR%%/paleale.qbrew
-%%DATADIR%%/qbrew.png
-%%DATADIR%%/qbrew.svg
%%DATADIR%%/qbrewdata
%%DATADIR%%/splash.png
-%%DATADIR%%/stout.qbrew
@dirrm %%DATADIR%%