aboutsummaryrefslogtreecommitdiff
path: root/misc/qmc
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-20 18:04:52 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-20 18:04:52 +0000
commit8202221baf843da90012732f36fd5b3c1c104b7a (patch)
treec9860346d62cf231c7ded3c5f9ba9ab270bee823 /misc/qmc
parent6055c390fa88a4b31300ba98e6aec7cf9ef584cb (diff)
downloadports-8202221baf843da90012732f36fd5b3c1c104b7a.tar.gz
ports-8202221baf843da90012732f36fd5b3c1c104b7a.zip
Notes
Diffstat (limited to 'misc/qmc')
-rw-r--r--misc/qmc/Makefile27
-rw-r--r--misc/qmc/distinfo1
-rw-r--r--misc/qmc/pkg-comment1
-rw-r--r--misc/qmc/pkg-descr3
-rw-r--r--misc/qmc/pkg-plist1
5 files changed, 33 insertions, 0 deletions
diff --git a/misc/qmc/Makefile b/misc/qmc/Makefile
new file mode 100644
index 000000000000..36f1304ec7b1
--- /dev/null
+++ b/misc/qmc/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# New ports collection makefile for: qmc
+# Date created: Nov 20, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= qmc
+PORTVERSION= 0.92b3
+CATEGORIES= misc
+MASTER_SITES= http://www.pollaknet.at/qmc/program/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/b/bbeta/}
+
+MAINTAINER= ports@FreeBSD.org
+
+NO_WRKSUBDIR= yes
+
+do-build:
+ @(cd ${WRKSRC} ; \
+ ${RM} -f *.o ; \
+ ${CXX} ${CXXFLAGS} -I. *.cc -o qmc)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/qmc ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/misc/qmc/distinfo b/misc/qmc/distinfo
new file mode 100644
index 000000000000..9f71d3b94959
--- /dev/null
+++ b/misc/qmc/distinfo
@@ -0,0 +1 @@
+MD5 (qmc-0.92bbeta3.tar.gz) = cd0a8d6e137ca9230984579f1d25c43f
diff --git a/misc/qmc/pkg-comment b/misc/qmc/pkg-comment
new file mode 100644
index 000000000000..2227bf161e67
--- /dev/null
+++ b/misc/qmc/pkg-comment
@@ -0,0 +1 @@
+Quine-McClusky process simplification tool
diff --git a/misc/qmc/pkg-descr b/misc/qmc/pkg-descr
new file mode 100644
index 000000000000..88e401482891
--- /dev/null
+++ b/misc/qmc/pkg-descr
@@ -0,0 +1,3 @@
+QMC: simplification tool (by using the Quine - McClusky process)
+
+WWW: http://www.pollaknet.at/qmc/
diff --git a/misc/qmc/pkg-plist b/misc/qmc/pkg-plist
new file mode 100644
index 000000000000..e03aeb7768d2
--- /dev/null
+++ b/misc/qmc/pkg-plist
@@ -0,0 +1 @@
+bin/qmc