aboutsummaryrefslogtreecommitdiff
path: root/misc/quick-lounge-applet/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-03-01 08:05:51 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-03-01 08:05:51 +0000
commita00f6a85e10eba0f9ab81ed7ad54a1aeaa9252c6 (patch)
tree4415421b8b6d2d3b9f6ad2c785da6fe2f5afcf17 /misc/quick-lounge-applet/Makefile
parent2a59d677b7eda8f10aa81c599786f737fa406031 (diff)
downloadports-a00f6a85e10eba0f9ab81ed7ad54a1aeaa9252c6.tar.gz
ports-a00f6a85e10eba0f9ab81ed7ad54a1aeaa9252c6.zip
Notes
Diffstat (limited to 'misc/quick-lounge-applet/Makefile')
-rw-r--r--misc/quick-lounge-applet/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/misc/quick-lounge-applet/Makefile b/misc/quick-lounge-applet/Makefile
new file mode 100644
index 000000000000..97321c6f4794
--- /dev/null
+++ b/misc/quick-lounge-applet/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: quick-lounge-applet
+# Date created: 01 March 2003
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= quick-lounge-applet
+PORTVERSION= 1.1.3
+CATEGORIES= misc gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.1
+DIST_SUBDIR= gnome2
+
+MAINTAINER= marcus@FreeBSD.org
+COMMENT= Applet to orginize your preferred applications on the GNOME Panel
+
+LIB_DEPENDS= panel-applet-2.0:${PORTSDIR}/x11/gnomepanel
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>