aboutsummaryrefslogtreecommitdiff
path: root/misc/quotes/Makefile
diff options
context:
space:
mode:
authorBill Fumerola <billf@FreeBSD.org>1999-02-22 01:34:12 +0000
committerBill Fumerola <billf@FreeBSD.org>1999-02-22 01:34:12 +0000
commit8580b6cf502dec6cadf7b6aa507bfc4efe571759 (patch)
tree41fc563c8ce6df43f9b245a83c14f357f5f1b125 /misc/quotes/Makefile
parent2d574f0244c49e2a05b074ee8272e58d0a0c1ab0 (diff)
downloadports-8580b6cf502dec6cadf7b6aa507bfc4efe571759.tar.gz
ports-8580b6cf502dec6cadf7b6aa507bfc4efe571759.zip
Notes
Diffstat (limited to 'misc/quotes/Makefile')
-rw-r--r--misc/quotes/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/misc/quotes/Makefile b/misc/quotes/Makefile
new file mode 100644
index 000000000000..96ea4663ba0d
--- /dev/null
+++ b/misc/quotes/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: quotes
+# Version required: 1.3.0
+# Date created: 9 February 1999
+# Whom: Dima Sivachenko
+#
+# $Id: $
+#
+
+DISTNAME= quotes-1.3-0
+PKGNAME= quotes-1.3.0
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.iae.nl/pub/users/grimaldo/ \
+ http://www.FreeBSD.org/~billf/distfiles/
+
+MAINTAINER= dima@Chg.RU
+
+WRKSRC= ${WRKDIR}/Quotes-1.3-0
+
+NO_BUILD= yes
+USE_PERL5= yes
+
+post-patch:
+
+ @ ${MV} ${WRKSRC}/quotes ${WRKSRC}/quotes.pre_sed
+ @ ${SED} -e 's#/usr/bin/perl#${PERL5}#' ${WRKSRC}/quotes.pre_sed \
+ > ${WRKSRC}/quotes
+ @ ${MV} ${WRKSRC}/QuExample.pm ${WRKSRC}/QuExample.pm.pre_sed
+ @ ${SED} -e 's#/usr/bin/perl#${PERL5}#' ${WRKSRC}/QuExample.pm.pre_sed \
+ > ${WRKSRC}/QuExample.pm
+
+do-install:
+
+ @ ${INSTALL_SCRIPT} ${WRKSRC}/quotes ${PREFIX}/bin
+ @ ${INSTALL_DATA} ${WRKSRC}/sample.quotesrc ${PREFIX}/etc
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/quotes
+ @ ${INSTALL_DATA} ${WRKSRC}/quotes.txt ${PREFIX}/share/doc/quotes
+ @ ${INSTALL_DATA} ${WRKSRC}/QuExample.pm ${PREFIX}/share/doc/quotes
+.endif
+
+.include <bsd.port.mk>