aboutsummaryrefslogtreecommitdiff
path: root/misc/rubygem-ohcount
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-06-07 18:58:02 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-06-07 18:58:02 +0000
commitb366a2b53ac40df0d0b18d0ae3089113ed2fa689 (patch)
treef04012faf1f0b7998dab26d67e2762be7f343385 /misc/rubygem-ohcount
parent47bb74f74fea547c6c57adc223bea1b78408884f (diff)
downloadports-b366a2b53ac40df0d0b18d0ae3089113ed2fa689.tar.gz
ports-b366a2b53ac40df0d0b18d0ae3089113ed2fa689.zip
Notes
Diffstat (limited to 'misc/rubygem-ohcount')
-rw-r--r--misc/rubygem-ohcount/Makefile26
-rw-r--r--misc/rubygem-ohcount/distinfo3
-rw-r--r--misc/rubygem-ohcount/pkg-descr10
3 files changed, 39 insertions, 0 deletions
diff --git a/misc/rubygem-ohcount/Makefile b/misc/rubygem-ohcount/Makefile
new file mode 100644
index 000000000000..8b4b66532986
--- /dev/null
+++ b/misc/rubygem-ohcount/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: ohcount
+# Date created: 2009-05-31
+# Whom: Edmondas Girkantas <eg@fbsd.lt>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ohcount
+PORTVERSION= 2.0.1
+CATEGORIES= misc rubygems
+MASTER_SITES= http://labs.ohloh.net/download/
+
+MAINTAINER= eg@fbsd.lt
+COMMENT= Ohcount is the source code line counter that powers Ohloh
+
+BUILD_DEPENDS= rubygem-diff-lcs>=1.1.2:${PORTSDIR}/textproc/rubygem-diff-lcs \
+ ragel:${PORTSDIR}/devel/ragel
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+USE_RAKE= yes
+RUBYGEM_AUTOPLIST= yes
+PLIST_FILES= bin/ohcount
+
+.include <bsd.port.mk>
diff --git a/misc/rubygem-ohcount/distinfo b/misc/rubygem-ohcount/distinfo
new file mode 100644
index 000000000000..a2bc1f6e3ee8
--- /dev/null
+++ b/misc/rubygem-ohcount/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/ohcount-2.0.1.gem) = 078ba2bc6b7d0a498804b2fad840973d
+SHA256 (rubygem/ohcount-2.0.1.gem) = 4afc7e03bc6e738b519cf2af897120d93f7937ad5636aed19c60d67604f09cf9
+SIZE (rubygem/ohcount-2.0.1.gem) = 287744
diff --git a/misc/rubygem-ohcount/pkg-descr b/misc/rubygem-ohcount/pkg-descr
new file mode 100644
index 000000000000..670fbfd379b0
--- /dev/null
+++ b/misc/rubygem-ohcount/pkg-descr
@@ -0,0 +1,10 @@
+Ohcount is the source code line counter that powers Ohloh. Ohcount supports
+over 70 popular programming languages, and has been used to count over 3
+billion lines of code by 200,000 developers!
+
+Ohcount does more than just count lines of code. It can also detect popular
+open source licenses such as GPL within a large directory of source code.
+It can also detect code that targets a particular programming API, such as
+Win32 or KDE.
+
+WWW: http://labs.ohloh.net/ohcount/