aboutsummaryrefslogtreecommitdiff
path: root/misc/saaghar
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-02-20 17:54:32 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-02-20 17:54:32 +0000
commit817046e37002b3beda0302d3adaccdc3e282705a (patch)
tree0402f5e268669709206189a9eca42f86eab524f1 /misc/saaghar
parentaf1457e3332fa33912c6defe8a1f0d30dfa1c26e (diff)
downloadports-817046e37002b3beda0302d3adaccdc3e282705a.tar.gz
ports-817046e37002b3beda0302d3adaccdc3e282705a.zip
Notes
Diffstat (limited to 'misc/saaghar')
-rw-r--r--misc/saaghar/Makefile50
-rw-r--r--misc/saaghar/distinfo4
-rw-r--r--misc/saaghar/pkg-descr16
-rw-r--r--misc/saaghar/pkg-plist127
4 files changed, 197 insertions, 0 deletions
diff --git a/misc/saaghar/Makefile b/misc/saaghar/Makefile
new file mode 100644
index 000000000000..2fbc4a60bd52
--- /dev/null
+++ b/misc/saaghar/Makefile
@@ -0,0 +1,50 @@
+# $FreeBSD$
+
+PORTNAME= saaghar
+PORTVERSION= 1.0.94
+CATEGORIES= misc
+MASTER_SITES= SF/saaghar/Source%20Code/:saaghar \
+ SF/ganjoor/s3db:ganjoor
+DISTFILES= Saaghar-${PORTVERSION}.tar.gz:saaghar \
+ ganjoor-s3db-910612.zip:ganjoor
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= javad.kouhi@gmail.com
+COMMENT= Persian poetry software
+
+LICENSE= GPLv3
+
+EXTRACT_DEPENDS= ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip
+
+USE_QT4= gui network sql xml sql-sqlite3_run \
+ moc_build qmake_build rcc_build uic_build
+HAS_CONFIGURE= yes
+QMAKEFLAGS+= PREFIX=${PREFIX}
+WRKSRC= ${WRKDIR}/Saaghar
+
+.include <bsd.port.options.mk>
+
+.if !${PORT_OPTIONS:MDEBUG}
+QMAKEFLAGS+= -config release
+.endif
+
+post-extract:
+ ${UNZIP_CMD} -d ${WRKDIR}/ganjoor \
+ ${DISTDIR}/${DIST_SUBDIR}/ganjoor-s3db-910612.zip
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share/saaghar/|${PREFIX}/share/saaghar|g' \
+ ${WRKSRC}/mainwindow.cpp
+ @${REINPLACE_CMD} -e '1 s|^.*/|/|g' \
+ ${WRKSRC}/QGanjoorDbBrowser.cpp \
+ ${WRKSRC}/QGanjoorDbStuff.h \
+ ${WRKSRC}/mainwindow.cpp
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} ${QMAKEFLAGS} saaghar.pro
+
+post-install:
+ cd ${WRKDIR}/ganjoor && ${COPYTREE_SHARE} . ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/misc/saaghar/distinfo b/misc/saaghar/distinfo
new file mode 100644
index 000000000000..6316c59b7ced
--- /dev/null
+++ b/misc/saaghar/distinfo
@@ -0,0 +1,4 @@
+SHA256 (saaghar/Saaghar-1.0.94.tar.gz) = 03a5d0e3f0e1ad65aefd6fa083d6bc7920c47c16fecafe0b5005bc2fe42b6391
+SIZE (saaghar/Saaghar-1.0.94.tar.gz) = 3907520
+SHA256 (saaghar/ganjoor-s3db-910612.zip) = 16c3ec40d6e6ba413e560053fbcfc2e76571f4a4b7c72cdc633edbd0fc0a3d96
+SIZE (saaghar/ganjoor-s3db-910612.zip) = 33854736
diff --git a/misc/saaghar/pkg-descr b/misc/saaghar/pkg-descr
new file mode 100644
index 000000000000..c1bf8611369c
--- /dev/null
+++ b/misc/saaghar/pkg-descr
@@ -0,0 +1,16 @@
+Saaghar is a cross-platform Persian poetry software.
+It uses "ganjoor.net" database as its database.
+It has lots of features:
+
+* Tabbed UI
+* Tabbed and dockable search widgets
+* Advanced Search
+* Search for Rhymes
+* Print and Print Preview
+* Export, It supports exporting to "PDF", "HTML", "TeX", "CSV" and "TXT"
+* Copy and Multi-selection
+* Icons Theme
+* Customisable interface
+* Portable Mode
+
+WWW: http://www.pozh.org/saaghar
diff --git a/misc/saaghar/pkg-plist b/misc/saaghar/pkg-plist
new file mode 100644
index 000000000000..9bbbf1bef33e
--- /dev/null
+++ b/misc/saaghar/pkg-plist
@@ -0,0 +1,127 @@
+bin/saaghar
+share/applications/Saaghar.desktop
+share/pixmaps/saaghar.png
+share/saaghar/AUTHORS
+share/saaghar/CHANGELOG
+share/saaghar/COPYING
+share/saaghar/LICENSE
+share/saaghar/README
+share/saaghar/Saaghar-Manual.pdf
+share/saaghar/TODO
+share/saaghar/ganjoor.s3db
+share/saaghar/poets_images/10.png
+share/saaghar/poets_images/11.png
+share/saaghar/poets_images/12.png
+share/saaghar/poets_images/13.png
+share/saaghar/poets_images/14.png
+share/saaghar/poets_images/15.png
+share/saaghar/poets_images/16.png
+share/saaghar/poets_images/17.png
+share/saaghar/poets_images/18.png
+share/saaghar/poets_images/19.png
+share/saaghar/poets_images/2.png
+share/saaghar/poets_images/20.png
+share/saaghar/poets_images/21.png
+share/saaghar/poets_images/22.png
+share/saaghar/poets_images/23.png
+share/saaghar/poets_images/24.png
+share/saaghar/poets_images/25.png
+share/saaghar/poets_images/26.png
+share/saaghar/poets_images/27.png
+share/saaghar/poets_images/28.png
+share/saaghar/poets_images/29.png
+share/saaghar/poets_images/3.png
+share/saaghar/poets_images/30.png
+share/saaghar/poets_images/31.png
+share/saaghar/poets_images/32.png
+share/saaghar/poets_images/33.png
+share/saaghar/poets_images/34.png
+share/saaghar/poets_images/35.png
+share/saaghar/poets_images/37.png
+share/saaghar/poets_images/38.png
+share/saaghar/poets_images/39.png
+share/saaghar/poets_images/4.png
+share/saaghar/poets_images/40.png
+share/saaghar/poets_images/41.png
+share/saaghar/poets_images/42.png
+share/saaghar/poets_images/43.png
+share/saaghar/poets_images/44.png
+share/saaghar/poets_images/45.png
+share/saaghar/poets_images/46.png
+share/saaghar/poets_images/47.png
+share/saaghar/poets_images/48.png
+share/saaghar/poets_images/49.png
+share/saaghar/poets_images/5.png
+share/saaghar/poets_images/50.png
+share/saaghar/poets_images/501.png
+share/saaghar/poets_images/502.png
+share/saaghar/poets_images/503.png
+share/saaghar/poets_images/504.png
+share/saaghar/poets_images/505.png
+share/saaghar/poets_images/506.png
+share/saaghar/poets_images/51.png
+share/saaghar/poets_images/6.png
+share/saaghar/poets_images/600.png
+share/saaghar/poets_images/602.png
+share/saaghar/poets_images/610.png
+share/saaghar/poets_images/7.png
+share/saaghar/poets_images/8.png
+share/saaghar/poets_images/9.png
+share/saaghar/qt_fa.qm
+share/saaghar/saaghar_fa.qm
+share/saaghar/themes/backgrounds/bgpatterns_1.png
+share/saaghar/themes/backgrounds/bgpatterns_2.png
+share/saaghar/themes/backgrounds/bgpatterns_3.png
+share/saaghar/themes/backgrounds/bgpatterns_4.png
+share/saaghar/themes/backgrounds/grav-rand_1.png
+share/saaghar/themes/backgrounds/grav-rand_2.png
+share/saaghar/themes/backgrounds/grav-rand_3.png
+share/saaghar/themes/backgrounds/grav-rand_4.png
+share/saaghar/themes/backgrounds/saaghar-pattern_1.png
+share/saaghar/themes/backgrounds/woodw-blue_1.png
+share/saaghar/themes/backgrounds/woodw-golden_1.png
+share/saaghar/themes/backgrounds/woodw-golden_2.png
+share/saaghar/themes/backgrounds/woodw-green_1.png
+share/saaghar/themes/backgrounds/woodw_3d_1.png
+share/saaghar/themes/iconsets/light-gray/README
+share/saaghar/themes/iconsets/light-gray/browse_net.png
+share/saaghar/themes/iconsets/light-gray/cancel.png
+share/saaghar/themes/iconsets/light-gray/check-updates.png
+share/saaghar/themes/iconsets/light-gray/clear-left.png
+share/saaghar/themes/iconsets/light-gray/clear-right.png
+share/saaghar/themes/iconsets/light-gray/close-tab.png
+share/saaghar/themes/iconsets/light-gray/copy.png
+share/saaghar/themes/iconsets/light-gray/down.png
+share/saaghar/themes/iconsets/light-gray/exit.png
+share/saaghar/themes/iconsets/light-gray/export-pdf.png
+share/saaghar/themes/iconsets/light-gray/export.png
+share/saaghar/themes/iconsets/light-gray/faal.png
+share/saaghar/themes/iconsets/light-gray/filter.png
+share/saaghar/themes/iconsets/light-gray/fullscreen.png
+share/saaghar/themes/iconsets/light-gray/home.png
+share/saaghar/themes/iconsets/light-gray/import-to-database.png
+share/saaghar/themes/iconsets/light-gray/left.png
+share/saaghar/themes/iconsets/light-gray/new_tab.png
+share/saaghar/themes/iconsets/light-gray/new_window.png
+share/saaghar/themes/iconsets/light-gray/next.png
+share/saaghar/themes/iconsets/light-gray/no-fullscreen.png
+share/saaghar/themes/iconsets/light-gray/ocr-verification.png
+share/saaghar/themes/iconsets/light-gray/previous.png
+share/saaghar/themes/iconsets/light-gray/print-preview.png
+share/saaghar/themes/iconsets/light-gray/print.png
+share/saaghar/themes/iconsets/light-gray/qt-logo.png
+share/saaghar/themes/iconsets/light-gray/random.png
+share/saaghar/themes/iconsets/light-gray/remove-poet.png
+share/saaghar/themes/iconsets/light-gray/right.png
+share/saaghar/themes/iconsets/light-gray/search-options.png
+share/saaghar/themes/iconsets/light-gray/search.png
+share/saaghar/themes/iconsets/light-gray/select-mask.png
+share/saaghar/themes/iconsets/light-gray/settings.png
+share/saaghar/themes/iconsets/light-gray/up.png
+@dirrm share/saaghar/themes/iconsets/light-gray
+@dirrm share/saaghar/themes/iconsets
+@dirrm share/saaghar/themes/backgrounds
+@dirrm share/saaghar/themes
+@dirrm share/saaghar/poets_images
+@dirrm share/saaghar
+@dirrmtry share/applications