aboutsummaryrefslogtreecommitdiff
path: root/misc/seizedesktop
diff options
context:
space:
mode:
authorKiriyama Kazuhiko <kiri@FreeBSD.org>2003-05-08 10:40:48 +0000
committerKiriyama Kazuhiko <kiri@FreeBSD.org>2003-05-08 10:40:48 +0000
commite78f22042242e220b1d4069db9569a787824f003 (patch)
tree624ef151fac983805aa268b78e8f085031ee35f8 /misc/seizedesktop
parentd6f6abdd3e5f3dc8469bf1c7fb6c95b45c659ce0 (diff)
downloadports-e78f22042242e220b1d4069db9569a787824f003.tar.gz
ports-e78f22042242e220b1d4069db9569a787824f003.zip
Notes
Diffstat (limited to 'misc/seizedesktop')
-rw-r--r--misc/seizedesktop/Makefile11
-rw-r--r--misc/seizedesktop/pkg-descr2
-rw-r--r--misc/seizedesktop/pkg-plist1
-rw-r--r--misc/seizedesktop/scripts/post-install12
4 files changed, 16 insertions, 10 deletions
diff --git a/misc/seizedesktop/Makefile b/misc/seizedesktop/Makefile
index 7651eda6657d..18d5a13772c7 100644
--- a/misc/seizedesktop/Makefile
+++ b/misc/seizedesktop/Makefile
@@ -8,11 +8,13 @@
PORTNAME= seizedesktop
PORTVERSION= 0.1a
CATEGORIES+= misc windowmaker tkstep80
-MASTER_SITES= http://www.aaa-int.or.jp/~jfactory/Factory/JDE/dist/
+MASTER_SITES= http://www.aaa-int.or.jp/~jfactory/JDE/dist/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= . kiri
DISTNAME= SeizeDesktop-${PORTVERSION}
EXTRACT_ONLY= # extracted directly in install target
-MAINTAINER= kiri@pis.toba-cmt.ac.jp
+MAINTAINER= kiri@FreeBSD.org
COMMENT= A customizer of desktop screen environment
RUN_DEPENDS= ${RUN_DEP_LIST}
@@ -21,7 +23,10 @@ LIB_DEPENDS= ${LIB_DEP_LIST}
NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_X_PREFIX= yes
-SCRIPTS_ENV= LANG=C LN=${LN} PERL=${PERL} LANGUAGE=${LANGUAGE} VERSION=${TKSTEPVERSION}
+USE_REINPLACE= yes
+REINPLACE_ARGS=
+SCRIPTS_ENV= LANG=C LN=${LN} REINPLACE_CMD='${REINPLACE_CMD}' \
+ LANGUAGE=${LANGUAGE} VERSION=${TKSTEPVERSION}
# This port is for both misc/seizedesktop and japanese/seizedesktop.
# But misc/seizedesktop and japanese/seizedesktop are mutually exclusive and
diff --git a/misc/seizedesktop/pkg-descr b/misc/seizedesktop/pkg-descr
index be005d0fabd6..9a0932961869 100644
--- a/misc/seizedesktop/pkg-descr
+++ b/misc/seizedesktop/pkg-descr
@@ -4,4 +4,4 @@ Note that both x11-toolkits/seizedesktop and japanese/seizedesktop
are mutually exclusive and SHOULD NOT BE INSTALLED SIMULTANEOUSLY!
-KIRIYAMA Kazuhiko
-<kiri@pis.toba-cmt.ac.jp>
+<kiri@FreeBSD.org>
diff --git a/misc/seizedesktop/pkg-plist b/misc/seizedesktop/pkg-plist
index 42132f73c667..fecde8ac7165 100644
--- a/misc/seizedesktop/pkg-plist
+++ b/misc/seizedesktop/pkg-plist
@@ -138,3 +138,4 @@ bin/SeizeDesktop.app
@dirrm JDE/SeizeDesktop/WindowMaker/screenshot
@dirrm JDE/SeizeDesktop/WindowMaker
@dirrm JDE/SeizeDesktop
+@unexec rmdir %D/JDE 2>/dev/null || true
diff --git a/misc/seizedesktop/scripts/post-install b/misc/seizedesktop/scripts/post-install
index 21d72020d3f3..d770a5394f35 100644
--- a/misc/seizedesktop/scripts/post-install
+++ b/misc/seizedesktop/scripts/post-install
@@ -5,9 +5,9 @@ installdir=${PREFIX}/JDE/SeizeDesktop; export installdir
case ${LANGUAGE} in
Japanese)
for f in SeizeDesktop.app PrefDesktop.app; do
- ${PERL} -pi -e '
- s/^(exec[ \t]+)wishstep[^ \t]*([ \t]+.*)$/$1wishstep$ENV{VERSION}jp$2/
- ' ${installdir}/bin/${f}
+ ${REINPLACE_CMD} -i "" -E -e \
+ "s/^(exec[[:space:]]+)wishstep[[:space:]]*([[:space:]]+.*)\$/\1wishstep${VERSION}jp\2/" \
+ ${installdir}/bin/${f}
done
;;
*)
@@ -22,9 +22,9 @@ for f in SeizeDesktop SeizeDesktop.app PrefDesktop.app; do
target=${installdir}/default/${f}
;;
esac
- ${PERL} -pi -e '
- s/^([ \t]*set[ \t]+dtLib[ \t]+)"[^"]*"$/$1"$ENV{installdir}"/;
- ' ${target}
+ ${REINPLACE_CMD} -i "" -E -e \
+ "s@^([[:space:]]*set[[:space:]]+dtLib[[:space:]]+)\"[^\"]*\"\$@\1\"${installdir}\"@" \
+ ${target}
done
${LN} -sf ${installdir}/bin/SeizeDesktop.app ${PREFIX}/bin