aboutsummaryrefslogtreecommitdiff
path: root/misc/shared-mime-info/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-12-26 07:05:08 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-12-26 07:05:08 +0000
commitedd78a5bb3e7ba85c228ef6087f5bc99fcbdfe72 (patch)
tree3f193c161423adad8cd0fff9f78d8e5654693789 /misc/shared-mime-info/Makefile
parentf9e8cb33cde9bb7bfafcfe3b3cd202b48047d613 (diff)
downloadports-edd78a5bb3e7ba85c228ef6087f5bc99fcbdfe72.tar.gz
ports-edd78a5bb3e7ba85c228ef6087f5bc99fcbdfe72.zip
Notes
Diffstat (limited to 'misc/shared-mime-info/Makefile')
-rw-r--r--misc/shared-mime-info/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/misc/shared-mime-info/Makefile b/misc/shared-mime-info/Makefile
index 0c76e02585e8..ff161d97d596 100644
--- a/misc/shared-mime-info/Makefile
+++ b/misc/shared-mime-info/Makefile
@@ -6,7 +6,7 @@
PORTNAME= shared-mime-info
PORTVERSION= 0.15
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= misc gnome
MASTER_SITES= http://www.marcuscom.com/downloads/ \
http://www.freedesktop.org/software/shared-mime-info/
@@ -21,6 +21,8 @@ USE_GNOME= glib20 libxml2 intltool gnomehack
MAN1= update-mime-database.1
+PKGINSTALL= ${WRKDIR}/pkg-install
+
MIMEDIRS= ${X11BASE}/share/gnome/mime \
${LOCALBASE}/share/gnome/mime \
${X11BASE}/share/mime \
@@ -34,4 +36,9 @@ post-patch:
s|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/update-mime-database.c
+post-install:
+ @${SED} -e 's|%%PREFIX%%|${PREFIX}| ; \
+ s|%%MIMEDIRS%%|${MIMEDIRS}|' \
+ < ${FILESDIR}/pkg-install.in > ${PKGINSTALL}
+
.include <bsd.port.mk>