aboutsummaryrefslogtreecommitdiff
path: root/misc/since
diff options
context:
space:
mode:
authorJohann Visagie <wjv@FreeBSD.org>2002-02-11 10:49:40 +0000
committerJohann Visagie <wjv@FreeBSD.org>2002-02-11 10:49:40 +0000
commit14aa8989b2b1ba0affd08466195f413a558006a9 (patch)
treec2662a28515c8ec6f21ed3735ede754a0844389e /misc/since
parent021900e87b07f2ece8a80a72e37f61d05917ca36 (diff)
downloadports-14aa8989b2b1ba0affd08466195f413a558006a9.tar.gz
ports-14aa8989b2b1ba0affd08466195f413a558006a9.zip
Notes
Diffstat (limited to 'misc/since')
-rw-r--r--misc/since/Makefile17
-rw-r--r--misc/since/distinfo1
-rw-r--r--misc/since/files/patch-Makefile31
-rw-r--r--misc/since/pkg-comment1
-rw-r--r--misc/since/pkg-descr10
-rw-r--r--misc/since/pkg-plist1
6 files changed, 61 insertions, 0 deletions
diff --git a/misc/since/Makefile b/misc/since/Makefile
new file mode 100644
index 000000000000..6a66be6634c8
--- /dev/null
+++ b/misc/since/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: py-martel
+# Date created: 11 February 2002
+# Whom: Johann Visagie <wjv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= since
+PORTVERSION= 0.3
+CATEGORIES= misc
+MASTER_SITES= ftp://jade.cs.uct.ac.za/pub/
+
+MAINTAINER= wjv@FreeBSD.org
+
+MAN1= since.1
+
+.include <bsd.port.mk>
diff --git a/misc/since/distinfo b/misc/since/distinfo
new file mode 100644
index 000000000000..cc6ddad0c128
--- /dev/null
+++ b/misc/since/distinfo
@@ -0,0 +1 @@
+MD5 (since-0.3.tar.gz) = 0575abb4f0b824ec04a0bce425e61df3
diff --git a/misc/since/files/patch-Makefile b/misc/since/files/patch-Makefile
new file mode 100644
index 000000000000..90a5d57f1be2
--- /dev/null
+++ b/misc/since/files/patch-Makefile
@@ -0,0 +1,31 @@
+--- Makefile.orig Mon May 7 13:05:30 2001
++++ Makefile Mon Feb 11 12:37:38 2002
+@@ -16,8 +16,8 @@
+ ###########################################################################
+ # Compiler and Flags ######################################################
+
+-CC = gcc
+-CFLAGS = -Wall -O2 -fomit-frame-pointer -DVERSION=\"$(VERSION)\"
++#CC = gcc
++CFLAGS += -Wall -fomit-frame-pointer -DVERSION=\"$(VERSION)\"
+ STRIP = strip
+
+ #CFLAGS += -DTRACE
+@@ -43,15 +43,14 @@
+ # Install #################################################################
+
+ install : $(TARGET)
+- $(INSTALL) -m 0755 $(TARGET) $(INTARGET)
+- $(INSTALL) -m 0644 $(MAN) $(INMAN)
++ $(BSD_INSTALL_PROGRAM) $(TARGET) $(PREFIX)/bin/$(TARGET)
++ $(BSD_INSTALL_MAN) $(MAN) $(PREFIX)/man/man1/$(MAN)
+
+ ###########################################################################
+ # Build since executable ##################################################
+
+ $(TARGET) : $(OBJ)
+ $(CC) $(CFLAGS) $(OBJ) -o $(TARGET)
+- $(STRIP) $(TARGET)
+
+ ###########################################################################
+ # Build object files from source ##########################################
diff --git a/misc/since/pkg-comment b/misc/since/pkg-comment
new file mode 100644
index 000000000000..195cdb34ed99
--- /dev/null
+++ b/misc/since/pkg-comment
@@ -0,0 +1 @@
+View the end of a file like tail(1), but save state between sessions
diff --git a/misc/since/pkg-descr b/misc/since/pkg-descr
new file mode 100644
index 000000000000..f75d266e7306
--- /dev/null
+++ b/misc/since/pkg-descr
@@ -0,0 +1,10 @@
+Paraphrasing since(1):
+
+ since is similar to tail(1) since it also displays the tail of a file.
+ However, since displays only the data which has been added since the last
+ time since was run. If since has not been run before, the entire file is
+ displayed. since is useful for watching over log files.
+
+Author: Marc Welz <marc@jade.cs.uct.ac.za>
+
+-- Johann Visagie <wjv@FreeBSD.org>
diff --git a/misc/since/pkg-plist b/misc/since/pkg-plist
new file mode 100644
index 000000000000..e33763b68bdc
--- /dev/null
+++ b/misc/since/pkg-plist
@@ -0,0 +1 @@
+bin/since