aboutsummaryrefslogtreecommitdiff
path: root/misc/since
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2009-06-17 18:20:23 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2009-06-17 18:20:23 +0000
commit8c53ad9c7ebb35fc17baa41b34bc7167a6bfd565 (patch)
treed5b47f4dc9e812aef018e6bb397fa88eaa1039f0 /misc/since
parent47cc9f7670a757ad052b07035ffe56ae7ad5d1e7 (diff)
downloadports-8c53ad9c7ebb35fc17baa41b34bc7167a6bfd565.tar.gz
ports-8c53ad9c7ebb35fc17baa41b34bc7167a6bfd565.zip
Notes
Diffstat (limited to 'misc/since')
-rw-r--r--misc/since/Makefile8
-rw-r--r--misc/since/distinfo6
-rw-r--r--misc/since/files/patch-Makefile47
-rw-r--r--misc/since/files/patch-since.18
-rw-r--r--misc/since/pkg-descr10
5 files changed, 45 insertions, 34 deletions
diff --git a/misc/since/Makefile b/misc/since/Makefile
index 58ca8cf78c74..69005caaec2c 100644
--- a/misc/since/Makefile
+++ b/misc/since/Makefile
@@ -6,16 +6,18 @@
#
PORTNAME= since
-PORTVERSION= 0.5
+PORTVERSION= 0.9
CATEGORIES= misc
-MASTER_SITES= http://welz.org.za/projects/since/ \
- http://fresh.t-systems-sfr.com/linux/src/
+MASTER_SITES= http://welz.org.za/projects/since/
MAINTAINER= tabthorpe@FreeBSD.org
COMMENT= View the end of a file like tail(1), but save state between sessions
+USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
+ALL_TARGET= ${PORTNAME}
+
MAN1= since.1
PLIST_FILES= bin/since
diff --git a/misc/since/distinfo b/misc/since/distinfo
index e94dab80fbf1..3ba574ac05a5 100644
--- a/misc/since/distinfo
+++ b/misc/since/distinfo
@@ -1,3 +1,3 @@
-MD5 (since-0.5.tar.gz) = 923c23f5198380cae42cbcaf411f3bca
-SHA256 (since-0.5.tar.gz) = 179afff70f9e13fbdfda72e5b3862fd84f6eed7631543f696108012dba9abf64
-SIZE (since-0.5.tar.gz) = 12557
+MD5 (since-0.9.tar.gz) = f33295867f2e0674e69de59bee2eb6a7
+SHA256 (since-0.9.tar.gz) = 118fe2275f77039cce56161ea067d3731f690fb9446942d7bf249253d7c9de83
+SIZE (since-0.9.tar.gz) = 24804
diff --git a/misc/since/files/patch-Makefile b/misc/since/files/patch-Makefile
index 3986873f90f1..845acf7acd30 100644
--- a/misc/since/files/patch-Makefile
+++ b/misc/since/files/patch-Makefile
@@ -1,24 +1,29 @@
---- Makefile.orig Sun Oct 6 15:02:43 2002
-+++ Makefile Sat Sep 17 00:46:29 2005
-@@ -7,8 +7,8 @@
- MANDIR = /usr/local/man/man1
+--- ./Makefile.orig 2009-01-05 15:52:55.000000000 -0500
++++ ./Makefile 2009-06-17 14:05:36.000000000 -0400
+@@ -1,4 +1,4 @@
+-prefix=/usr/local
++#prefix=/usr/local
- # Compiler and Flags
--CC = gcc
--CFLAGS = -Wall -O2
-+#CC = gcc
-+#CFLAGS = -Wall -O2
- RM = rm -f
- INSTALL = install -c
- LINK = ln -s
-@@ -20,8 +20,8 @@
+ NAME = since
+ VERSION = 0.9
+@@ -9,16 +9,16 @@
+ CFLAGS += -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+ #CFLAGS += -DDEBUG
- # Install
- install : $(TARGET)
-- $(INSTALL) -m 0755 $(TARGET) $(BINDIR)
-- $(INSTALL) -m 0644 $(MAN) $(MANDIR)
-+ $(BSD_INSTALL_PROGRAM) $(TARGET) $(PREFIX)/bin/$(TARGET)
-+ $(BSD_INSTALL_MAN) $(MAN) $(PREFIX)/man/man1/$(MAN)
+-CC = gcc
++#CC = gcc
+ RM = rm -f
+-INSTALL = install -D
++#INSTALL = install -D
- # Build since executable
- $(TARGET) : $(OBJ)
+ $(NAME): $(NAME).c
+ $(CC) $(CFLAGS) -o $@ $^
+
+ install: $(NAME)
+- $(INSTALL) $(NAME) $(prefix)/bin/$(NAME)
+- $(INSTALL) $(NAME).1 $(prefix)/share/man1/$(NAME).1
++ $(BSD_INSTALL_PROGRAM) $(NAME) $(PREFIX)/bin/$(NAME)
++ $(BSD_INSTALL_MAN) $(NAME).1 $(PREFIX)/man/man1/$(NAME).1
+
+ clean:
+ $(RM) $(NAME) core *.o
diff --git a/misc/since/files/patch-since.1 b/misc/since/files/patch-since.1
new file mode 100644
index 000000000000..8358d3cf5d7f
--- /dev/null
+++ b/misc/since/files/patch-since.1
@@ -0,0 +1,8 @@
+--- ./since.1.orig 2009-01-05 15:52:55.000000000 -0500
++++ ./since.1 2009-06-17 14:06:14.000000000 -0400
+@@ -1,4 +1,4 @@
+-.TH SINCE 1 "JULY 1998" Linux "User Manuals"
++.TH SINCE 1 "JULY 1998" FreeBSD "User Manuals"
+ .SH NAME
+ since \- display content of a file since the last time
+ .SH SYNOPSIS
diff --git a/misc/since/pkg-descr b/misc/since/pkg-descr
index 1a2f85ba84b1..647607211c15 100644
--- a/misc/since/pkg-descr
+++ b/misc/since/pkg-descr
@@ -1,9 +1,5 @@
-Paraphrasing since(1):
-
- since is similar to tail(1) since it also displays the tail of a
- file. However, since displays only the data which has been added
- since the last time since was run. If since has not been run
- before, the entire file is displayed. since is useful for watching
- over log files.
+since is a unix utility similar to tail. Unlike tail, since only
+shows the lines appended since the last time. It is useful to monitor
+growing log files.
WWW: http://welz.org.za/projects/since