aboutsummaryrefslogtreecommitdiff
path: root/misc/sloccount/Makefile
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-08-27 15:43:26 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-08-27 15:43:26 +0000
commitf265d6c1d6bd0bdd6a9f1031ec0ad56ee3a4ec81 (patch)
tree203650df30da984d05e1d81c94291e3dc5fbb3d6 /misc/sloccount/Makefile
parent727a86a656e90b59acf10752ddb4e3768aa52f4f (diff)
Notes
Diffstat (limited to 'misc/sloccount/Makefile')
-rw-r--r--misc/sloccount/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/misc/sloccount/Makefile b/misc/sloccount/Makefile
index 3dd9714847b5..15418c4a2253 100644
--- a/misc/sloccount/Makefile
+++ b/misc/sloccount/Makefile
@@ -7,18 +7,26 @@
#
PORTNAME= sloccount
-PORTVERSION= 1.8
+PORTVERSION= 1.9
CATEGORIES= misc
MASTER_SITES= http://www.dwheeler.com/sloccount/
MAINTAINER= ports@FreeBSD.org
MAKEFILE= makefile
+INSTALL_TARGET= install_programs install_man
-MANCOMPRESSED= yes
-MAN1= sloccount.1
+MAN1= sloccount.1
-pre-install:
- @${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+post-install:
+.for file in lexcount1 c_count java_count
+ @strip ${PREFIX}/bin/${file}
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ChangeLog README TODO sloccount.html
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>