aboutsummaryrefslogtreecommitdiff
path: root/misc/susv3
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-19 12:01:37 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-19 12:01:37 +0000
commite2377459259a49109b8e73790e2946e0c7e81e3a (patch)
treec419983a134ac0500f0ec08ab13a38a657ac12f3 /misc/susv3
parent2f341d2e473f5c2ed75b4fd0d13f90ef8803d97f (diff)
downloadports-e2377459259a49109b8e73790e2946e0c7e81e3a.tar.gz
ports-e2377459259a49109b8e73790e2946e0c7e81e3a.zip
Notes
Diffstat (limited to 'misc/susv3')
-rw-r--r--misc/susv3/Makefile48
-rw-r--r--misc/susv3/distinfo1
-rw-r--r--misc/susv3/pkg-comment1
-rw-r--r--misc/susv3/pkg-descr6
4 files changed, 56 insertions, 0 deletions
diff --git a/misc/susv3/Makefile b/misc/susv3/Makefile
new file mode 100644
index 000000000000..962150faa7b6
--- /dev/null
+++ b/misc/susv3/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: susv3
+# Date created: 11 April 2002
+# Whom: Simon 'corecode' Schubert <corecode@corecode.ath.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= susv3
+PORTVERSION= 1.1
+CATEGORIES= misc
+MASTER_SITES= #
+DISTNAME= susv3
+
+MAINTAINER= corecode@corecode.ath.cx
+
+RESTRICTED= "Redistribution of the documents is not permitted"
+
+USE_BZIP2= yes
+NO_BUILD= yes
+
+PLIST= ${WRKDIR}/pkg-plist
+
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE= "may not be redistributed because of licensing reasons. Please visit http://www.unix-systems.org/version3/online.html to accept their license and download ${DISTFILES} into ${DISTDIR}"
+.endif
+
+do-install:
+ @${MKDIR} ${DOCSDIR}
+ @> ${PLIST}
+ @${FIND} ${WRKSRC} | ${SED} -e 's#^${WRKSRC}##' | while read file; do \
+ if ${TEST} -d "${WRKSRC}$$file"; then \
+ ${MKDIR} "${DOCSDIR}$$file"; \
+ ${ECHO} "@dirrm ${DOCSDIR:S#^${PREFIX}/##}$$file" >> ${PLIST}; \
+ else \
+ if ${TEST} -L "${WRKSRC}$$file"; then \
+ ${LN} -s "`${LS} -l \"${WRKSRC}$$file\" | ${SED} -e 's/^.*> //'`" \
+ "${DOCSDIR}$$file"; \
+ else \
+ ${INSTALL_DATA} "${WRKSRC}$$file" "${DOCSDIR}$$file"; \
+ fi; \
+ ${ECHO} "${DOCSDIR:S#^${PREFIX}/##}$$file" >> ${PLIST}; \
+ fi; \
+ done
+ @(${RM} -f ${PLIST}; ${SED} -ne '/^@/{G;h;};/^@/!p;$${g;p;}' > ${PLIST}) < ${PLIST}
+
+.include <bsd.port.post.mk>
diff --git a/misc/susv3/distinfo b/misc/susv3/distinfo
new file mode 100644
index 000000000000..b23871947e6e
--- /dev/null
+++ b/misc/susv3/distinfo
@@ -0,0 +1 @@
+MD5 (susv3.tar.bz2) = 1dd3a50022c8eb683e720962d56e30db
diff --git a/misc/susv3/pkg-comment b/misc/susv3/pkg-comment
new file mode 100644
index 000000000000..01660c972223
--- /dev/null
+++ b/misc/susv3/pkg-comment
@@ -0,0 +1 @@
+Single UNIX Specification Version 3
diff --git a/misc/susv3/pkg-descr b/misc/susv3/pkg-descr
new file mode 100644
index 000000000000..9c3ba60a596c
--- /dev/null
+++ b/misc/susv3/pkg-descr
@@ -0,0 +1,6 @@
+The Singe UNIX Specification Version 3 is a set of
+numerous HTML pages describing this standard.
+
+WWW: http://www.unix-systems.org/version3/online.html
+
+- Simon 'corecode' Schubert