aboutsummaryrefslogtreecommitdiff
path: root/misc/sword/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-06-28 03:34:56 +0000
committerPatrick Li <pat@FreeBSD.org>2002-06-28 03:34:56 +0000
commit111f4b20f8ceee49375f7aa6482ae0cd5e30eb8f (patch)
tree83f35729b48b87f025d962ae2f5ccb1b1f8d5e53 /misc/sword/Makefile
parent3140591da9abc59a0ab0c23b982953b6f73e8a6e (diff)
Notes
Diffstat (limited to 'misc/sword/Makefile')
-rw-r--r--misc/sword/Makefile42
1 files changed, 11 insertions, 31 deletions
diff --git a/misc/sword/Makefile b/misc/sword/Makefile
index a025c3492fc8..4003bc62e07c 100644
--- a/misc/sword/Makefile
+++ b/misc/sword/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sword
-PORTVERSION= 1.5.2
+PORTVERSION= 1.5.3
CATEGORIES= misc
MASTER_SITES= ftp://ftp.crosswire.org/pub/sword/source/v1.5/ \
http://www.crosswire.org/sword/download/ftpmirror/pub/sword/source/v1.5/ \
@@ -16,40 +16,20 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= wvengen@stack.nl
USE_GMAKE= yes
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --program-transform-name=""
-INCLUDES= Greek2Greek.h GreekChars.h canon.h cipherfil.h defs.h \
- echomod.h entriesblk.h femain.h filemgr.h gbffootnotes.h \
- gbfheadings.h gbfhtml.h gbfmorph.h gbfplain.h gbfrtf.h \
- gbfstrongs.h gbfthml.h hrefcom.h listkey.h localemgr.h \
- lzsscomprs.h plainfootnotes.h plainhtml.h rawcom.h rawfiles.h \
- rawgbf.h rawld.h rawld4.h rawstr.h rawstr4.h rawtext.h \
- rawverse.h regex.h roman.h rtfhtml.h rwphtml.h rwprtf.h \
- sapphire.h strkey.h swcipher.h swcom.h swcomprs.h swconfig.h \
- swdisp.h swdisprtf.h swdisprtfchap.h swfilter.h swkey.h swld.h \
- swlocale.h swlog.h swmacs.h swmgr.h swmodule.h swobject.h \
- swtext.h swunicod.h swwinlog.h tbdisp.h thmlgbf.h thmlhtml.h \
- thmlolb.h thmlplain.h thmlrtf.h unicodertf.h unixstr.h untgz.h \
- utilconf.h utilfuns.h utilstr.h versekey.h zcom.h zconf.h \
- zipcomprs.h zlib.h ztext.h zverse.h
-
-pre-build:
- @${ECHO_CMD} "instdir:= ${PREFIX}" >${WRKSRC}/localport.cfg
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/lib/libsword.a ${PREFIX}/lib
- ${INSTALL_PROGRAM} ${WRKSRC}/lib/libsword.so ${PREFIX}/lib/libsword.so.1
- ${LN} -sf ${PREFIX}/lib/libsword.so.1 ${PREFIX}/lib/libsword.so
+post-install: register
+.if !exists(${PREFIX}/etc/sword.conf)
@${ECHO_CMD} "[Install]" >${PREFIX}/etc/sword.conf
@${ECHO_CMD} "DataPath=${DATADIR}" >>${PREFIX}/etc/sword.conf
- ${MKDIR} ${DATADIR}
- ${MKDIR} ${PREFIX}/include/sword
-.for file in ${INCLUDES}
- ${INSTALL_DATA} ${WRKSRC}/include/${file} ${PREFIX}/include/sword
-.endfor
-
-post-install: register
- @${ECHO} ""
+ @${ECHO_CMD} "Config file installed in ${PREFIX}/etc/sword.conf"
+.else
+ @${ECHO_CMD} "Config file not installed since ${PREFIX}/etc/sword.conf already exists."
+ @${ECHO_CMD} "Please check that DataPath points to your modules (default ${DATADIR}).";
+.endif
+ @${ECHO_CMD} ""
@${CAT} ${PKGMESSAGE}
register: