aboutsummaryrefslogtreecommitdiff
path: root/misc/sword/files
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-06-28 03:34:56 +0000
committerPatrick Li <pat@FreeBSD.org>2002-06-28 03:34:56 +0000
commit111f4b20f8ceee49375f7aa6482ae0cd5e30eb8f (patch)
tree83f35729b48b87f025d962ae2f5ccb1b1f8d5e53 /misc/sword/files
parent3140591da9abc59a0ab0c23b982953b6f73e8a6e (diff)
downloadports-111f4b20f8ceee49375f7aa6482ae0cd5e30eb8f.tar.gz
ports-111f4b20f8ceee49375f7aa6482ae0cd5e30eb8f.zip
Notes
Diffstat (limited to 'misc/sword/files')
-rw-r--r--misc/sword/files/patch-Makefile.cfg80
-rw-r--r--misc/sword/files/patch-examples::cmdline::Makefile.am8
-rw-r--r--misc/sword/files/patch-examples::cmdline::Makefile.in11
-rw-r--r--misc/sword/files/patch-examples::cmdline::search.cpp8
-rw-r--r--misc/sword/files/patch-examples::cmdline::threaded_search.cpp8
-rw-r--r--misc/sword/files/patch-src::mgr::swmgr.cpp37
-rw-r--r--misc/sword/files/patch-tests::treeidxtest.cpp12
7 files changed, 47 insertions, 117 deletions
diff --git a/misc/sword/files/patch-Makefile.cfg b/misc/sword/files/patch-Makefile.cfg
deleted file mode 100644
index 682e51af6e1c..000000000000
--- a/misc/sword/files/patch-Makefile.cfg
+++ /dev/null
@@ -1,80 +0,0 @@
---- Makefile.cfg.orig Wed Dec 12 00:56:50 2001
-+++ Makefile.cfg Wed Dec 12 00:57:18 2001
-@@ -1,4 +1,5 @@
- # General defines
-+include ${root}/localport.cfg
-
- version := 1.5.2
-
-@@ -6,7 +7,7 @@
- # ownership (used by 'make install')
-
- user := root
--group := root
-+group := wheel
-
-
- # this WILL NOT WORK for you. only inhouse patched version of
-@@ -27,7 +28,7 @@
-
- # shared library- set to yes if you would like to build
-
--buildshare := no
-+buildshare := yes
-
-
- # VCL library- set to yes if you would like to build
-@@ -60,8 +61,6 @@
-
- # paths
-
--instdir := /usr
--
- bindir := ${instdir}/bin
- libdir := ${instdir}/lib
- hdir := ${instdir}/include/sword
-@@ -80,16 +79,16 @@
- WARNINGS = -Wall -Wno-format -pedantic
- #WARNINGS += -Werror
- WARNINGS += -pedantic
--CFLAGS = -pipe $(WARNINGS) $(DEBUG)
-+CFLAGS += -pipe $(WARNINGS) $(DEBUG)
-
--CPPFLAGS = -I${root}/include/ $(DEFINES)
-+CPPFLAGS += -I${root}/include/ $(DEFINES)
- ifeq ($(system),macosx)
- CPPFLAGS += -I/System/Library/Frameworks/System.framework/Headers/
- endif
- CPPFLAGS += $(DEFINES)
-
- LFLAGS = $(OPTIMIZE) $(DEBUG) -L${root}/lib/
--LIBS = -lsword -lstdc++
-+LIBS += -lsword -lstdc++
-
- ifeq ($(zlib),no)
- CFLAGS += -DEXCLUDEZLIB
-@@ -97,9 +96,9 @@
- LIBS += -lz
- endif
-
--LDFLAGS = $(LFLAGS) $(LIBS)
-+LDFLAGS += $(LFLAGS) $(LIBS)
-
--DEFINES = -D_GNU_SOURCE
-+DEFINES = -D_GNU_SOURCE -D_INSTDIR_="\"${instdir}\""
-
- ifeq ($(profile),yes)
- CFLAGS += -pg
-@@ -256,9 +255,9 @@
- ifneq (${confdir},)
- @if [ ! -d ${confdir}/mods.d ]; then install -o ${user} -g ${group} -m a+rx,u+rxw -d ${confdir}/mods.d/ ; fi
- @if [ ! -d ${confdir}/locales.d ]; then install -o ${user} -g ${group} -m a+rx,u+rxw -d ${confdir}/locales.d/ ; fi
-- @echo "[Install]" > /etc/sword.conf
-- @echo "DataPath=${confdir}" >> /etc/sword.conf
--# install -o ${user} -g ${group} -m a+r,u+rw samples/recommended/sword.conf /etc/
-+ @echo "[Install]" > ${instdir}/etc/sword.conf
-+ @echo "DataPath=${confdir}" >> ${instdir}/etc/sword.conf
-+# install -o ${user} -g ${group} -m a+r,u+rw samples/recommended/sword.conf ${instdir}/etc/
- install -o ${user} -g ${group} -m a+r,u+rw ${modsconf} ${confdir}/mods.d/
- install -o ${user} -g ${group} -m a+r,u+rw ${localesconf} ${confdir}/locales.d/
- endif
diff --git a/misc/sword/files/patch-examples::cmdline::Makefile.am b/misc/sword/files/patch-examples::cmdline::Makefile.am
new file mode 100644
index 000000000000..50535881e5a8
--- /dev/null
+++ b/misc/sword/files/patch-examples::cmdline::Makefile.am
@@ -0,0 +1,8 @@
+--- examples/cmdline/Makefile.am.orig Thu May 2 11:24:34 2002
++++ examples/cmdline/Makefile.am Thu May 2 11:24:41 2002
+@@ -7,4 +7,4 @@
+ lookup_SOURCES = lookup.cpp
+ search_SOURCES = search.cpp
+ threaded_search_SOURCES = threaded_search.cpp
+-threaded_search_LDADD = $(LDADD) -lpthread
++threaded_search_LDADD = $(LDADD) -pthread
diff --git a/misc/sword/files/patch-examples::cmdline::Makefile.in b/misc/sword/files/patch-examples::cmdline::Makefile.in
new file mode 100644
index 000000000000..78c75dd1fddb
--- /dev/null
+++ b/misc/sword/files/patch-examples::cmdline::Makefile.in
@@ -0,0 +1,11 @@
+--- examples/cmdline/Makefile.in.orig Thu May 2 11:24:45 2002
++++ examples/cmdline/Makefile.in Thu May 2 11:23:52 2002
+@@ -105,7 +105,7 @@
+ lookup_SOURCES = lookup.cpp
+ search_SOURCES = search.cpp
+ threaded_search_SOURCES = threaded_search.cpp
+-threaded_search_LDADD = $(LDADD) -lpthread
++threaded_search_LDADD = $(LDADD) -pthread
+ subdir = examples/cmdline
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = $(top_builddir)/config.h
diff --git a/misc/sword/files/patch-examples::cmdline::search.cpp b/misc/sword/files/patch-examples::cmdline::search.cpp
new file mode 100644
index 000000000000..729eee07f8b6
--- /dev/null
+++ b/misc/sword/files/patch-examples::cmdline::search.cpp
@@ -0,0 +1,8 @@
+diff -ruN sword-1.5.3.orig/examples/cmdline/search.cpp sword-1.5.3/examples/cmdline/search.cpp
+--- examples/cmdline/search.cpp Mon Nov 6 13:18:43 2000
++++ examples/cmdline/search.cpp Wed Jun 19 14:11:08 2002
+@@ -1,3 +1,4 @@
++#include <iostream.h>
+ #include <stdio.h>
+ #include <rawtext.h>
+ #include <swmgr.h>
diff --git a/misc/sword/files/patch-examples::cmdline::threaded_search.cpp b/misc/sword/files/patch-examples::cmdline::threaded_search.cpp
new file mode 100644
index 000000000000..753076ab9c66
--- /dev/null
+++ b/misc/sword/files/patch-examples::cmdline::threaded_search.cpp
@@ -0,0 +1,8 @@
+diff -ruN sword-1.5.3.orig/examples/cmdline/threaded_search.cpp sword-1.5.3/examples/cmdline/threaded_search.cpp
+--- examples/cmdline/threaded_search.cpp Thu Mar 15 19:24:39 2001
++++ examples/cmdline/threaded_search.cpp Wed Jun 19 14:12:14 2002
+@@ -1,3 +1,4 @@
++#include <iostream.h>
+ #include <stdio.h>
+ #include <rawtext.h>
+ #include <swmgr.h>
diff --git a/misc/sword/files/patch-src::mgr::swmgr.cpp b/misc/sword/files/patch-src::mgr::swmgr.cpp
deleted file mode 100644
index fe0db28f4cb7..000000000000
--- a/misc/sword/files/patch-src::mgr::swmgr.cpp
+++ /dev/null
@@ -1,37 +0,0 @@
---- src/mgr/swmgr.cpp.org Wed Dec 12 00:43:04 2001
-+++ src/mgr/swmgr.cpp Wed Dec 12 00:44:39 2001
-@@ -268,21 +268,21 @@
- }
-
-
-- // check for systemwide /etc/sword.conf
-+ // check for systemwide _INSTDIR_/etc/sword.conf
-
- #ifndef __VISUALC__
- if (debug)
-- cerr << "\nChecking for /etc/sword.conf...";
-+ cerr << "\nChecking for "_INSTDIR_"/etc/sword.conf...";
- #endif
-
-- if (!::access("/etc/sword.conf", 04)) {
-+ if (!::access(_INSTDIR_"/etc/sword.conf", 04)) {
-
- #ifndef __VISUALC__
- if (debug)
- cerr << "found\n";
- #endif
-
-- SWConfig etcconf("/etc/sword.conf");
-+ SWConfig etcconf(_INSTDIR_"/etc/sword.conf");
- if ((entry = etcconf.Sections["Install"].find("DataPath")) != etcconf.Sections["Install"].end()) {
- path = (*entry).second;
- if (((*entry).second.c_str()[strlen((*entry).second.c_str())-1] != '\\') && ((*entry).second.c_str()[strlen((*entry).second.c_str())-1] != '/'))
-@@ -290,7 +290,7 @@
-
- #ifndef __VISUALC__
- if (debug)
-- cerr << "DataPath in /etc/sword.conf is set to: " << path;
-+ cerr << "DataPath in "_INSTDIR_"/etc/sword.conf is set to: " << path;
- #endif
-
- #ifndef __VISUALC__
diff --git a/misc/sword/files/patch-tests::treeidxtest.cpp b/misc/sword/files/patch-tests::treeidxtest.cpp
new file mode 100644
index 000000000000..59f038b0e285
--- /dev/null
+++ b/misc/sword/files/patch-tests::treeidxtest.cpp
@@ -0,0 +1,12 @@
+diff -ruN sword-1.5.3.orig/tests/treeidxtest.cpp sword-1.5.3/tests/treeidxtest.cpp
+--- tests/treeidxtest.cpp Thu Jan 24 09:55:27 2002
++++ tests/treeidxtest.cpp Wed Jun 19 14:03:37 2002
+@@ -85,7 +85,7 @@
+ }
+ TreeKeyIdx root = *treeKey;
+
+- string input;
++ std::string input;
+ char line[1024];
+
+ do {