aboutsummaryrefslogtreecommitdiff
path: root/misc/sword
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2014-01-16 20:44:20 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2014-01-16 20:44:20 +0000
commit1dea55304529dd7972dc914d2b555b89381c1167 (patch)
tree24a141c50d63d366ab4bc01af56efdf45b3c4b0b /misc/sword
parentc20f913ef939583e5f637bc53df299e00c7cdc81 (diff)
downloadports-1dea55304529dd7972dc914d2b555b89381c1167.tar.gz
ports-1dea55304529dd7972dc914d2b555b89381c1167.zip
Notes
Diffstat (limited to 'misc/sword')
-rw-r--r--misc/sword/Makefile27
-rw-r--r--misc/sword/distinfo4
-rw-r--r--misc/sword/files/patch-configure31
-rw-r--r--misc/sword/files/patch-include::ftpparse.h19
-rw-r--r--misc/sword/files/patch-src::utilfuns::ftpparse.c10
-rw-r--r--misc/sword/files/patch-src__mgr__curlftpt.cpp10
-rw-r--r--misc/sword/files/patch-src__modules__swmodule.cpp94
-rw-r--r--misc/sword/pkg-plist126
8 files changed, 70 insertions, 251 deletions
diff --git a/misc/sword/Makefile b/misc/sword/Makefile
index 40a252597dce..ef223e741dea 100644
--- a/misc/sword/Makefile
+++ b/misc/sword/Makefile
@@ -2,25 +2,21 @@
# $FreeBSD$
PORTNAME= sword
-PORTVERSION= 1.6.2
-PORTREVISION= 4
+PORTVERSION= 1.7.2
CATEGORIES= misc
MASTER_SITES= ftp://ftp.crosswire.org/pub/sword/source/v${PORTVERSION:R}/ \
- http://crosswire.org/ftpmirror/pub/sword/source/v${PORTVERSION:R}/ \
- LOCAL/tabthorpe
+ http://crosswire.org/ftpmirror/pub/sword/source/v${PORTVERSION:R}/
MAINTAINER= tabthorpe@FreeBSD.org
COMMENT= Framework for manipulating Bible texts
LICENSE= GPLv2
-CONFLICTS= sword-1.7.*
-
BUILD_DEPENDS= cppunit-config:${PORTSDIR}/devel/cppunit
USES= gmake pkgconfig
USE_AUTOTOOLS= automake autoconf
-CONFIGURE_ARGS= --without-conf --with-zlib
+CONFIGURE_ARGS= --with-conf --with-zlib
USE_LDCONFIG= yes
SUB_FILES= pkg-message
@@ -30,7 +26,6 @@ OPTIONS_DEFINE= CURL CLUCENE
CLUCENE_DESC= Include indexing capability
OPTIONS_DEFAULT=CURL CLUCENE
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCURL}
@@ -44,24 +39,19 @@ CONFIGURE_ARGS+= --without-curl
LIB_DEPENDS+= libclucene-core.so:${PORTSDIR}/textproc/clucene \
libicudata.so:${PORTSDIR}/devel/icu
CONFIGURE_ARGS+= --with-clucene=${LOCALBASE} --with-icu
-PLIST_SUB+= ICU="" ICUVER="`${LOCALBASE}/bin/icu-config --version`"
.else
CONFIGURE_ARGS+= --without-clucene --without-icu
-PLIST_SUB+= ICU="@comment "
.endif
run-autotools:: run-autotools-aclocal
+ @${REINPLACE_CMD} -e 's|-O3||' ${WRKSRC}/configure
+
post-patch:
@${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
+ -e's|-O3||g' \
+ -e 's|%%DESTDIR%%|${STAGEDIR}|g' \
${WRKSRC}/Makefile.am ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|:=|=|' ${WRKSRC}/Makefile.am \
- ${WRKSRC}/Makefile.in ${WRKSRC}/lib/Makefile.am \
- ${WRKSRC}/lib/Makefile.in
- @${REINPLACE_CMD} -e '/<curl\/types.h>/d' \
- ${WRKSRC}/src/mgr/curlhttpt.cpp ${WRKSRC}/src/mgr/curlftpt.cpp
- @${REINPLACE_CMD} -e 's/find(k)/this->&/ ; s/insert(/this->&/ ; \
- s/[a-z]*_bound(k)/this->&/' ${WRKSRC}/include/multimapwdef.h
post-install:
@${MKDIR} ${PREFIX}/share/sword/mods.d
@@ -75,7 +65,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-register:
- ${MAKE_CMD} register -C ${WRKSRC}
-
.include <bsd.port.mk>
diff --git a/misc/sword/distinfo b/misc/sword/distinfo
index 2a6b0131745a..430694a68fbc 100644
--- a/misc/sword/distinfo
+++ b/misc/sword/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sword-1.6.2.tar.gz) = af76c7d54135c444b09eeaafb49229ef5201a4e1d44539d9341dceaeb60a87b9
-SIZE (sword-1.6.2.tar.gz) = 1965427
+SHA256 (sword-1.7.2.tar.gz) = ac7aace0ecb7a405d4b4b211ee1ae5b2250bb5c57c9197179747c9e830787871
+SIZE (sword-1.7.2.tar.gz) = 2127944
diff --git a/misc/sword/files/patch-configure b/misc/sword/files/patch-configure
deleted file mode 100644
index 33c1572444a9..000000000000
--- a/misc/sword/files/patch-configure
+++ /dev/null
@@ -1,31 +0,0 @@
---- configure.orig 2010-10-22 17:14:28.000000000 -0400
-+++ configure 2013-01-10 19:07:36.000000000 -0500
-@@ -16347,25 +16347,13 @@
- for flag in $with_clucene; do
- if test -z "$clucene_set_failed"; then
- if test -e "$flag/include/CLucene.h"; then
--# 64-bit checks first
-- if test -e "$flag/lib64/libclucene.la" || test -e "$flag/lib64/libclucene.so"; then
-+ if test -e "$flag/lib/libclucene-core.la" || test -e "$flag/lib/libclucene-core.so"; then
- clucene_set_failed=$flag
-- CLUCENE_LIBS="-L$flag/lib64 -lclucene"
-+ CLUCENE_LIBS="-L$flag/lib -lclucene-core"
- if test -e "$flag/include/CLucene/clucene-config.h"; then
- CLUCENE_CXXFLAGS="-I$flag/include"
- else
-- CLUCENE_CXXFLAGS="-I$flag/include -I$flag/lib64"
-- fi
-- else
--# 32-bit checks
-- if test -e "$flag/lib/libclucene.la" || test -e "$flag/lib/libclucene.so"; then
-- clucene_set_failed=$flag
-- CLUCENE_LIBS="-L$flag/lib -lclucene"
-- if test -e "$flag/include/CLucene/clucene-config.h"; then
-- CLUCENE_CXXFLAGS="-I$flag/include"
-- else
-- CLUCENE_CXXFLAGS="-I$flag/include -I$flag/lib"
-- fi
-+ CLUCENE_CXXFLAGS="-I$flag/include -I$flag/lib"
- fi
- fi
- fi
diff --git a/misc/sword/files/patch-include::ftpparse.h b/misc/sword/files/patch-include::ftpparse.h
deleted file mode 100644
index e135d22a25e8..000000000000
--- a/misc/sword/files/patch-include::ftpparse.h
+++ /dev/null
@@ -1,19 +0,0 @@
---- include/ftpparse.h.orig Tue Aug 17 10:49:11 2004
-+++ include/ftpparse.h Tue Aug 17 10:49:24 2004
-@@ -1,7 +1,6 @@
- #ifndef FTPPARSE_H
- #define FTPPARSE_H
-
--#include <time.h>
-
- /*
- ftpparse(&fp,buf,len) tries to parse one line of LIST output.
-@@ -25,7 +24,7 @@
- int sizetype;
- long size; /* number of octets */
- int mtimetype;
-- time_t mtime; /* modification time */
-+ long mtime; /* modification time */
- int idtype;
- char *id; /* not necessarily 0-terminated */
- int idlen;
diff --git a/misc/sword/files/patch-src::utilfuns::ftpparse.c b/misc/sword/files/patch-src::utilfuns::ftpparse.c
deleted file mode 100644
index ab8a3eab8e85..000000000000
--- a/misc/sword/files/patch-src::utilfuns::ftpparse.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/utilfuns/ftpparse.c.orig Thu Feb 19 23:22:11 2004
-+++ src/utilfuns/ftpparse.c Thu Feb 19 23:22:19 2004
-@@ -21,6 +21,7 @@
- NCSA Telnet FTP server. Has LIST = NLST (and bad NLST for directories).
- */
-
-+#include <time.h>
- #include <ftpparse.h>
-
- static long totai(long year,long month,long mday)
diff --git a/misc/sword/files/patch-src__mgr__curlftpt.cpp b/misc/sword/files/patch-src__mgr__curlftpt.cpp
deleted file mode 100644
index 774f17f09782..000000000000
--- a/misc/sword/files/patch-src__mgr__curlftpt.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./src/mgr/curlftpt.cpp.orig 2010-04-04 01:26:26.000000000 -0400
-+++ ./src/mgr/curlftpt.cpp 2010-04-04 01:26:02.000000000 -0400
-@@ -124,6 +124,7 @@
-
-
- CURLFTPTransport::~CURLFTPTransport() {
-+ curl_easy_setopt(session, CURLOPT_PROGRESSDATA, (void*)NULL);
- curl_easy_cleanup(session);
- }
-
diff --git a/misc/sword/files/patch-src__modules__swmodule.cpp b/misc/sword/files/patch-src__modules__swmodule.cpp
deleted file mode 100644
index 87cd9c61e56c..000000000000
--- a/misc/sword/files/patch-src__modules__swmodule.cpp
+++ /dev/null
@@ -1,94 +0,0 @@
---- src/modules/swmodule.cpp.orig 2009-12-28 13:03:22.000000000 -0500
-+++ src/modules/swmodule.cpp 2013-01-10 18:59:59.000000000 -0500
-@@ -40,7 +40,6 @@
-
- #ifdef USELUCENE
- #include <CLucene.h>
--#include <CLucene/CLBackwards.h>
-
- //Lucence includes
- //#include "CLucene.h"
-@@ -59,6 +58,9 @@
-
- using std::vector;
-
-+extern size_t lucene_utf8towcs(wchar_t *, const char *, size_t maxslen);
-+extern size_t lucene_wcstoutf8 (char *, const wchar_t *, size_t maxslen);
-+
- SWORD_NAMESPACE_START
-
- SWDisplay SWModule::rawdisp;
-@@ -521,7 +523,7 @@
-
- // iterate thru each good module position that meets the search
- bool checkBounds = getKey()->isBoundSet();
-- for (long i = 0; i < h->length(); i++) {
-+ for (unsigned long i = 0; i < h->length(); i++) {
- Document &doc = h->doc(i);
-
- // set a temporary verse key to this module position
-@@ -1144,7 +1146,7 @@
-
- lucene_utf8towcs(wcharBuffer, keyText, MAX_CONV_SIZE); //keyText must be utf8
- // doc->add( *(new Field("key", wcharBuffer, Field::STORE_YES | Field::INDEX_TOKENIZED)));
-- doc->add( *Field::Text(_T("key"), wcharBuffer ) );
-+ doc->add(*_CLNEW Field(_T("key"), wcharBuffer, Field::STORE_YES | Field::INDEX_TOKENIZED) );
-
-
- if (includeKeyInSearch) {
-@@ -1155,11 +1157,11 @@
- }
-
- lucene_utf8towcs(wcharBuffer, content, MAX_CONV_SIZE); //content must be utf8
-- doc->add( *Field::UnStored(_T("content"), wcharBuffer) );
-+ doc->add(*_CLNEW Field(_T("content"), wcharBuffer, Field::STORE_NO | Field::INDEX_TOKENIZED));
-
- if (strong.length() > 0) {
- lucene_utf8towcs(wcharBuffer, strong, MAX_CONV_SIZE);
-- doc->add( *Field::UnStored(_T("lemma"), wcharBuffer) );
-+ doc->add(*_CLNEW Field(_T("lemma"), wcharBuffer, Field::STORE_NO | Field::INDEX_TOKENIZED) );
- //printf("setting fields (%s).\ncontent: %s\nlemma: %s\n", (const char *)*key, content, strong.c_str());
- }
-
-@@ -1280,12 +1282,12 @@
-
- //printf("proxBuf after (%s).\nprox: %s\nproxLem: %s\n", (const char *)*key, proxBuf.c_str(), proxLem.c_str());
-
-- doc->add( *Field::UnStored(_T("prox"), wcharBuffer) );
-+ doc->add(*_CLNEW Field(_T("prox"), wcharBuffer, Field::STORE_NO | Field::INDEX_TOKENIZED) );
- good = true;
- }
- if (proxLem.length() > 0) {
- lucene_utf8towcs(wcharBuffer, proxLem, MAX_CONV_SIZE); //keyText must be utf8
-- doc->add( *Field::UnStored(_T("proxlem"), wcharBuffer) );
-+ doc->add(*_CLNEW Field(_T("proxlem"), wcharBuffer, Field::STORE_NO | Field::INDEX_TOKENIZED) );
- good = true;
- }
- if (good) {
-@@ -1303,20 +1305,20 @@
- //coreWriter->optimize();
- coreWriter->close();
-
-+ d = FSDirectory::getDirectory(target.c_str());
- if (IndexReader::indexExists(target.c_str())) {
-- d = FSDirectory::getDirectory(target.c_str(), false);
- if (IndexReader::isLocked(d)) {
- IndexReader::unlock(d);
- }
--
-- fsWriter = new IndexWriter( d, an, false);
-- } else {
-- d = FSDirectory::getDirectory(target.c_str(), true);
-+ fsWriter = new IndexWriter(d, an, false);
-+ }
-+ else {
- fsWriter = new IndexWriter(d, an, true);
- }
-
- Directory *dirs[] = { ramDir, 0 };
-- fsWriter->addIndexes(dirs);
-+ lucene::util::ConstValueArray< lucene::store::Directory *>dirsa(dirs, 1);
-+ fsWriter->addIndexes(dirsa);
- fsWriter->close();
-
- delete ramDir;
diff --git a/misc/sword/pkg-plist b/misc/sword/pkg-plist
index f72f2baeaf74..4b2ec2109579 100644
--- a/misc/sword/pkg-plist
+++ b/misc/sword/pkg-plist
@@ -1,38 +1,22 @@
-bin/addld
bin/diatheke
-bin/imp2gbs
-bin/imp2ld
-bin/imp2vs
-bin/installmgr
-bin/mkfastmod
bin/mod2imp
bin/mod2osis
-bin/mod2vpl
-bin/mod2zmod
bin/osis2mod
bin/tei2mod
-bin/vpl2mod
bin/vs2osisref
bin/vs2osisreftxt
+bin/mod2vpl
+bin/mkfastmod
+bin/vpl2mod
+bin/imp2vs
+bin/installmgr
bin/xml2gbs
+bin/imp2gbs
+bin/imp2ld
+bin/mod2zmod
%%ETCDIR%%.conf
-include/sword/Greek2Greek.h
-include/sword/GreekChars.h
include/sword/canon.h
include/sword/canon_abbrevs.h
-include/sword/canon_catholic.h
-include/sword/canon_catholic2.h
-include/sword/canon_german.h
-include/sword/canon_kjva.h
-include/sword/canon_leningrad.h
-include/sword/canon_luther.h
-include/sword/canon_mt.h
-include/sword/canon_nrsv.h
-include/sword/canon_nrsva.h
-include/sword/canon_null.h
-include/sword/canon_synodal.h
-include/sword/canon_synodalp.h
-include/sword/canon_vulg.h
include/sword/cipherfil.h
include/sword/curlftpt.h
include/sword/curlhttpt.h
@@ -42,24 +26,27 @@ include/sword/encfiltmgr.h
include/sword/entriesblk.h
include/sword/femain.h
include/sword/filemgr.h
+include/sword/versificationmgr.h
include/sword/flatapi.h
-include/sword/ftplib.h
-include/sword/ftplibftpt.h
include/sword/ftpparse.h
-include/sword/ftptrans.h
+include/sword/remotetrans.h
+include/sword/ftplibftpt.h
+include/sword/ftplib.h
include/sword/gbffootnotes.h
include/sword/gbfheadings.h
include/sword/gbfhtml.h
+include/sword/gbfxhtml.h
include/sword/gbfhtmlhref.h
+include/sword/rawld.h
+include/sword/gbfwebif.h
include/sword/gbfmorph.h
include/sword/gbfosis.h
include/sword/gbfplain.h
include/sword/gbfredletterwords.h
include/sword/gbfrtf.h
include/sword/gbfstrongs.h
-include/sword/gbfthml.h
-include/sword/gbfwebif.h
include/sword/gbfwordjs.h
+include/sword/gbfthml.h
include/sword/greeklexattribs.h
include/sword/hebrewmcim.h
include/sword/hrefcom.h
@@ -72,37 +59,41 @@ include/sword/lzsscomprs.h
include/sword/markupfiltmgr.h
include/sword/multimapwdef.h
include/sword/nullim.h
-include/sword/osisfootnotes.h
+include/sword/osisglosses.h
+include/sword/osisenum.h
include/sword/osisheadings.h
include/sword/osishtmlhref.h
-include/sword/osislemma.h
+include/sword/osisxhtml.h
+include/sword/osiswebif.h
include/sword/osismorph.h
include/sword/osismorphsegmentation.h
-include/sword/osisosis.h
include/sword/osisplain.h
-include/sword/osisredletterwords.h
include/sword/osisrtf.h
-include/sword/osisscripref.h
+include/sword/osisosis.h
include/sword/osisstrongs.h
-include/sword/osisvariants.h
-include/sword/osiswebif.h
+include/sword/osisfootnotes.h
+include/sword/osislemma.h
+include/sword/osisredletterwords.h
+include/sword/osisscripref.h
include/sword/osiswordjs.h
+include/sword/osisvariants.h
+include/sword/osisxlit.h
include/sword/papyriplain.h
-include/sword/plainfootnotes.h
-include/sword/plainhtml.h
include/sword/rawcom.h
+include/sword/rawcom4.h
include/sword/rawfiles.h
include/sword/rawgenbook.h
-include/sword/rawld.h
include/sword/rawld4.h
include/sword/rawstr.h
include/sword/rawstr4.h
include/sword/rawtext.h
+include/sword/rawtext4.h
include/sword/rawverse.h
+include/sword/rawverse4.h
include/sword/roman.h
include/sword/rtfhtml.h
include/sword/sapphire.h
-include/sword/stringmgr.h
+include/sword/scsuutf8.h
include/sword/strkey.h
include/sword/swbasicfilter.h
include/sword/swbuf.h
@@ -122,22 +113,21 @@ include/sword/swlocale.h
include/sword/swlog.h
include/sword/swmacs.h
include/sword/swmgr.h
+include/sword/stringmgr.h
include/sword/swmodule.h
-include/sword/swobject.h
include/sword/swoptfilter.h
+include/sword/swobject.h
include/sword/swsearchable.h
include/sword/swtext.h
-include/sword/swunicod.h
include/sword/swversion.h
include/sword/sysdata.h
-include/sword/teihtmlhref.h
-include/sword/teiplain.h
-include/sword/teirtf.h
include/sword/thmlfootnotes.h
include/sword/thmlgbf.h
include/sword/thmlheadings.h
include/sword/thmlhtml.h
+include/sword/thmlxhtml.h
include/sword/thmlhtmlhref.h
+include/sword/thmlwebif.h
include/sword/thmllemma.h
include/sword/thmlmorph.h
include/sword/thmlosis.h
@@ -146,20 +136,23 @@ include/sword/thmlrtf.h
include/sword/thmlscripref.h
include/sword/thmlstrongs.h
include/sword/thmlvariants.h
-include/sword/thmlwebif.h
include/sword/thmlwordjs.h
+include/sword/teiplain.h
+include/sword/teirtf.h
+include/sword/teixhtml.h
+include/sword/teihtmlhref.h
include/sword/treekey.h
include/sword/treekeyidx.h
include/sword/unicodertf.h
-include/sword/untgz.h
include/sword/url.h
+include/sword/untgz.h
include/sword/utf16utf8.h
-include/sword/utf8arabicpoints.h
include/sword/utf8arshaping.h
include/sword/utf8bidireorder.h
include/sword/utf8cantillation.h
include/sword/utf8greekaccents.h
include/sword/utf8hebrewpoints.h
+include/sword/utf8arabicpoints.h
include/sword/utf8html.h
include/sword/utf8latin1.h
include/sword/utf8nfc.h
@@ -169,31 +162,33 @@ include/sword/utf8utf16.h
include/sword/utilstr.h
include/sword/utilxml.h
include/sword/versekey.h
-include/sword/versemgr.h
include/sword/versetreekey.h
include/sword/zcom.h
-include/sword/zconf.h
include/sword/zipcomprs.h
include/sword/zld.h
include/sword/zstr.h
include/sword/ztext.h
include/sword/zverse.h
+include/sword/canon_kjva.h
+include/sword/canon_leningrad.h
+include/sword/canon_mt.h
+include/sword/canon_nrsv.h
+include/sword/canon_nrsva.h
+include/sword/canon_synodal.h
+include/sword/canon_synodalprot.h
+include/sword/canon_vulg.h
+include/sword/canon_german.h
+include/sword/canon_luther.h
+include/sword/canon_catholic.h
+include/sword/canon_catholic2.h
+include/sword/canon_lxx.h
+include/sword/canon_null.h
+include/sword/canon_orthodox.h
lib/libsword-%%PORTVERSION%%.so
lib/libsword.a
lib/libsword.la
lib/libsword.so
-%%ICU%%lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%/translit_Any_Latex.res
-%%ICU%%lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%/translit_Any_Latin1.res
-%%ICU%%lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%/translit_BETA_Greek.res
-%%ICU%%lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%/translit_BGreek_Greek.res
-%%ICU%%lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%/translit_CCAT_Hebrew.res
-%%ICU%%lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%/translit_CCAT_Syriac.res
-%%ICU%%lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%/translit_Latin_Coptic.res
-%%ICU%%lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%/translit_Latin_Gothic.res
-%%ICU%%lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%/translit_Latin_Ugaritic.res
-%%ICU%%lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%/translit_swordindex.res
libdata/pkgconfig/sword.pc
-%%DATADIR%%/locales.d/locales.conf
%%DATADIR%%/locales.d/abbr.conf
%%DATADIR%%/locales.d/af-utf8.conf
%%DATADIR%%/locales.d/af.conf
@@ -201,7 +196,6 @@ libdata/pkgconfig/sword.pc
%%DATADIR%%/locales.d/ar_EG-utf8.conf
%%DATADIR%%/locales.d/az-utf8.conf
%%DATADIR%%/locales.d/bg_BG-cp1251.conf
-%%DATADIR%%/locales.d/bg_BG-utf8.conf
%%DATADIR%%/locales.d/cs-utf8.conf
%%DATADIR%%/locales.d/cs.conf
%%DATADIR%%/locales.d/cy-utf8.conf
@@ -221,6 +215,7 @@ libdata/pkgconfig/sword.pc
%%DATADIR%%/locales.d/fa-utf8.conf
%%DATADIR%%/locales.d/fi-utf8.conf
%%DATADIR%%/locales.d/fi.conf
+%%DATADIR%%/locales.d/fo-utf8.conf
%%DATADIR%%/locales.d/fr-utf8.conf
%%DATADIR%%/locales.d/fr.conf
%%DATADIR%%/locales.d/fr_abbrev-utf8.conf
@@ -234,6 +229,7 @@ libdata/pkgconfig/sword.pc
%%DATADIR%%/locales.d/id.conf
%%DATADIR%%/locales.d/it-utf8.conf
%%DATADIR%%/locales.d/it.conf
+%%DATADIR%%/locales.d/iu-utf8.conf
%%DATADIR%%/locales.d/ja-utf8.conf
%%DATADIR%%/locales.d/ko-utf8.conf
%%DATADIR%%/locales.d/ko.conf
@@ -241,6 +237,7 @@ libdata/pkgconfig/sword.pc
%%DATADIR%%/locales.d/ko_abbrev.conf
%%DATADIR%%/locales.d/la-utf8.conf
%%DATADIR%%/locales.d/la.conf
+%%DATADIR%%/locales.d/locales.conf
%%DATADIR%%/locales.d/lt-utf8.conf
%%DATADIR%%/locales.d/mt-utf8.conf
%%DATADIR%%/locales.d/nb-utf8.conf
@@ -251,6 +248,7 @@ libdata/pkgconfig/sword.pc
%%DATADIR%%/locales.d/no.conf
%%DATADIR%%/locales.d/pl-utf8.conf
%%DATADIR%%/locales.d/pl.conf
+%%DATADIR%%/locales.d/pon_utf8.conf
%%DATADIR%%/locales.d/pt-utf8.conf
%%DATADIR%%/locales.d/pt.conf
%%DATADIR%%/locales.d/pt_BR-utf8.conf
@@ -269,16 +267,14 @@ libdata/pkgconfig/sword.pc
%%DATADIR%%/locales.d/th-utf8.conf
%%DATADIR%%/locales.d/uk_UA-cp1251.conf
%%DATADIR%%/locales.d/uk_UA-koi8-u.conf
-%%DATADIR%%/locales.d/uk_UA-utf8.conf
%%DATADIR%%/locales.d/vi-utf8.conf
%%DATADIR%%/locales.d/zh_CN-utf8.conf
%%DATADIR%%/locales.d/zh_Hans-utf8.conf
%%DATADIR%%/locales.d/zh_Hant-utf8.conf
%%DATADIR%%/locales.d/zh_TW-utf8.conf
%%DATADIR%%/locales.d/zh_english-utf8.conf
+%%DATADIR%%/mods.d/globals.conf
@dirrm %%DATADIR%%/mods.d
@dirrm %%DATADIR%%/locales.d
@dirrm %%DATADIR%%
-%%ICU%%@dirrm lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%
-@dirrm lib/sword
@dirrm include/sword