aboutsummaryrefslogtreecommitdiff
path: root/misc/sword
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2010-04-04 06:06:02 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2010-04-04 06:06:02 +0000
commit0f7c365816c4e99a91bbb6ede92254c52e81ddcc (patch)
tree317a9b7d425f1e394887aac19e82cde9f23c362c /misc/sword
parent5208dca85e1ce1eebb46a7f510c8e24da53de8d9 (diff)
downloadports-0f7c365816c4e99a91bbb6ede92254c52e81ddcc.tar.gz
ports-0f7c365816c4e99a91bbb6ede92254c52e81ddcc.zip
Notes
Diffstat (limited to 'misc/sword')
-rw-r--r--misc/sword/Makefile2
-rw-r--r--misc/sword/files/patch-src__mgr__curlftpt.cpp10
2 files changed, 11 insertions, 1 deletions
diff --git a/misc/sword/Makefile b/misc/sword/Makefile
index 8cea405518f3..e55e8ca275cf 100644
--- a/misc/sword/Makefile
+++ b/misc/sword/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sword
PORTVERSION= 1.6.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc
MASTER_SITES= ftp://ftp.crosswire.org/pub/sword/source/v1.6/ \
http://crosswire.org/ftpmirror/pub/sword/source/v1.6/ \
diff --git a/misc/sword/files/patch-src__mgr__curlftpt.cpp b/misc/sword/files/patch-src__mgr__curlftpt.cpp
new file mode 100644
index 000000000000..774f17f09782
--- /dev/null
+++ b/misc/sword/files/patch-src__mgr__curlftpt.cpp
@@ -0,0 +1,10 @@
+--- ./src/mgr/curlftpt.cpp.orig 2010-04-04 01:26:26.000000000 -0400
++++ ./src/mgr/curlftpt.cpp 2010-04-04 01:26:02.000000000 -0400
+@@ -124,6 +124,7 @@
+
+
+ CURLFTPTransport::~CURLFTPTransport() {
++ curl_easy_setopt(session, CURLOPT_PROGRESSDATA, (void*)NULL);
+ curl_easy_cleanup(session);
+ }
+