aboutsummaryrefslogtreecommitdiff
path: root/misc/tellico/Makefile
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2005-09-29 22:05:27 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2005-09-29 22:05:27 +0000
commitb0b6630bb94a5a206f06f45b138b34a81343ab09 (patch)
treeec6d9d470c266717ad027660d6530efb2429bef7 /misc/tellico/Makefile
parente52736c3741651a66794c48872bb3944ab4dbccd (diff)
downloadports-b0b6630bb94a5a206f06f45b138b34a81343ab09.tar.gz
ports-b0b6630bb94a5a206f06f45b138b34a81343ab09.zip
Notes
Diffstat (limited to 'misc/tellico/Makefile')
-rw-r--r--misc/tellico/Makefile38
1 files changed, 34 insertions, 4 deletions
diff --git a/misc/tellico/Makefile b/misc/tellico/Makefile
index 0f460f5f5b28..69c91d3f34a9 100644
--- a/misc/tellico/Makefile
+++ b/misc/tellico/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= tellico
-PORTVERSION= 0.13.8
-PORTREVISION= 1
+PORTVERSION= 1.0.1
CATEGORIES= misc kde
MASTER_SITES= http://www.periapsis.org/tellico/download/
@@ -15,16 +14,47 @@ MAINTAINER= markus@FreeBSD.org
COMMENT= Collection manager for KDE
LIB_DEPENDS= tag:${PORTSDIR}/audio/taglib \
- kcddb:${PORTSDIR}/multimedia/kdemultimedia3 \
yaz.2:${PORTSDIR}/net/yaz
EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-old_configure
USE_KDELIBS_VER=3
+USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
+OPTIONS= CDDB "CDDB support" on \
+ KCAL "KOrganizer support" on \
+ AMAZON "Amazon search support" on \
+ IMDB "IMDb search support" on
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
+.if defined(WITHOUT_CDDB)
+CONFIGURE_ARGS+=--disable-libkcddb
+.else
+LIB_DEPENDS+= kcddb:${PORTSDIR}/multimedia/kdemultimedia3
+.endif
+
+.if defined(WITHOUT_KCAL)
+CONFIGURE_ARGS+=--disable-libkcal
+.else
+LIB_DEPENDS+= kcal.2:${PORTSDIR}/deskutils/kdepim3
+.endif
+
+.if defined(WITHOUT_AMAZON)
+CONFIGURE_ARGS+=--disable-amazon
+.endif
+
+.if defined(WITHOUT_IMDB)
+CONFIGURE_ARGS+=--disable-imdb
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>