aboutsummaryrefslogtreecommitdiff
path: root/misc/tellico
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2004-10-17 13:39:42 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2004-10-17 13:39:42 +0000
commit9f4c824e268710cbcac55d61bf64773b1362818a (patch)
tree79092da1256935c19613ea1b08eb2c5486ea2290 /misc/tellico
parent95a6bb8fb7757f22453fe2b6cee28a7187fb6370 (diff)
downloadports-9f4c824e268710cbcac55d61bf64773b1362818a.tar.gz
ports-9f4c824e268710cbcac55d61bf64773b1362818a.zip
Notes
Diffstat (limited to 'misc/tellico')
-rw-r--r--misc/tellico/Makefile23
-rw-r--r--misc/tellico/distinfo4
-rw-r--r--misc/tellico/files/patch-src-fetch-amazonfetcher.cpp11
-rw-r--r--misc/tellico/files/patch-src-translators-alexandriaexporter.cpp11
-rw-r--r--misc/tellico/files/patch-src-translators-btparse-err.h10
-rw-r--r--misc/tellico/pkg-descr27
-rw-r--r--misc/tellico/pkg-plist161
7 files changed, 140 insertions, 107 deletions
diff --git a/misc/tellico/Makefile b/misc/tellico/Makefile
index 8de4a81e975f..3a5f99c7f36b 100644
--- a/misc/tellico/Makefile
+++ b/misc/tellico/Makefile
@@ -5,28 +5,23 @@
# $FreeBSD$
#
-PORTNAME= bookcase
-PORTVERSION= 0.9.3
+PORTNAME= tellico
+PORTVERSION= 0.12
CATEGORIES= misc kde
-MASTER_SITES= http://www.periapsis.org/bookcase/download/
+MASTER_SITES= http://www.periapsis.org/tellico/download/
MAINTAINER= markus@FreeBSD.org
-COMMENT= Personal book collection manager for KDE
+COMMENT= Collection manager for KDE
+
+LIB_DEPENDS= tag:${PORTSDIR}/audio/taglib \
+ cdda_paranoia:${PORTSDIR}/audio/cdparanoia \
+ kcddb:${PORTSDIR}/multimedia/kdemultimedia3
USE_KDELIBS_VER=3
GNU_CONFIGURE= yes
USE_REINPLACE= yes
-post-extract:
- ${TOUCH} ${WRKSRC}/config.h.in
-
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-CFLAGS+= -D__LIBSTDCPP_PARTIAL_SUPPORT__
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/tellico/distinfo b/misc/tellico/distinfo
index 51ab393fb721..f47b6ddf6f02 100644
--- a/misc/tellico/distinfo
+++ b/misc/tellico/distinfo
@@ -1,2 +1,2 @@
-MD5 (bookcase-0.9.3.tar.gz) = ccb7035054fbbba18f47c24929881205
-SIZE (bookcase-0.9.3.tar.gz) = 1946832
+MD5 (tellico-0.12.tar.gz) = edabbacfc2d2c1ca43cdad6b65c65f62
+SIZE (tellico-0.12.tar.gz) = 2093904
diff --git a/misc/tellico/files/patch-src-fetch-amazonfetcher.cpp b/misc/tellico/files/patch-src-fetch-amazonfetcher.cpp
new file mode 100644
index 000000000000..ea6c450eef0e
--- /dev/null
+++ b/misc/tellico/files/patch-src-fetch-amazonfetcher.cpp
@@ -0,0 +1,11 @@
+--- src/fetch/amazonfetcher.cpp.orig Sat Oct 16 00:23:06 2004
++++ src/fetch/amazonfetcher.cpp Sat Oct 16 00:23:48 2004
+@@ -428,7 +428,7 @@
+ // emit signalStatus(i18n("<qt>The cover image for <i>%1</i> could not be loaded.</qt>").arg(
+ // entry->field(QString::fromLatin1("title"))));
+ emit signalStatus(i18n("The cover image could not be loaded."));
+- } else if(img.width() > 1 and img.height() > 1) { // amazon serves up 1x1 gifs occasionally
++ } else if(img.width() > 1 && img.height() > 1) { // amazon serves up 1x1 gifs occasionally
+ // all relevant collection types have cover fields
+ entry->setField(QString::fromLatin1("cover"), img.id());
+ }
diff --git a/misc/tellico/files/patch-src-translators-alexandriaexporter.cpp b/misc/tellico/files/patch-src-translators-alexandriaexporter.cpp
new file mode 100644
index 000000000000..8db988e1d4fa
--- /dev/null
+++ b/misc/tellico/files/patch-src-translators-alexandriaexporter.cpp
@@ -0,0 +1,11 @@
+--- src/translators/alexandriaexporter.cpp.orig Sat Oct 16 00:18:34 2004
++++ src/translators/alexandriaexporter.cpp Sat Oct 16 00:19:10 2004
+@@ -111,7 +111,7 @@
+ entry_->field(QString::fromLatin1("publisher"));
+ pub.replace('"', QString::fromLatin1("\\\""));
+ // publisher uses n/a when empty
+- ts << "publisher: \"" << (pub.isEmpty() ? "n/a" : pub) << "\"\n";
++ ts << "publisher: \"" << (pub.isEmpty() ? QString::fromLatin1("n/a") : pub) << "\"\n";
+ QString rating = entry_->field(QString::fromLatin1("rating"));
+ for(uint pos = 0; pos < rating.length(); ++pos) {
+ if(rating[pos].isDigit()) {
diff --git a/misc/tellico/files/patch-src-translators-btparse-err.h b/misc/tellico/files/patch-src-translators-btparse-err.h
deleted file mode 100644
index cbc686f46f59..000000000000
--- a/misc/tellico/files/patch-src-translators-btparse-err.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/translators/btparse/err.h.orig Sun Aug 15 18:48:06 2004
-+++ src/translators/btparse/err.h Sun Aug 15 18:50:09 2004
-@@ -118,7 +118,6 @@
- int *err_k;
- int i;
- va_list ap;
-- int k;
- va_start(ap, k);
- text[0] = '\0';
- for (i=1; i<=k; i++) /* collect all lookahead sets */
diff --git a/misc/tellico/pkg-descr b/misc/tellico/pkg-descr
index 7d1db2ae761c..54d0a1573045 100644
--- a/misc/tellico/pkg-descr
+++ b/misc/tellico/pkg-descr
@@ -1,5 +1,24 @@
-Bookcase is a personal book collection manager for KDE. It uses
-an XML file storage format, and tracks 26 book properties by
-default.
+Tellico is an KDE application for organizing your collections. It provides
+default templates for books, bibliographies, videos, music, coins, stamps,
+trading cards, comic books, and wines.
-WWW: http://www.periapsis.org/bookcase/
+Capabilities:
+ - Supports default collections of books, bibliographic entries, videos,
+ music, comic books, coins, stamps, trading cards, and wines.
+ - Supports user-defined custom collections, as well.
+ - Supports any number of user-defined fields, of eleven different types
+ - Handles entries with multiple authors, genres, keywords, etc.
+ - Automatically formats titles and names
+ - Supports collection searching and view filtering
+ - Sorts and groups collection by various properties
+ - Automatically validates ISBN
+ - Allows customizable entry templates through XSLT
+ - Imports Bibtex, Bibtexml, CSV, and XSLT-filtered data
+ - Exports to Bibtex, Bibtexml, CSV, HTML, PilotDB, and XSLT-filtered data
+ - Includes translations for more than nine languages, other than English
+ - Imports information directly from Amazon.com
+ - Imports CDDB data
+ - Scans and imports audio file collections, such as mp3 or ogg
+ - Imports and exports to Alexandria libraries
+
+WWW: http://www.periapsis.org/tellico/
diff --git a/misc/tellico/pkg-plist b/misc/tellico/pkg-plist
index 97edf352267b..7a55bbd98813 100644
--- a/misc/tellico/pkg-plist
+++ b/misc/tellico/pkg-plist
@@ -1,76 +1,82 @@
-bin/bookcase
-share/applnk/Applications/bookcase.desktop
-share/apps/bookcase/bibtex-translation.xml
-share/apps/bookcase/bookcase-by-author.xsl
-share/apps/bookcase/bookcase-by-title.xsl
-share/apps/bookcase/bookcase-common.xsl
-share/apps/bookcase/bookcase-printing.xsl
-share/apps/bookcase/bookcase.dtd
-share/apps/bookcase/bookcase.tips
-share/apps/bookcase/bookcase2html.xsl
-share/apps/bookcase/bookcaseui.rc
-share/apps/bookcase/cassette-logo.png
-share/apps/bookcase/cd-logo.png
-share/apps/bookcase/dvd-logo.png
-share/apps/bookcase/entry-templates/Album.xsl
-share/apps/bookcase/entry-templates/Compact.xsl
-share/apps/bookcase/entry-templates/Default.xsl
-share/apps/bookcase/entry-templates/Fancy.xsl
-share/apps/bookcase/entry-templates/Video.xsl
-share/apps/bookcase/mods2bookcase.xsl
-share/apps/bookcase/pics/album.png
-share/apps/bookcase/pics/bibtex.png
-share/apps/bookcase/pics/book.png
-share/apps/bookcase/pics/bookcase.png
-share/apps/bookcase/pics/card.png
-share/apps/bookcase/pics/coin.png
-share/apps/bookcase/pics/comic.png
-share/apps/bookcase/pics/person-open.png
-share/apps/bookcase/pics/person.png
-share/apps/bookcase/pics/stamp.png
-share/apps/bookcase/pics/video.png
-share/apps/bookcase/pics/wine.png
-share/apps/bookcase/record-logo.png
-share/apps/bookcase/shadowAlpha.png
-share/apps/bookcase/vhs-logo.png
-share/doc/HTML/en/bookcase/bibtex-options.png
-share/doc/HTML/en/bookcase/common
-share/doc/HTML/en/bookcase/configuration.docbook
-share/doc/HTML/en/bookcase/csv-dialog.png
-share/doc/HTML/en/bookcase/details.docbook
-share/doc/HTML/en/bookcase/entry-editor1.png
-share/doc/HTML/en/bookcase/entry-editor2.png
-share/doc/HTML/en/bookcase/entry-editor3.png
-share/doc/HTML/en/bookcase/entry-editor4.png
-share/doc/HTML/en/bookcase/faqs.docbook
-share/doc/HTML/en/bookcase/fields-dialog.png
-share/doc/HTML/en/bookcase/filter-dialog.png
-share/doc/HTML/en/bookcase/fundamentals.docbook
-share/doc/HTML/en/bookcase/general-options.png
-share/doc/HTML/en/bookcase/hacking.docbook
-share/doc/HTML/en/bookcase/importing-exporting.docbook
-share/doc/HTML/en/bookcase/index.cache.bz2
-share/doc/HTML/en/bookcase/index.docbook
-share/doc/HTML/en/bookcase/main-window.png
-share/doc/HTML/en/bookcase/menus.docbook
-share/doc/HTML/en/bookcase/print-options.png
-share/doc/HTML/en/bookcase/template-options.png
-share/icons/hicolor/16x16/apps/bookcase.png
-share/icons/hicolor/32x32/apps/bookcase.png
-share/locale/bg/LC_MESSAGES/bookcase.mo
-share/locale/cs/LC_MESSAGES/bookcase.mo
-share/locale/de/LC_MESSAGES/bookcase.mo
-share/locale/ee/LC_MESSAGES/bookcase.mo
-share/locale/es/LC_MESSAGES/bookcase.mo
-share/locale/fi/LC_MESSAGES/bookcase.mo
-share/locale/fr/LC_MESSAGES/bookcase.mo
-share/locale/hu/LC_MESSAGES/bookcase.mo
-share/locale/it/LC_MESSAGES/bookcase.mo
-share/locale/nb/LC_MESSAGES/bookcase.mo
-share/locale/nl/LC_MESSAGES/bookcase.mo
-share/locale/ro/LC_MESSAGES/bookcase.mo
-share/locale/sv/LC_MESSAGES/bookcase.mo
-share/mimelnk/application/x-bookcase.desktop
+bin/tellico
+share/applnk/Applications/tellico.desktop
+share/apps/kconf_update/tellico-rename.upd
+share/apps/tellico/amazon2bookcase.xsl
+share/apps/tellico/bibtex-translation.xml
+share/apps/tellico/bookcase-by-author.xsl
+share/apps/tellico/bookcase-by-title.xsl
+share/apps/tellico/bookcase-common.xsl
+share/apps/tellico/bookcase-printing.xsl
+share/apps/tellico/bookcase2html.xsl
+share/apps/tellico/cassette-logo.png
+share/apps/tellico/cd-logo.png
+share/apps/tellico/dvd-logo.png
+share/apps/tellico/entry-templates/Album.xsl
+share/apps/tellico/entry-templates/Compact.xsl
+share/apps/tellico/entry-templates/Default.xsl
+share/apps/tellico/entry-templates/Fancy.xsl
+share/apps/tellico/entry-templates/Video.xsl
+share/apps/tellico/mods2bookcase.xsl
+share/apps/tellico/pics/album.png
+share/apps/tellico/pics/bibtex.png
+share/apps/tellico/pics/book.png
+share/apps/tellico/pics/card.png
+share/apps/tellico/pics/coin.png
+share/apps/tellico/pics/comic.png
+share/apps/tellico/pics/person-open.png
+share/apps/tellico/pics/person.png
+share/apps/tellico/pics/stamp.png
+share/apps/tellico/pics/tellico.png
+share/apps/tellico/pics/video.png
+share/apps/tellico/pics/wine.png
+share/apps/tellico/record-logo.png
+share/apps/tellico/shadowAlpha.png
+share/apps/tellico/tellico.dtd
+share/apps/tellico/tellico.tips
+share/apps/tellico/tellicoui.rc
+share/apps/tellico/vhs-logo.png
+share/doc/HTML/en/tellico/bibtex-options.png
+share/doc/HTML/en/tellico/common
+share/doc/HTML/en/tellico/configuration.docbook
+share/doc/HTML/en/tellico/csv-dialog.png
+share/doc/HTML/en/tellico/details.docbook
+share/doc/HTML/en/tellico/entry-editor1.png
+share/doc/HTML/en/tellico/entry-editor2.png
+share/doc/HTML/en/tellico/entry-editor3.png
+share/doc/HTML/en/tellico/entry-editor4.png
+share/doc/HTML/en/tellico/export-csv.png
+share/doc/HTML/en/tellico/export-html.png
+share/doc/HTML/en/tellico/export-options.png
+share/doc/HTML/en/tellico/faqs.docbook
+share/doc/HTML/en/tellico/fetch-dialog.png
+share/doc/HTML/en/tellico/fields-dialog.png
+share/doc/HTML/en/tellico/filter-dialog.png
+share/doc/HTML/en/tellico/fundamentals.docbook
+share/doc/HTML/en/tellico/general-options.png
+share/doc/HTML/en/tellico/hacking.docbook
+share/doc/HTML/en/tellico/importing-exporting.docbook
+share/doc/HTML/en/tellico/index.cache.bz2
+share/doc/HTML/en/tellico/index.docbook
+share/doc/HTML/en/tellico/main-window.png
+share/doc/HTML/en/tellico/menus.docbook
+share/doc/HTML/en/tellico/print-options.png
+share/doc/HTML/en/tellico/template-options.png
+share/icons/hicolor/16x16/apps/tellico.png
+share/icons/hicolor/32x32/apps/tellico.png
+share/locale/bg/LC_MESSAGES/tellico.mo
+share/locale/cs/LC_MESSAGES/tellico.mo
+share/locale/de/LC_MESSAGES/tellico.mo
+share/locale/ee/LC_MESSAGES/tellico.mo
+share/locale/es/LC_MESSAGES/tellico.mo
+share/locale/fi/LC_MESSAGES/tellico.mo
+share/locale/fr/LC_MESSAGES/tellico.mo
+share/locale/hu/LC_MESSAGES/tellico.mo
+share/locale/it/LC_MESSAGES/tellico.mo
+share/locale/nb/LC_MESSAGES/tellico.mo
+share/locale/nl/LC_MESSAGES/tellico.mo
+share/locale/ro/LC_MESSAGES/tellico.mo
+share/locale/sv/LC_MESSAGES/tellico.mo
+share/mimelnk/application/x-tellico.desktop
@unexec rmdir %D/share/mimelnk/application 2>/dev/null || true
@unexec rmdir %D/share/mimelnk 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/32x32/apps 2>/dev/null || true
@@ -79,12 +85,13 @@ share/mimelnk/application/x-bookcase.desktop
@unexec rmdir %D/share/icons/hicolor/16x16 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor 2>/dev/null || true
@unexec rmdir %D/share/icons 2>/dev/null || true
-@dirrm share/doc/HTML/en/bookcase
+@dirrm share/doc/HTML/en/tellico
@unexec rmdir %D/share/doc/HTML/en 2>/dev/null || true
@unexec rmdir %D/share/doc/HTML 2>/dev/null || true
-@dirrm share/apps/bookcase/pics
-@dirrm share/apps/bookcase/entry-templates
-@dirrm share/apps/bookcase
+@dirrm share/apps/tellico/pics
+@dirrm share/apps/tellico/entry-templates
+@dirrm share/apps/tellico
+@unexec rmdir %D/share/apps/kconf_update 2>/dev/null || true
@unexec rmdir %D/share/apps 2>/dev/null || true
@unexec rmdir %D/share/applnk/Applications 2>/dev/null || true
@unexec rmdir %D/share/applnk 2>/dev/null || true