aboutsummaryrefslogtreecommitdiff
path: root/misc/terraform/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-02-08 11:47:58 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-02-08 11:47:58 +0000
commit864ed0d273ee8feb18be8810f3e48033f71f98be (patch)
tree9aa43d6090948bc52f7aa2456329d1f7c312b3bc /misc/terraform/Makefile
parent2ea36c10d8d290571bae8de8b3806bd022bf9bba (diff)
downloadports-864ed0d273ee8feb18be8810f3e48033f71f98be.tar.gz
ports-864ed0d273ee8feb18be8810f3e48033f71f98be.zip
Notes
Diffstat (limited to 'misc/terraform/Makefile')
-rw-r--r--misc/terraform/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/misc/terraform/Makefile b/misc/terraform/Makefile
new file mode 100644
index 000000000000..f6b47e8054a7
--- /dev/null
+++ b/misc/terraform/Makefile
@@ -0,0 +1,37 @@
+# ex:ts=8
+# Ports collection makefile for: terraform
+# Date created: Feb 8, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= terraform
+PORTVERSION= 0.9.0
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
+ intl.4:${PORTSDIR}/devel/gettext \
+ png.5:${PORTSDIR}/graphics/png \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
+ xml.5:${PORTSDIR}/textproc/libxml
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_BISON= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12 gdkpixbuf orbit gnomelibs gnomeprint
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+USE_GMAKE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|Bison |Bison|" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s|malloc\.h|stdlib.h|" ${WRKSRC}/src/xmlsupport.c
+
+.include <bsd.port.mk>