aboutsummaryrefslogtreecommitdiff
path: root/misc/thefuck
diff options
context:
space:
mode:
authorGuangyuan Yang <ygy@FreeBSD.org>2018-01-05 09:26:49 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2018-01-05 09:26:49 +0000
commite161886166d91ccbbc3cc1e36705f7316a582ed3 (patch)
treee8975d500b3c40d6af0fa663ab2eab48e848fd0c /misc/thefuck
parent77644aaefe24145db03eec2eceaa74c8b14f0295 (diff)
downloadports-e161886166d91ccbbc3cc1e36705f7316a582ed3.tar.gz
ports-e161886166d91ccbbc3cc1e36705f7316a582ed3.zip
Notes
Diffstat (limited to 'misc/thefuck')
-rw-r--r--misc/thefuck/Makefile25
-rw-r--r--misc/thefuck/distinfo3
-rw-r--r--misc/thefuck/pkg-descr10
3 files changed, 38 insertions, 0 deletions
diff --git a/misc/thefuck/Makefile b/misc/thefuck/Makefile
new file mode 100644
index 000000000000..09a81828f99f
--- /dev/null
+++ b/misc/thefuck/Makefile
@@ -0,0 +1,25 @@
+# Created by: Guangyuan Yang <ygy@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= thefuck
+DISTVERSION= 3.25
+CATEGORIES= misc python
+MASTER_SITES= CHEESESHOP
+
+MAINTAINER= ygy@FreeBSD.org
+COMMENT= App that corrects your previous console command
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}colorama>0:devel/py-colorama@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}decorator>0:devel/py-decorator@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}psutil>0:sysutils/py-psutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyte>0:devel/py-pyte@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
+
+USES= python:3.4+
+USE_PYTHON= autoplist distutils noflavors
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/thefuck/distinfo b/misc/thefuck/distinfo
new file mode 100644
index 000000000000..ba0377499a16
--- /dev/null
+++ b/misc/thefuck/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1512711410
+SHA256 (thefuck-3.25.tar.gz) = 70cbe6295d2d2d371a395619216d38eb1666e4b3c3b1a24f67d11b88e65fea78
+SIZE (thefuck-3.25.tar.gz) = 63444
diff --git a/misc/thefuck/pkg-descr b/misc/thefuck/pkg-descr
new file mode 100644
index 000000000000..a1af4b98b879
--- /dev/null
+++ b/misc/thefuck/pkg-descr
@@ -0,0 +1,10 @@
+Thefuck is a magnificent app which corrects your previous console command.
+It tries to match a rule for the previous command, creates a new command
+using the matched rule and runs it. Thefuck comes with a lot of predefined
+rules, but you can create your own rules as well.
+
+You should place this command in your shell config file:
+
+eval $(thefuck --alias)
+
+WWW: https://github.com/nvbn/thefuck