aboutsummaryrefslogtreecommitdiff
path: root/misc/tkcron
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-11-28 18:32:45 +0000
committerSteve Price <steve@FreeBSD.org>1999-11-28 18:32:45 +0000
commitbc087374d35aa9c841dd63d44e9c9697702921ed (patch)
tree9bfffecdf0e79fc2f3af0e2a2f1044536ad164ca /misc/tkcron
parent3689fb2140698b1b4eff0933fe730262b161f533 (diff)
downloadports-bc087374d35aa9c841dd63d44e9c9697702921ed.tar.gz
ports-bc087374d35aa9c841dd63d44e9c9697702921ed.zip
Update to use Tcl/Tk version 8.2.
Submitted by: Ade Lovett <ade@lovett.com>
Notes
Notes: svn path=/head/; revision=23474
Diffstat (limited to 'misc/tkcron')
-rw-r--r--misc/tkcron/Makefile4
-rw-r--r--misc/tkcron/files/Makefile6
2 files changed, 7 insertions, 3 deletions
diff --git a/misc/tkcron/Makefile b/misc/tkcron/Makefile
index a2a57e87790e..d4811e53ac20 100644
--- a/misc/tkcron/Makefile
+++ b/misc/tkcron/Makefile
@@ -7,13 +7,13 @@
#
DISTNAME= tkcron-2.12
-CATEGORIES= misc tk80
+CATEGORIES= misc tk82
MASTER_SITES= ftp://ftp.neosoft.com/languages/tcl/alcatel/code/
EXTRACT_SUFX= .tcl.gz
MAINTAINER= sander@haldjas.folklore.ee
-RUN_DEPENDS= wish8.0:${PORTSDIR}/x11-toolkits/tk80
+RUN_DEPENDS= wish8.2:${PORTSDIR}/x11-toolkits/tk82
EXTRACT_CMD= ${GZIP_CMD}
EXTRACT_BEFORE_ARGS= -cd
diff --git a/misc/tkcron/files/Makefile b/misc/tkcron/files/Makefile
index b46a3ce43f0b..b18a1dee335f 100644
--- a/misc/tkcron/files/Makefile
+++ b/misc/tkcron/files/Makefile
@@ -1,10 +1,14 @@
+#
+# $FreeBSD$
+#
+
BINDIR= ${PREFIX}/bin
WISHDIR?= ${BINDIR}
all: tkcron
tkcron:
- sed -e "\:/usr/local/bin/wish: s;;${BINDIR}/wish8.0;g" tkcron.tcl > tkcron
+ sed -e "\:/usr/local/bin/wish: s;;${BINDIR}/wish8.2;g" tkcron.tcl > tkcron
install: all
install ${COPY} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} tkcron ${BINDIR}