aboutsummaryrefslogtreecommitdiff
path: root/misc/tkman
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-04-21 12:02:17 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-04-21 12:02:17 +0000
commitadeb7ff8955ba9665ba530405657c39a9514f9c4 (patch)
tree86e093738357cbe18f17c07d3914936f1d0d254c /misc/tkman
parent067be7699cbc5e101d0aedf80dd1871dc617ba74 (diff)
downloadports-adeb7ff8955ba9665ba530405657c39a9514f9c4.tar.gz
ports-adeb7ff8955ba9665ba530405657c39a9514f9c4.zip
Notes
Diffstat (limited to 'misc/tkman')
-rw-r--r--misc/tkman/Makefile12
-rw-r--r--misc/tkman/files/patch-aa103
2 files changed, 12 insertions, 103 deletions
diff --git a/misc/tkman/Makefile b/misc/tkman/Makefile
index 8941ef9d451a..b3128d396be7 100644
--- a/misc/tkman/Makefile
+++ b/misc/tkman/Makefile
@@ -20,12 +20,24 @@ RUN_DEPENDS= rman:${PORTSDIR}/textproc/rman \
glimpse:${PORTSDIR}/textproc/glimpse
USE_GMAKE= yes
+MAKE_ARGS= WISH="${PREFIX}/bin/wish8.4" \
+ texinfodir="${PREFIX}/info" \
+ gzgrep="\"/usr/bin/zgrep -E\"" \
+ mastermen="\"/usr/share/man ${PREFIX}/man ${X11BASE}/man\"" \
+ masterbin="\"/usr/bin ${PREFIX}/bin ${X11BASE}/bin\"" \
+ manformat="{groff -Tlatin1 -te -mandoc}" \
+ manprint="{groff -mandoc -Tps -te -l}"
+
USE_REINPLACE= yes
post-patch:
@${REINPLACE_CMD} -e "s;/usr/local/bin/wish;${PREFIX}/bin/wish8.4;" \
${WRKSRC}/contrib/tkmanclient
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/tkman ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/retkman ${PREFIX}/bin
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/misc/tkman/files/patch-aa b/misc/tkman/files/patch-aa
deleted file mode 100644
index 3a6b92cdf5cc..000000000000
--- a/misc/tkman/files/patch-aa
+++ /dev/null
@@ -1,103 +0,0 @@
---- Makefile.orig Wed Apr 2 01:31:38 2003
-+++ Makefile Sun Oct 19 11:05:53 2003
-@@ -25,14 +25,16 @@
-
- ### you need to localize the paths on these lines
-
--WISH = /usr/local/bin/wish8.4
-+#WISH = /usr/local/bin/wish8.4
- #WISH = /usr/sww/tcl-8.4/bin/wish
- #WISH = /private/share/bin/wish8.4
-+WISH = ${PREFIX}/bin/wish8.4
-
- # the executable `tkman' is placed in BINDIR
- # this should be a directory that's in your bin PATH
--BINDIR = /usr/local/bin
-+#BINDIR = /usr/local/bin
- #BINDIR = /private/share/bin
-+BINDIR = ${PREFIX}/bin
-
-
- # OPTIONAL FEATURES
-@@ -42,13 +44,14 @@
- # This directory should not have any Texinfo source itself.
- # More information is given in manual.html
- # if you don't have Texinfo files, leave this variable empty
--texinfodir = ""
-+#texinfodir = ""
- #texinfodir = /home/orodruin/h/bair/phelps/spine/tkman/info
- #texinfodir = /usr/local/info
-+texinfodir = ${PREFIX}/info
- # In order to search within Texinfo files you need a grep, such as GNU grep 2.1,
- # that can report byte offsets (with the -b switch). This needs to be
- # gzgrep if you'll be searching in compressed Texinfo source.
--gzgrep = ""
-+#gzgrep = ""
- #gzgrep = "gzgrep -E"
- #gzgrep = "gzgrep -Ew"
- # Linux calls it zgrep
-@@ -57,6 +60,7 @@
- #gzgrep = grep
- # if you don't compress your Texinfo source, this is fine
- #gzgrep = grep
-+gzgrep = "/usr/bin/zgrep -E"
-
- # OPTIONAL
- # directory root of hierarchy of RFC files, with "rfc-index.txt" at the root
-@@ -80,10 +84,12 @@
- # will examine for matches if a search in the usual locations fails while searching
- # for a man pages and displaying its associated binaries (if any).
- # Use this feature carefully as a large number of directories can slow down startup.
--mastermen = "/usr/man /usr/local/man"
-+#mastermen = "/usr/man /usr/local/man"
- #mastermen = "/usr/man /usr/local/man /usr/sww/man /usr/share/man /usr/kerberos/man"
--masterbin = "/usr/bin /usr/local/bin"
-+mastermen = "/usr/share/man ${PREFIX}/man ${X11BASE}/man"
-+#masterbin = "/usr/bin /usr/local/bin"
- #masterbin = "/usr/bin /usr/local/bin /usr/sww/bin /usr/sww/share/bin /usr/sww/share/X11R5/bin"
-+masterbin = "/usr/bin ${PREFIX}/bin ${X11BASE}/bin"
-
-
- # names of common printers, in addition to default printer (PRINTER or LPDEST)
-@@ -113,7 +119,7 @@
- # Lines are cached in .../man/cat<n>@<line-length>;
- # that is, the line length is appended to the usual cache directory names
- #manformat = {groff -te -Tascii -man /tmp/ll -}
--manformat = {groff -te -Tlatin1 -man /tmp/ll -}
-+#manformat = {groff -te -Tlatin1 -man /tmp/ll -}
- # Ultrix users should uncomment the following line (you don't have eqn)
- #manformat = {tbl | nroff -man }
- # HP-UX uses a number of macros that groff doesn't define, so use the builtin nroff
-@@ -122,6 +128,7 @@
- #manformat = {tbl | neqn | nroff -man }
- # BSD macros (.Sh, .Ss, .PP, ...) need -mandoc
- #manformat = {groff -Tascii -te -mandoc}
-+manformat = {groff -Tlatin1 -te -mandoc}
- # BSDI
- #manformat = {tbl | eqn -Tascii | nroff -man }
- # It's actually legal to leave this empty if all the pages you'll ever
-@@ -166,13 +173,14 @@
-
- # pick a printing pipeline for which your platform has all the constituants
- #manprint = {groff -man -Tps -te -l}
-+manprint = {groff -mandoc -Tps -te -l}
- # alternatives
- #manprint = {groff -man -Tps -te -l | psnup -n2}
- #manprint = {tbl | eqn | troff -man -t | lpr -t}
- #manprint = {tbl | eqn | psroff -man}
- #manprint = {tbl | eqn | gtroff -Tpsc | psdit | lpr}
- # use an empty pipeline if you're environmentally conscious or have no printer
--manprint = ""
-+#manprint = ""
- # printing string for preformatted pages without [tn]roff source
- #catprint = lpr
- #catprint = "lpr -h"
-@@ -460,7 +468,7 @@
- chmod +rx $(BINDIR)/tkman
- $(CP) retkman $(BINDIR)
- chmod +rx $(BINDIR)/retkman
-- @echo 'You also need RosettaMan to run TkMan.'
-+# @echo 'You also need RosettaMan to run TkMan.'
-
- test: dox tkman
- cp tkman $(BINDIR)