aboutsummaryrefslogtreecommitdiff
path: root/misc/toilet
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-08-13 11:53:30 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-08-13 11:53:30 +0000
commitf5d8044bf4605e6bc1c3d7a458c53f0f7b32539c (patch)
tree0d494d756cd7bebcb571b5dcac4ef68a7bcf7267 /misc/toilet
parent73eb29be00c754c013a018a723ddc55069f4e810 (diff)
Add port misc/toilet:
The TOIlet project attempts to create a free replacement for the FIGlet utility. TOIlet stands for "The Other Implementation's letters", coined after FIGlet's "Frank, Ian and Glen's letters". TOIlet is in its very early development phase. It uses the powerful libcucul library to achieve various text-based effects. TOIlet implements or plans to implement the following features: * The ability to load FIGlet fonts * Support for Unicode input and output * Support for colour output * Support for various output formats: HTML, IRC, ANSI... TOIlet also aims for full FIGlet compatibility. It is currently able to load FIGlet fonts and perform horizontal smushing. WWW: http://libcaca.zoy.org/toilet.html Author: Sam Hocevar <sam@zoy.org> Based on: Gentoo Portage
Notes
Notes: svn path=/head/; revision=197569
Diffstat (limited to 'misc/toilet')
-rw-r--r--misc/toilet/Makefile33
-rw-r--r--misc/toilet/distinfo3
-rw-r--r--misc/toilet/pkg-descr17
-rw-r--r--misc/toilet/pkg-plist15
4 files changed, 68 insertions, 0 deletions
diff --git a/misc/toilet/Makefile b/misc/toilet/Makefile
new file mode 100644
index 000000000000..296a776d5e57
--- /dev/null
+++ b/misc/toilet/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: toilet
+# Date created: 13 August 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= toilet
+PORTVERSION= 0.1
+CATEGORIES= misc
+MASTER_SITES= http://libcaca.zoy.org/files/ CENKES
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Enhanced figlet(6)
+
+LIB_DEPENDS= cucul.0:${PORTSDIR}/graphics/libcaca
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-transform-name=""
+CFLAGS+= -fno-strength-reduce
+MAN1= ${PORTNAME}.1
+PORT_VERBS= ${PORTNAME} caca2tlf share/figlet/*tlf
+
+post-patch:
+ @${REINPLACE_CMD} -e '/CFLAGS=/d;\
+ s| date.*stamp| date -jf"%Y-%m-%d" "$$stamp" +"%e %B %Y|'\
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|\$$\^|$${.ALLSRC}|' ${WRKSRC}/doc/Makefile.in
+
+post-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/tools/caca2tlf ${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/misc/toilet/distinfo b/misc/toilet/distinfo
new file mode 100644
index 000000000000..a8e2968c4fc6
--- /dev/null
+++ b/misc/toilet/distinfo
@@ -0,0 +1,3 @@
+MD5 (toilet-0.1.tar.gz) = 7d26ca36c83eeca2f0c285872624c2c8
+SHA256 (toilet-0.1.tar.gz) = 626663a5dbed9c1c5844480b91812f0be4fe8c3c0135f44ef76490f79632d2da
+SIZE (toilet-0.1.tar.gz) = 429493
diff --git a/misc/toilet/pkg-descr b/misc/toilet/pkg-descr
new file mode 100644
index 000000000000..20f5d3fac075
--- /dev/null
+++ b/misc/toilet/pkg-descr
@@ -0,0 +1,17 @@
+The TOIlet project attempts to create a free replacement for the FIGlet
+utility. TOIlet stands for "The Other Implementation's letters", coined
+after FIGlet's "Frank, Ian and Glen's letters".
+
+TOIlet is in its very early development phase. It uses the powerful
+libcucul library to achieve various text-based effects. TOIlet
+implements or plans to implement the following features:
+* The ability to load FIGlet fonts
+* Support for Unicode input and output
+* Support for colour output
+* Support for various output formats: HTML, IRC, ANSI...
+
+TOIlet also aims for full FIGlet compatibility. It is currently able to
+load FIGlet fonts and perform horizontal smushing.
+
+WWW: http://libcaca.zoy.org/toilet.html
+Author: Sam Hocevar <sam@zoy.org>
diff --git a/misc/toilet/pkg-plist b/misc/toilet/pkg-plist
new file mode 100644
index 000000000000..6576054dad6e
--- /dev/null
+++ b/misc/toilet/pkg-plist
@@ -0,0 +1,15 @@
+bin/caca2tlf
+bin/toilet
+share/figlet/bigmono12.tlf
+share/figlet/bigmono9.tlf
+share/figlet/circle.tlf
+share/figlet/emboss.tlf
+share/figlet/emboss2.tlf
+share/figlet/future.tlf
+share/figlet/mono12.tlf
+share/figlet/mono9.tlf
+share/figlet/smblock.tlf
+share/figlet/smbraille.tlf
+share/figlet/smmono12.tlf
+share/figlet/smmono9.tlf
+@dirrmtry share/figlet