aboutsummaryrefslogtreecommitdiff
path: root/misc/tpp
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-08-30 14:03:30 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-08-30 14:03:30 +0000
commitf5811dfd829ae9bd68338bb86e717d16f297b86b (patch)
tree382745628068debadf6c47213f1b2cb9015c5591 /misc/tpp
parentcf53242161ec968c6fb57d8e09951f7d17c5287e (diff)
downloadports-f5811dfd829ae9bd68338bb86e717d16f297b86b.tar.gz
ports-f5811dfd829ae9bd68338bb86e717d16f297b86b.zip
Notes
Diffstat (limited to 'misc/tpp')
-rw-r--r--misc/tpp/Makefile39
-rw-r--r--misc/tpp/distinfo2
-rw-r--r--misc/tpp/pkg-descr4
-rw-r--r--misc/tpp/pkg-plist21
4 files changed, 66 insertions, 0 deletions
diff --git a/misc/tpp/Makefile b/misc/tpp/Makefile
new file mode 100644
index 000000000000..04d9e4a43960
--- /dev/null
+++ b/misc/tpp/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: tpp
+# Date created: 2004-08-30
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= tpp
+PORTVERSION= 1.0
+CATEGORIES= misc
+MASTER_SITES= http://synflood.at/tpp/
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= Text presentation program
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/ncurses.rb:${PORTSDIR}/devel/ruby-ncurses \
+ figlet:${PORTSDIR}/misc/figlet
+
+NO_BUILD= yes
+USE_REINPLACE= yes
+USE_RUBY= yes
+RUBY_NO_BUILD_DEPENDS= yes
+
+MAN1= tpp.1
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,/usr/bin,${PREFIX}/bin," ${WRKSRC}/tpp.rb
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/tpp.rb ${PREFIX}/bin
+ ${LN} -sf ${PREFIX}/bin/tpp.rb ${PREFIX}/bin/tpp
+ ${INSTALL_MAN} ${WRKSRC}/doc/tpp.1 ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}; ${INSTALL_DATA} CHANGES COPYING README ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}/examples
+ cd ${WRKSRC}/examples; ${INSTALL_DATA} * ${DOCSDIR}/examples
+.endif
+
+.include <bsd.port.mk>
diff --git a/misc/tpp/distinfo b/misc/tpp/distinfo
new file mode 100644
index 000000000000..a306e6cddf60
--- /dev/null
+++ b/misc/tpp/distinfo
@@ -0,0 +1,2 @@
+MD5 (tpp-1.0.tar.gz) = 03683cb9ce66caca237b1b4402df3bcf
+SIZE (tpp-1.0.tar.gz) = 24519
diff --git a/misc/tpp/pkg-descr b/misc/tpp/pkg-descr
new file mode 100644
index 000000000000..4e50d94759b3
--- /dev/null
+++ b/misc/tpp/pkg-descr
@@ -0,0 +1,4 @@
+tpp is an ncurses-based presentation tool
+
+WWW: http://synflood.at/tpp/
+Author: Andreas Krennmair <ak@synflood.at>
diff --git a/misc/tpp/pkg-plist b/misc/tpp/pkg-plist
new file mode 100644
index 000000000000..4425631b4521
--- /dev/null
+++ b/misc/tpp/pkg-plist
@@ -0,0 +1,21 @@
+bin/tpp.rb
+bin/tpp
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/examples/ac-am.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/bold.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/center-et-al.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/colors.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/colors2.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/exec.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/horline.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/huge.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/list.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/manyslides.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/shell.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/slidein.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/source.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/test.tpp
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/examples
+%%PORTDOCS%%@dirrm %%DOCSDIR%%