aboutsummaryrefslogtreecommitdiff
path: root/misc/txt2regex/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-06-14 07:51:23 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-06-14 07:51:23 +0000
commit21e9cf1799e57dd07f49d43c8d97ad325fc54108 (patch)
tree64b71698f91d59c64b2ec3642875974da3a91c0a /misc/txt2regex/Makefile
parent3a26ce1394c0358c066a93e5d32e1f00e372afb8 (diff)
Notes
Diffstat (limited to 'misc/txt2regex/Makefile')
-rw-r--r--misc/txt2regex/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/misc/txt2regex/Makefile b/misc/txt2regex/Makefile
new file mode 100644
index 000000000000..6ccacb664b1e
--- /dev/null
+++ b/misc/txt2regex/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# New ports collection makefile for: txt2regex
+# Date created: Jun 14, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= txt2regex
+PORTVERSION= 0.3
+CATEGORIES= misc
+MASTER_SITES= http://txt2regex.sourceforge.net/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ijliao@FreeBSD.org
+
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
+ gseq:${PORTSDIR}/misc/sh-utils
+
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e "s,/bin/bash,${LOCALBASE}/bin/bash,g ; \
+ s,\`seq,\`gseq,g" ${WRKSRC}/txt2regex-0.3.sh
+ @${PERL} -pi -e "s,/usr,${LOCALBASE},g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/txt2regex-0.3.sh ${PREFIX}/bin/txt2regex
+
+.include <bsd.port.mk>