aboutsummaryrefslogtreecommitdiff
path: root/misc/txt2regex
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-06-14 07:51:23 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-06-14 07:51:23 +0000
commit21e9cf1799e57dd07f49d43c8d97ad325fc54108 (patch)
tree64b71698f91d59c64b2ec3642875974da3a91c0a /misc/txt2regex
parent3a26ce1394c0358c066a93e5d32e1f00e372afb8 (diff)
downloadports-21e9cf1799e57dd07f49d43c8d97ad325fc54108.tar.gz
ports-21e9cf1799e57dd07f49d43c8d97ad325fc54108.zip
Notes
Diffstat (limited to 'misc/txt2regex')
-rw-r--r--misc/txt2regex/Makefile30
-rw-r--r--misc/txt2regex/distinfo1
-rw-r--r--misc/txt2regex/pkg-comment1
-rw-r--r--misc/txt2regex/pkg-descr7
-rw-r--r--misc/txt2regex/pkg-plist1
5 files changed, 40 insertions, 0 deletions
diff --git a/misc/txt2regex/Makefile b/misc/txt2regex/Makefile
new file mode 100644
index 000000000000..6ccacb664b1e
--- /dev/null
+++ b/misc/txt2regex/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# New ports collection makefile for: txt2regex
+# Date created: Jun 14, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= txt2regex
+PORTVERSION= 0.3
+CATEGORIES= misc
+MASTER_SITES= http://txt2regex.sourceforge.net/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ijliao@FreeBSD.org
+
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
+ gseq:${PORTSDIR}/misc/sh-utils
+
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e "s,/bin/bash,${LOCALBASE}/bin/bash,g ; \
+ s,\`seq,\`gseq,g" ${WRKSRC}/txt2regex-0.3.sh
+ @${PERL} -pi -e "s,/usr,${LOCALBASE},g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/txt2regex-0.3.sh ${PREFIX}/bin/txt2regex
+
+.include <bsd.port.mk>
diff --git a/misc/txt2regex/distinfo b/misc/txt2regex/distinfo
new file mode 100644
index 000000000000..fff984d45fcd
--- /dev/null
+++ b/misc/txt2regex/distinfo
@@ -0,0 +1 @@
+MD5 (txt2regex-0.3.tgz) = bcf6c5e1b27edd3d80c63d269aa96fa0
diff --git a/misc/txt2regex/pkg-comment b/misc/txt2regex/pkg-comment
new file mode 100644
index 000000000000..fcbe480fbca7
--- /dev/null
+++ b/misc/txt2regex/pkg-comment
@@ -0,0 +1 @@
+A Regular Expression "wizard"
diff --git a/misc/txt2regex/pkg-descr b/misc/txt2regex/pkg-descr
new file mode 100644
index 000000000000..505417e9eeea
--- /dev/null
+++ b/misc/txt2regex/pkg-descr
@@ -0,0 +1,7 @@
+^txt2regex$ is a Regular Expression "wizard", all written with bash2 builtins,
+that converts human sentences to RegExs. with a simple interface, you just
+answer to questions and build your own RegEx for a large variety of programs,
+like awk, ed, emacs, grep, perl, php, python, sed, tcl and vim. there are 18
+supported programs now.
+
+WWW: http://txt2regex.sourceforge.net/
diff --git a/misc/txt2regex/pkg-plist b/misc/txt2regex/pkg-plist
new file mode 100644
index 000000000000..d98f60cfe8f5
--- /dev/null
+++ b/misc/txt2regex/pkg-plist
@@ -0,0 +1 @@
+bin/txt2regex