aboutsummaryrefslogtreecommitdiff
path: root/misc/uf-view/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-05-30 20:19:32 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-05-30 20:19:32 +0000
commit246dffc5878dec9571b501e3e5cc4d417e965db3 (patch)
tree24d05c11f2826d40c5403772e3e0dc710427b219 /misc/uf-view/Makefile
parent6a9be81a73972df415d170dea71461f3995fa4ea (diff)
Notes
Diffstat (limited to 'misc/uf-view/Makefile')
-rw-r--r--misc/uf-view/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/misc/uf-view/Makefile b/misc/uf-view/Makefile
new file mode 100644
index 000000000000..7df7dcdf88b7
--- /dev/null
+++ b/misc/uf-view/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: uf-view
+# Date created: 5 December 1994
+# Whom: Jonathan McGee <mcgee@mcgee.student.umd.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uf-view
+PORTVERSION= 1.4.2
+CATEGORIES= misc
+MASTER_SITES= http://hadess.net/files/
+
+MAINTAINER= mcgee@wam.umd.edu
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>