aboutsummaryrefslogtreecommitdiff
path: root/misc/upclient/files
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-02-14 00:16:51 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-02-14 00:16:51 +0000
commit528f5193e7f11cb319d304a9ddf65bcc6f6ef2f7 (patch)
tree8030ef36bdd2534e99c44bb6f408740841a3220c /misc/upclient/files
parent3a0e8c9f670791ad867bce42b026cae988cc4e9a (diff)
downloadports-528f5193e7f11cb319d304a9ddf65bcc6f6ef2f7.tar.gz
ports-528f5193e7f11cb319d304a9ddf65bcc6f6ef2f7.zip
Notes
Diffstat (limited to 'misc/upclient/files')
-rw-r--r--misc/upclient/files/patch-aa32
-rw-r--r--misc/upclient/files/patch-ab2
-rw-r--r--misc/upclient/files/patch-stats-bsd.c23
-rw-r--r--misc/upclient/files/upclient.sh2
4 files changed, 26 insertions, 33 deletions
diff --git a/misc/upclient/files/patch-aa b/misc/upclient/files/patch-aa
index b0deb2cc3186..b4c8f6944897 100644
--- a/misc/upclient/files/patch-aa
+++ b/misc/upclient/files/patch-aa
@@ -1,33 +1,35 @@
---- src/Makefile.orig Sat Nov 30 03:29:55 2002
-+++ src/Makefile Wed Dec 18 01:29:34 2002
+--- src/Makefile.orig Wed Dec 18 01:01:16 2002
++++ src/Makefile Mon Feb 3 20:18:03 2003
@@ -34,7 +34,7 @@
#
- PROGRAMNAME = upclient
- # UPCLIENT_VERSION = "5.0b6"
+ PROGRAMNAME = UpClient
+ # UPCLIENT_VERSION = "5.0b7"
- UPCLIENT_VERSION = `grep '\#define UPCLIENT_VERSION ' version.h | sed -e 's@\#define UPCLIENT_VERSION @@g' | tr -d '"'`
-+ UPCLIENT_VERSION = `sed -n 's/"//g;/\#define UPCLIENT_VERSION /s///p' version.h`
- ################################################################################
++ UPCLIENT_VERSION = `sed -n 's/"//g;/\#define UPCLIENT_VERSION /s///p' version.h`
+ #########################################################################
- binname = upclient
-@@ -44,7 +44,7 @@
+@@ -46,7 +46,7 @@
+ OPTIMIZATION_CFLAGS=-O3
# System directories
-prefix = /usr/local
+prefix = %%PREFIX%%
#prefix = /sw
- #prefix = /opt/${PROGRAMNAME}
-
-@@ -55,7 +55,7 @@
- sbindir = ${exec_prefix}/sbin
+ #prefix = /opt/${binname}
+ #prefix = /tmp/upclient
+@@ -59,8 +59,8 @@
datadir = ${prefix}/share
sysconfdir = ${prefix}/etc
+ #sysconfdir = /etc
-localstatedir = ${prefix}/var
+-#localstatedir = /var
++#localstatedir = ${prefix}/var
+localstatedir = /var
+ destdir=
+
- # Further Reading
- # Filesystem Hierarchy Standard 2.2 May 24, 2001
-@@ -82,9 +82,9 @@
+@@ -90,9 +90,9 @@
## [x86] FreeBSD (4.7-RC)
## assumes gettext installed in /usr/local
diff --git a/misc/upclient/files/patch-ab b/misc/upclient/files/patch-ab
index e65685849647..ed742e878c4c 100644
--- a/misc/upclient/files/patch-ab
+++ b/misc/upclient/files/patch-ab
@@ -2,7 +2,7 @@
+++ src/conf/upclient.conf Wed Dec 18 02:31:09 2002
@@ -9,7 +9,7 @@
- AuthKey = <your_authkey> # Your Authorization key
+ AuthKey = your_authkey # Your Authorization key
-Interval = 300 # Transmit interval
+Interval = 550 # Transmit interval
diff --git a/misc/upclient/files/patch-stats-bsd.c b/misc/upclient/files/patch-stats-bsd.c
index 2c5f1380a3b5..deb664280f60 100644
--- a/misc/upclient/files/patch-stats-bsd.c
+++ b/misc/upclient/files/patch-stats-bsd.c
@@ -1,5 +1,5 @@
---- src/stats-bsd.c.orig Sat Nov 30 03:27:16 2002
-+++ src/stats-bsd.c Wed Dec 18 03:28:16 2002
+--- src/stats-bsd.c.orig Wed Dec 18 01:01:17 2002
++++ src/stats-bsd.c Mon Feb 3 20:20:12 2003
@@ -64,6 +64,8 @@
#include "locale.h" /* gettext */
@@ -67,17 +67,8 @@
}
#if !defined __MACH__ /* Mach kernel stuff is in stats-mach.c */
-@@ -245,7 +245,7 @@
-
- for (state = 0; state < CPUSTATES; state++) {
- time += ctime[state] - stime[state];
-- if (!(state == CPU_STATE_IDLE)) {
-+ if (!(state == CP_IDLE)) {
- nonidlecpu += (float)(ctime[state] - stime[state]);
- }
- }
-@@ -258,6 +258,10 @@
-
+@@ -259,6 +259,10 @@
+ /* store values for next calculation interval */
for (state = 0; state < CPUSTATES; state++)
stime[state] = ctime[state];
+#if defined DEBUG
@@ -87,7 +78,7 @@
}
}
else {
-@@ -268,17 +272,13 @@
+@@ -269,17 +273,13 @@
cfg_SendUsage = 0;
cfg_SendIdle = 0;
}
@@ -106,7 +97,7 @@
boottimesecs = initBoottime();
-@@ -293,7 +293,7 @@
+@@ -294,7 +294,7 @@
#endif /* DEBUG */
}
else {
@@ -115,7 +106,7 @@
"getUptime() boottime.tv_sec");
}
}
-@@ -306,19 +306,18 @@
+@@ -307,19 +307,18 @@
double *IdlePercent, char *osname, char *osversion, char *cpu,
double *loadavg)
{
diff --git a/misc/upclient/files/upclient.sh b/misc/upclient/files/upclient.sh
index 549ea783dc44..b44005f1061f 100644
--- a/misc/upclient/files/upclient.sh
+++ b/misc/upclient/files/upclient.sh
@@ -49,7 +49,7 @@ start)
"${config_path}."
exit 72
fi
- if grep -qs "^[$ws]*AuthKey[$ws]*=[$ws]*<your_authkey>" ${config_path}
+ if grep -qs "^[$ws]*AuthKey[$ws]*=[$ws]*your_authkey" ${config_path}
then
logger -sp ${syslog_facility} -t ${program_file} \
"unable to start: AuthKey isn't configured in" \