aboutsummaryrefslogtreecommitdiff
path: root/misc/vifm
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-07-02 16:10:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-07-02 16:10:58 +0000
commitfd7cf054ebb022815fe26e8d556d709aa5b89e70 (patch)
tree4f4271a002be31074714d847b2ce6ed7241a0259 /misc/vifm
parent72debfa859e9bf0c1447626da6c145dda7280964 (diff)
downloadports-fd7cf054ebb022815fe26e8d556d709aa5b89e70.tar.gz
ports-fd7cf054ebb022815fe26e8d556d709aa5b89e70.zip
- Update to 0.6.2
PR: 158493 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=276913
Diffstat (limited to 'misc/vifm')
-rw-r--r--misc/vifm/Makefile43
-rw-r--r--misc/vifm/distinfo4
-rw-r--r--misc/vifm/files/patch-src__commands.c11
-rw-r--r--misc/vifm/files/patch-src__file_magic.c13
-rw-r--r--misc/vifm/files/patch-src__status.c12
5 files changed, 62 insertions, 21 deletions
diff --git a/misc/vifm/Makefile b/misc/vifm/Makefile
index 53e588c08a18..15164b686678 100644
--- a/misc/vifm/Makefile
+++ b/misc/vifm/Makefile
@@ -6,44 +6,49 @@
#
PORTNAME= vifm
-PORTVERSION= 0.5
+PORTVERSION= 0.6.2
CATEGORIES= misc
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Ncurses based file manager with vi like keybindings
-.if defined(WITH_VIFM_SCREEN)
-RUN_DEPENDS= screen:${PORTSDIR}/sysutils/screen
-.endif
+OPTIONS= VIFM_SCREEN "Use vifm with the screen program" off
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_BZIP2= yes
+USE_NCURSES= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-gtk
+MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOHEADER="${TRUE}" \
+ AUTOMAKE="${TRUE}"
+MAN1= vifm.1
PLIST_FILES= bin/pauseme \
bin/vifm \
- share/vifm/vifm-help.txt \
- share/vifm/vifm.txt \
- share/vifm/vifm.vim
-PLIST_DIRS= share/vifm
+ %%DATADIR%%/startup \
+ %%DATADIR%%/vifm-help.txt \
+ %%DATADIR%%/vifm.txt \
+ %%DATADIR%%/vifm.vim \
+ %%DATADIR%%/vifmrc
+PLIST_DIRS= %%DATADIR%%
-MAN1= vifm.1
-MANCOMPRESSED= no
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_VIFM_SCREEN)
+RUN_DEPENDS= screen:${PORTSDIR}/sysutils/screen
+.endif
post-patch:
@${REINPLACE_CMD} -e 's/resize_term/resizeterm/g' \
${WRKSRC}/src/ui.c
-
.if defined(WITH_VIFM_SCREEN)
-pre-build:
@${REINPLACE_CMD} -e "s/cfg.use_screen = 0/cfg.use_screen = 1/" \
${WRKSRC}/src/config.c
@${REINPLACE_CMD} -e "s/USE_SCREEN=0/USE_SCREEN=1/" \
${WRKSRC}/src/vifmrc
-.else
-pre-everything::
- @${ECHO_CMD} "You can define WITH_VIFM_SCREEN to add screen as a dependency."
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/misc/vifm/distinfo b/misc/vifm/distinfo
index 759dccf6f481..e32dd0d314cf 100644
--- a/misc/vifm/distinfo
+++ b/misc/vifm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (vifm-0.5.tar.bz2) = 11bc1138050d6b2887d7f099e12bc57d27cc60a6f14252744654c35d22d38164
-SIZE (vifm-0.5.tar.bz2) = 272835
+SHA256 (vifm-0.6.2.tar.bz2) = 8375f0cce8e1a703cf97322dbbab7ce2fc3be2b2ee072085b10623510b88c137
+SIZE (vifm-0.6.2.tar.bz2) = 333249
diff --git a/misc/vifm/files/patch-src__commands.c b/misc/vifm/files/patch-src__commands.c
new file mode 100644
index 000000000000..8d6b860cabed
--- /dev/null
+++ b/misc/vifm/files/patch-src__commands.c
@@ -0,0 +1,11 @@
+--- src/commands.c.orig 2011-06-19 22:52:25.000000000 +0900
++++ src/commands.c 2011-06-26 15:19:03.000000000 +0900
+@@ -27,6 +27,8 @@
+ #include <stdlib.h> /* system() */
+ #include <string.h> /* strncmp() */
+ #include <time.h>
++#include <sys/types.h>
++#include <sys/wait.h>
+
+ #include "background.h"
+ #include "bookmarks.h"
diff --git a/misc/vifm/files/patch-src__file_magic.c b/misc/vifm/files/patch-src__file_magic.c
new file mode 100644
index 000000000000..ffe30275ab16
--- /dev/null
+++ b/misc/vifm/files/patch-src__file_magic.c
@@ -0,0 +1,13 @@
+--- src/file_magic.c.orig 2011-06-19 22:52:25.000000000 +0900
++++ src/file_magic.c 2011-06-26 15:30:02.000000000 +0900
+@@ -9,7 +9,9 @@
+ #include <magic.h>
+ #endif
+
+-#include <sys/dir.h>
++#include <sys/types.h>
++#include <dirent.h>
++#include <limits.h>
+
+ #include <stdio.h>
+ #include <stdlib.h>
diff --git a/misc/vifm/files/patch-src__status.c b/misc/vifm/files/patch-src__status.c
new file mode 100644
index 000000000000..70142a3ea960
--- /dev/null
+++ b/misc/vifm/files/patch-src__status.c
@@ -0,0 +1,12 @@
+--- src/status.c.orig 2011-06-19 22:52:25.000000000 +0900
++++ src/status.c 2011-06-26 15:27:19.000000000 +0900
+@@ -41,7 +41,9 @@
+ curr_stats.dirsize_cache = 0;
+ curr_stats.fast_run = 0;
+ curr_stats.errmsg_shown = 0;
++#ifdef HAVE_LIBGTK
+ curr_stats.gtk_available = 0;
++#endif
+ }
+
+ /* vim: set tabstop=2 softtabstop=2 shiftwidth=2 noexpandtab cinoptions-=(0 : */