aboutsummaryrefslogtreecommitdiff
path: root/misc/wmcalendar
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-04-24 12:04:15 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-04-24 12:04:15 +0000
commit7e891092be59ceff3f230ce02d34c255b174cdb2 (patch)
treeea97c4938015c959921a2fc3485a2e9d583d334e /misc/wmcalendar
parentb909f64beee1921f7730a5b37b381e9cd4c29781 (diff)
downloadports-7e891092be59ceff3f230ce02d34c255b174cdb2.tar.gz
ports-7e891092be59ceff3f230ce02d34c255b174cdb2.zip
New port: wmcalendar: a dockable calendar with interface to iCalendar
based calendars. Submitted by: Alexey Dokuchaev
Notes
Notes: svn path=/head/; revision=79582
Diffstat (limited to 'misc/wmcalendar')
-rw-r--r--misc/wmcalendar/Makefile31
-rw-r--r--misc/wmcalendar/distinfo1
-rw-r--r--misc/wmcalendar/files/patch-Src::Makefile27
-rw-r--r--misc/wmcalendar/files/patch-Src::wmCalendar.c18
-rw-r--r--misc/wmcalendar/pkg-descr4
-rw-r--r--misc/wmcalendar/pkg-plist1
6 files changed, 82 insertions, 0 deletions
diff --git a/misc/wmcalendar/Makefile b/misc/wmcalendar/Makefile
new file mode 100644
index 000000000000..c5ece828dc31
--- /dev/null
+++ b/misc/wmcalendar/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: wmcalendar
+# Date created: 24 Apr 2003
+# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmcalendar
+PORTVERSION= 0.3.6
+CATEGORIES= misc windowmaker
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://freebsd.nsu.ru/distfiles/
+
+MAINTAINER= danfe@regency.nsu.ru
+COMMENT= A dockable calendar with interface to iCalendar based calendars
+
+LIB_DEPENDS= ical.0:${PORTSDIR}/devel/libical
+
+BUILD_WRKSRC= ${WRKSRC}/Src
+
+USE_GNOME= gtk12
+USE_X_PREFIX= yes
+USE_XPM= yes
+
+MAN1= wmCalendar.1
+
+do-install:
+ @${INSTALL_PROGRAM} ${BUILD_WRKSRC}/wmCalendar ${PREFIX}/bin
+ @${INSTALL_MAN} ${BUILD_WRKSRC}/wmCalendar.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/misc/wmcalendar/distinfo b/misc/wmcalendar/distinfo
new file mode 100644
index 000000000000..e0fe611865b4
--- /dev/null
+++ b/misc/wmcalendar/distinfo
@@ -0,0 +1 @@
+MD5 (wmcalendar-0.3.6.tar.gz) = 257e9ff06f3f16cef7bbe7ba0ae7bf32
diff --git a/misc/wmcalendar/files/patch-Src::Makefile b/misc/wmcalendar/files/patch-Src::Makefile
new file mode 100644
index 000000000000..7dd45b2bdaef
--- /dev/null
+++ b/misc/wmcalendar/files/patch-Src::Makefile
@@ -0,0 +1,27 @@
+--- Src/Makefile.orig Thu Apr 24 15:19:02 2003
++++ Src/Makefile Thu Apr 24 15:19:53 2003
+@@ -1,10 +1,10 @@
+ CC = gcc
+-INCLUDES = `gtk-config --cflags` -I.
+-LFLAGS = `gtk-config --libs`
+-CFLAGS = -O2 -Wall -pedantic $(INCLUDES) -DICON_TYPE=$(ICON_TYPE)
+-INCDIR = -I/usr/X11R6/include/X11 -I/usr/X11R6/include
++INCLUDES = `gtk12-config --cflags` -I.
++LFLAGS = `gtk12-config --libs`
++CFLAGS = $(INCLUDES) -DICON_TYPE=$(ICON_TYPE)
++INCDIR = -I${X11BASE}/include/X11 -I${X11BASE}/include
+ DESTDIR= /usr/local
+-LIBDIR = -L/usr/lib -L/usr/X11R6/lib
++LIBDIR = -L/usr/lib -L${X11BASE}/lib -L/usr/local/lib
+
+ # for Linux
+ LIBS = -lXpm -lX11 -lXext -lical
+@@ -17,7 +17,7 @@
+ calendarfunc.o
+
+ .c.o:
+- $(CC) $(CFLAGS) -D$(shell echo `uname -s`) -c $< -o $*.o $(INCDIR)
++ $(CC) $(CFLAGS) -D`uname -s` -DHAVE_SYS_TIME_H -c $< -o $*.o $(INCDIR)
+
+
+ all: wmCalendar.o wmCalendar
diff --git a/misc/wmcalendar/files/patch-Src::wmCalendar.c b/misc/wmcalendar/files/patch-Src::wmCalendar.c
new file mode 100644
index 000000000000..9ab9d60ab593
--- /dev/null
+++ b/misc/wmcalendar/files/patch-Src::wmCalendar.c
@@ -0,0 +1,18 @@
+--- Src/wmCalendar.c.orig Thu Apr 24 16:23:05 2003
++++ Src/wmCalendar.c Thu Apr 24 16:23:15 2003
+@@ -55,6 +55,7 @@
+ -----------------------------------------------------*/
+ void initValues(){
+ int i;
++ XpmColorSymbol colors[2] = { {"Back0", NULL, 0}, {"Back1", NULL, 0} };
+ monthOffset = 0;
+
+ /* Compute widths of months and digits */
+@@ -72,7 +73,6 @@
+ for (i = 0; i < 32; ++i)
+ datetype[i][1] = 0;
+
+- XpmColorSymbol colors[2] = { {"Back0", NULL, 0}, {"Back1", NULL, 0} };
+ dockapp_set_eventmask();
+ dockapp_xpm2pixmap( wmCalendar_master2_xpm, &bg[1], &mask, colors, 0);
+ dockapp_xpm2pixmap( wmCalendar_master_xpm, &bg[0], &mask, colors, 0);
diff --git a/misc/wmcalendar/pkg-descr b/misc/wmcalendar/pkg-descr
new file mode 100644
index 000000000000..cffeb64f3878
--- /dev/null
+++ b/misc/wmcalendar/pkg-descr
@@ -0,0 +1,4 @@
+A dockapp calendar with monthly view and interface to iCalendar based
+calendars like Ximian Evolution or Mozilla calendar.
+
+WWW: http://sourceforge.net/projects/wmcalendar/
diff --git a/misc/wmcalendar/pkg-plist b/misc/wmcalendar/pkg-plist
new file mode 100644
index 000000000000..bf44e33ec6ad
--- /dev/null
+++ b/misc/wmcalendar/pkg-plist
@@ -0,0 +1 @@
+bin/wmCalendar