aboutsummaryrefslogtreecommitdiff
path: root/misc/wminfo/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2004-02-20 20:32:50 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2004-02-20 20:32:50 +0000
commitf4e43742fb0b298b812e65ada5f621873cd6da65 (patch)
treedcabdc8d985f0affe92e79722fc753dc14672734 /misc/wminfo/Makefile
parent0da9c27b867f610a48d235dd85ac45c33a18a9cb (diff)
Notes
Diffstat (limited to 'misc/wminfo/Makefile')
-rw-r--r--misc/wminfo/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/misc/wminfo/Makefile b/misc/wminfo/Makefile
new file mode 100644
index 000000000000..8bd55235f8ac
--- /dev/null
+++ b/misc/wminfo/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: wminfo
+# Date created: 09 February 2004
+# Whom: Thomas Kempka <t.kempka@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wminfo
+PORTVERSION= 1.51
+CATEGORIES= misc windowmaker
+MASTER_SITES= http://kling.mine.nu/files/
+
+MAINTAINER= t.kempka@web.de
+COMMENT= Dockapp to run shell scripts and display the output
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/${PORTNAME}
+
+USE_X_PREFIX= yes
+USE_XPM= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$(LIBS)$$|& $$(OBJS)|g' \
+ -e 's|/usr/X11R6|$$(X11BASE)|g' \
+ -e 's|/share/include|/include|g' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/wminfo ${PREFIX}/bin
+
+.include <bsd.port.mk>