aboutsummaryrefslogtreecommitdiff
path: root/misc/xfce4-appfinder/Makefile
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2019-01-22 14:44:38 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2019-01-22 14:44:38 +0000
commit41ff4e536e680bc94d0949bc7708ddfe6f5646a7 (patch)
tree0b87a1825693d30844e1b681ab080746ab147896 /misc/xfce4-appfinder/Makefile
parentec5f7eb8bb72b6cf44e7b35905514df560d5f22b (diff)
Clenup xfce ports:
- Add missing dependencies - Remove unneeded patches - Regenerate and rename legacy patches - Add NLS option to ports providing such a knob, and missing the option - Add INSTALL_TARGET=install-strip where missing - Sort things - Remove unneeded += - Cosmetic changes to OPTION related variables to improve readability - Update WWW - Silence portlint warnings about variables order - Bump PORTREVISION where changing dependencies and/or adding install-strip
Notes
Notes: svn path=/head/; revision=490953
Diffstat (limited to 'misc/xfce4-appfinder/Makefile')
-rw-r--r--misc/xfce4-appfinder/Makefile29
1 files changed, 18 insertions, 11 deletions
diff --git a/misc/xfce4-appfinder/Makefile b/misc/xfce4-appfinder/Makefile
index b16a0d775f04..c17e76baf3b6 100644
--- a/misc/xfce4-appfinder/Makefile
+++ b/misc/xfce4-appfinder/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xfce4-appfinder
PORTVERSION= 4.12.0
+PORTREVISION= 1
CATEGORIES= misc xfce
MASTER_SITES= XFCE
DIST_SUBDIR= xfce4
@@ -12,22 +13,28 @@ COMMENT= Application launcher and finder
LICENSE= GPLv2
-LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib
+LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
+ libdbus-1.so:devel/dbus \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
-GNU_CONFIGURE= yes
-USES= gmake pkgconfig gettext-tools tar:bzip2
-USE_GNOME= glib20 intltool intlhack
+USES= gettext-tools gmake gnome pkgconfig tar:bzip2 xfce
+USE_GNOME= cairo gdkpixbuf2 glib20 intlhack intltool
USE_XFCE= garcon
-OPTIONS_DEFINE= GTK3 NLS
-GTK3_USES= xfce:gtk3
-GTK3_USE= gnome=gtk30
+GNU_CONFIGURE= yes
+
+OPTIONS_DEFINE= GTK3 NLS
+OPTIONS_SUB= yes
+
GTK3_CONFIGURE_ENABLE= gtk3
-GTK3_USES_OFF= xfce
-GTK3_USE_OFF= gnome=gtk20
-NLS_USES= gettext-runtime
+GTK3_USE_OFF= gnome=gtk20
+GTK3_USE= gnome=gtk30
+GTK3_USES_OFF= xfce
+GTK3_USES= xfce:gtk3
+
NLS_CONFIGURE_ENABLE= nls
-OPTIONS_SUB= yes
+NLS_USES= gettext-runtime
post-patch:
${REINPLACE_CMD} -e 's|=gtk-find|=system-search|' \