aboutsummaryrefslogtreecommitdiff
path: root/misc/xiphos
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2005-06-02 16:53:43 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2005-06-02 16:53:43 +0000
commit90da95b6615d58cff9154218d6beacdf3f753780 (patch)
treee2608f92aaf0420db2b27059525c90fb04d22e14 /misc/xiphos
parenta100f51ce4664b6c2133229c5836e4b3c4dc26a2 (diff)
downloadports-90da95b6615d58cff9154218d6beacdf3f753780.tar.gz
ports-90da95b6615d58cff9154218d6beacdf3f753780.zip
Notes
Diffstat (limited to 'misc/xiphos')
-rw-r--r--misc/xiphos/Makefile8
-rw-r--r--misc/xiphos/files/patch-src-backend-sword_main.diff13
2 files changed, 14 insertions, 7 deletions
diff --git a/misc/xiphos/Makefile b/misc/xiphos/Makefile
index a571d4aeb654..00781741aeb1 100644
--- a/misc/xiphos/Makefile
+++ b/misc/xiphos/Makefile
@@ -40,10 +40,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-BROKEN= "Does not compile (int type mismatch)"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/xiphos/files/patch-src-backend-sword_main.diff b/misc/xiphos/files/patch-src-backend-sword_main.diff
new file mode 100644
index 000000000000..35e1cb29d547
--- /dev/null
+++ b/misc/xiphos/files/patch-src-backend-sword_main.diff
@@ -0,0 +1,13 @@
+--- src/backend/sword_main.cc.orig Thu Jul 1 15:45:30 2004
++++ src/backend/sword_main.cc Thu Jun 2 16:47:23 2005
+@@ -190,8 +190,8 @@
+ VerseKey key;
+ GList *retlist = NULL;
+ char *book = NULL;
+- unsigned int bytes_read;
+- unsigned int bytes_written;
++ gsize bytes_read;
++ gsize bytes_written;
+ GError *error;
+ int i = 0, j = 0, x = 2;
+