aboutsummaryrefslogtreecommitdiff
path: root/misc/xiphos
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2010-10-21 17:36:18 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2010-10-21 17:36:18 +0000
commit8d4d4cd4a9471133c9bd742b14e4a6611c706b16 (patch)
tree5e1ab636ddc0bea7f36de3a7ee9f7b34bb809474 /misc/xiphos
parent653f7f0c60ea3976ae58beb101acca27daf23965 (diff)
downloadports-8d4d4cd4a9471133c9bd742b14e4a6611c706b16.tar.gz
ports-8d4d4cd4a9471133c9bd742b14e4a6611c706b16.zip
Notes
Diffstat (limited to 'misc/xiphos')
-rw-r--r--misc/xiphos/Makefile22
-rw-r--r--misc/xiphos/distinfo6
-rw-r--r--misc/xiphos/files/patch-src__gnome2__utilities.c12
-rw-r--r--misc/xiphos/files/patch-waffles__gnome.py11
-rw-r--r--misc/xiphos/pkg-plist34
5 files changed, 47 insertions, 38 deletions
diff --git a/misc/xiphos/Makefile b/misc/xiphos/Makefile
index db753e4687db..809834f6cef3 100644
--- a/misc/xiphos/Makefile
+++ b/misc/xiphos/Makefile
@@ -6,28 +6,36 @@
#
PORTNAME= xiphos
-PORTVERSION= 3.1.3
-PORTREVISION= 3
+PORTVERSION= 3.1.4
CATEGORIES= misc gnome
MASTER_SITES= SF/gnomesword/Xiphos/${PORTVERSION}
MAINTAINER= tabthorpe@FreeBSD.org
COMMENT= A bible interface utilizing the sword framework
+LICENSE= GPLv2
+
RUN_DEPENDS= ${LOCALBASE}/lib/libsword-1.6.1.so:${PORTSDIR}/misc/sword
BUILD_DEPENDS= ${RUN_DEPENDS} \
+ docbook2html:${PORTSDIR}/textproc/docbook-utils \
gnome-doc-tool:${PORTSDIR}/textproc/gnome-doc-utils \
nspr>=4.8:${PORTSDIR}/devel/nspr
+USE_PYTHON_BUILD= yes
USE_GETTEXT= yes
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
USE_GNOME= gnomehack gnomeprefix gnometarget gnomelibs gtkhtml3 \
intlhack libgsf
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/nspr" \
- LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS+= --disable-maintainer-mode --without-gecko
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./waf configure \
+ --prefix=${PREFIX} --enable-gtkhtml --debug-level=optimized
+
+do-build:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./waf build
+
+do-install:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./waf install
.include <bsd.port.mk>
diff --git a/misc/xiphos/distinfo b/misc/xiphos/distinfo
index 98112ceec0b8..00807648b22c 100644
--- a/misc/xiphos/distinfo
+++ b/misc/xiphos/distinfo
@@ -1,3 +1,3 @@
-MD5 (xiphos-3.1.3.tar.gz) = aaded6bc81b29935edd989d204928ba3
-SHA256 (xiphos-3.1.3.tar.gz) = 345c04d3521239f8e8dff8d0a8447ce6eba6809d22fe699c69a0677894e87b4c
-SIZE (xiphos-3.1.3.tar.gz) = 4405305
+MD5 (xiphos-3.1.4.tar.gz) = 4d6f7805c4c8185f5c4ac3bd95fc705a
+SHA256 (xiphos-3.1.4.tar.gz) = 4a585459e15458509d6a6e4e71a8c8739f8ab27ca913c846bc2a903763103687
+SIZE (xiphos-3.1.4.tar.gz) = 6473885
diff --git a/misc/xiphos/files/patch-src__gnome2__utilities.c b/misc/xiphos/files/patch-src__gnome2__utilities.c
new file mode 100644
index 000000000000..7db06dd03d84
--- /dev/null
+++ b/misc/xiphos/files/patch-src__gnome2__utilities.c
@@ -0,0 +1,12 @@
+--- ./src/gnome2/utilities.c.orig 2010-10-21 11:08:39.000000000 -0400
++++ ./src/gnome2/utilities.c 2010-10-21 11:10:46.000000000 -0400
+@@ -1934,7 +1934,9 @@
+
+ #define IMGSRC_STRING "<img src=\""
+ #define IMGSRC_LENGTH 10 // strlen(IMGSRC_STRING)
++#ifndef HAVE_STRCASESTR
+ const char *strcasestr(const char *haystack, const char *needle);
++#endif
+
+ const char *
+ AnalyzeForImageSize(const char *origtext,
diff --git a/misc/xiphos/files/patch-waffles__gnome.py b/misc/xiphos/files/patch-waffles__gnome.py
new file mode 100644
index 000000000000..dd21da59ea11
--- /dev/null
+++ b/misc/xiphos/files/patch-waffles__gnome.py
@@ -0,0 +1,11 @@
+--- ./waffles/gnome.py.orig 2010-10-15 17:32:41.000000000 -0400
++++ ./waffles/gnome.py 2010-10-21 11:00:42.000000000 -0400
+@@ -216,7 +216,7 @@
+ xsltproc2po = conf.find_program('xsltproc', var='XSLTPROC2PO')
+ conf.env['XML2POFLAGS'] = '-e -p'
+ conf.env['SCROLLKEEPER_DATADIR'] = Utils.cmd_output("scrollkeeper-config --pkgdatadir", silent=1).strip()
+- conf.env['DB2OMF'] = Utils.cmd_output("/usr/bin/pkg-config --variable db2omf gnome-doc-utils", silent=1).strip()
++ conf.env['DB2OMF'] = Utils.cmd_output("pkg-config --variable db2omf gnome-doc-utils", silent=1).strip()
+
+ def set_options(opt):
+ opt.add_option('--want-rpath', type='int', default=1, dest='want_rpath', help='set rpath to 1 or 0 [Default 1]')
diff --git a/misc/xiphos/pkg-plist b/misc/xiphos/pkg-plist
index af5b1e0390e0..6ab04ac94074 100644
--- a/misc/xiphos/pkg-plist
+++ b/misc/xiphos/pkg-plist
@@ -32,8 +32,6 @@ share/gnome/help/xiphos/C/figures/preferences.png
share/gnome/help/xiphos/C/figures/preferences_fonts-color.png
share/gnome/help/xiphos/C/figures/preferences_fonts-misc.png
share/gnome/help/xiphos/C/figures/preferences_general-misc.png
-share/gnome/help/xiphos/C/figures/preferences_general-tabs.png
-share/gnome/help/xiphos/C/figures/preferences_modules-main.png
share/gnome/help/xiphos/C/figures/preferences_modules-misc.png
share/gnome/help/xiphos/C/figures/preferences_modules-parallel.png
share/gnome/help/xiphos/C/figures/search_search.png
@@ -79,8 +77,6 @@ share/gnome/help/xiphos/fa/figures/preferences.png
share/gnome/help/xiphos/fa/figures/preferences_fonts-color.png
share/gnome/help/xiphos/fa/figures/preferences_fonts-misc.png
share/gnome/help/xiphos/fa/figures/preferences_general-misc.png
-share/gnome/help/xiphos/fa/figures/preferences_general-tabs.png
-share/gnome/help/xiphos/fa/figures/preferences_modules-main.png
share/gnome/help/xiphos/fa/figures/preferences_modules-misc.png
share/gnome/help/xiphos/fa/figures/preferences_modules-parallel.png
share/gnome/help/xiphos/fa/figures/search_search.png
@@ -90,17 +86,6 @@ share/gnome/help/xiphos/fa/figures/sword_config.png
share/gnome/help/xiphos/fa/figures/sword_install.png
share/gnome/help/xiphos/fa/figures/sword_remove.png
share/gnome/help/xiphos/fa/figures/sword_sources.png
-share/gnome/help/xiphos/fa/interface.xml
-share/gnome/help/xiphos/fa/introduction.xml
-share/gnome/help/xiphos/fa/journals.xml
-share/gnome/help/xiphos/fa/modules.xml
-share/gnome/help/xiphos/fa/onlinehelp.xml
-share/gnome/help/xiphos/fa/originallanguage.xml
-share/gnome/help/xiphos/fa/personal.xml
-share/gnome/help/xiphos/fa/preferences.xml
-share/gnome/help/xiphos/fa/search.xml
-share/gnome/help/xiphos/fa/start.xml
-share/gnome/help/xiphos/fa/studypad.xml
share/gnome/help/xiphos/fa/xiphos.xml
share/gnome/help/xiphos/fr/figures/first_start.png
share/gnome/help/xiphos/fr/figures/gtkhtml3-vs-mozembed.png
@@ -125,8 +110,6 @@ share/gnome/help/xiphos/fr/figures/preferences.png
share/gnome/help/xiphos/fr/figures/preferences_fonts-color.png
share/gnome/help/xiphos/fr/figures/preferences_fonts-misc.png
share/gnome/help/xiphos/fr/figures/preferences_general-misc.png
-share/gnome/help/xiphos/fr/figures/preferences_general-tabs.png
-share/gnome/help/xiphos/fr/figures/preferences_modules-main.png
share/gnome/help/xiphos/fr/figures/preferences_modules-misc.png
share/gnome/help/xiphos/fr/figures/preferences_modules-parallel.png
share/gnome/help/xiphos/fr/figures/search_search.png
@@ -136,20 +119,11 @@ share/gnome/help/xiphos/fr/figures/sword_config.png
share/gnome/help/xiphos/fr/figures/sword_install.png
share/gnome/help/xiphos/fr/figures/sword_remove.png
share/gnome/help/xiphos/fr/figures/sword_sources.png
-share/gnome/help/xiphos/fr/interface.xml
-share/gnome/help/xiphos/fr/introduction.xml
-share/gnome/help/xiphos/fr/journals.xml
-share/gnome/help/xiphos/fr/modules.xml
-share/gnome/help/xiphos/fr/onlinehelp.xml
-share/gnome/help/xiphos/fr/originallanguage.xml
-share/gnome/help/xiphos/fr/personal.xml
-share/gnome/help/xiphos/fr/preferences.xml
-share/gnome/help/xiphos/fr/search.xml
-share/gnome/help/xiphos/fr/start.xml
-share/gnome/help/xiphos/fr/studypad.xml
share/gnome/help/xiphos/fr/xiphos.xml
+bin/xiphos-nav
share/icons/hicolor/icon-theme.cache
share/icons/hicolor/scalable/apps/xiphos.svg
+share/locale/ar/LC_MESSAGES/xiphos.mo
share/locale/cs/LC_MESSAGES/xiphos.mo
share/locale/cy/LC_MESSAGES/xiphos.mo
share/locale/da/LC_MESSAGES/xiphos.mo
@@ -161,6 +135,7 @@ share/locale/fi/LC_MESSAGES/xiphos.mo
share/locale/fr/LC_MESSAGES/xiphos.mo
share/locale/he/LC_MESSAGES/xiphos.mo
share/locale/hu/LC_MESSAGES/xiphos.mo
+share/locale/ja/LC_MESSAGES/xiphos.mo
share/locale/lv/LC_MESSAGES/xiphos.mo
share/locale/nb/LC_MESSAGES/xiphos.mo
share/locale/nl/LC_MESSAGES/xiphos.mo
@@ -172,6 +147,8 @@ share/locale/ru/LC_MESSAGES/xiphos.mo
share/locale/sk/LC_MESSAGES/xiphos.mo
share/locale/sl/LC_MESSAGES/xiphos.mo
share/locale/sv/LC_MESSAGES/xiphos.mo
+share/locale/tr/LC_MESSAGES/xiphos.mo
+share/locale/zh_CN/LC_MESSAGES/xiphos.mo
share/locale/zh_TW/LC_MESSAGES/xiphos.mo
share/omf/xiphos/xiphos-C.omf
share/omf/xiphos/xiphos-fa.omf
@@ -211,6 +188,7 @@ share/pixmaps/xiphos/sword_icon-16.png
share/pixmaps/xiphos/translation_icon-16.png
share/pixmaps/xiphos/tt.png
share/pixmaps/xiphos/window-close.png
+share/pixmaps/xiphos/xiphos-button-125.png
share/pixmaps/xiphos/xiphos-x-16.png
share/pixmaps/xiphos/xiphos.xpm
%%DATADIR%%/arrow_down.png